Problem with Turkish characters with Winalign
Thread poster: gulperi
gulperi
France
Local time: 20:50
English to French
+ ...
Mar 5, 2008

Hi,

I am trying to align (with TRADOS WINALIGN) an English document with a Turkish one, but while doing so a problem with the Turkish characters occurs once the documents aligned.

« ğ » « ı » et « ş » characters are shown as symbols.

Anyone has managed to solve that problem before? Your help would be much appreciated.

Regards


Direct link Reply with quote
 

Attila Piróth  Identity Verified
France
Local time: 20:50
Member
English to Hungarian
+ ...
Try Wordfast's free add on, PlusTools Mar 5, 2008

Well, this might not be the answer you are looking for. But if you may need to deal with alignment regularly, you should seriously consider dumping WinAlign.
PlusTools is a free add-on to Wordfast, and its alignment module is way better than WinAlign. It's simple and truly intuitive to use. You'll save a lot of time with it in the long run. I have used PlusTools to align Word files in several languages - and accents were always treated correctly.
To be able to use PlusTools you have to install WF - but the trial version is fine for that purpose, so you don't have to pay anything. In such a configuration WF has limited functionality (TM cannot exceed 500 translation units) but not PlusTools.
See a very detailed description of the alignment procedure with PlusTools here.
The TM generated by WF cannot be immediately used with Trados. You may need to edit it - for example using the free TM Editor Olifant (open the WF memory and save it as Trados memory). This manipulation takes two clicks.
HTH,
Attila


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 14:50
Member (2002)
English to Hungarian
+ ...
If you are using Windows XP, this may be the solution Mar 6, 2008

I have had similar problems with Hungarian and Japanese, when I aligned them with English. The reason is that both languages use Unicode and Winalign does not seem to perfectly handle that, so some characters get garbled. I will tell you the setting I check/switch every time I need to align one of these languages.

Here are the steps:
1. Close down all applications as you will need to reboot at the last step.
2. Go to Settings->Control Panel
3. Select Regional and Language Options
4. Go to the third tab, called Advanced.
5. First make sure, that in the list of the Code page conversion tables the checkboxes for Turkish are checked. (10081, 1254, 20905, 857)
6. Above the code page list, there is a pull-down list "Select a language to match the language version of the non-Unicode programs you want to use:". Select Turkish here.
7. Click Apply, and OK.
8. The system will most likely ask you to reboot the machine, so go ahead and reboot.
9. After the computer gained consciousness, launch Winalign and try the alignment procedure.

Let me know if it worked.


Direct link Reply with quote
 
gulperi
France
Local time: 20:50
English to French
+ ...
TOPIC STARTER
Thanks Mar 10, 2008

Many thanks!

I've solved the problem!


Direct link Reply with quote
 
TeamTranslation
Local time: 20:50
Italian to English
Fast solution Oct 15, 2012

Simply save the translation memory as .tmx instead of .txt. It works!

Direct link Reply with quote
 
TeamTranslation
Local time: 20:50
Italian to English
Fast solution Oct 15, 2012

You just have to follow the steps below:
After the alignment has been completed in WinAlign, go to Settings>Project>export> Check Translation Memory Exchange Format (TMX)


Direct link Reply with quote
 

Selcuk Akyuz  Identity Verified
Turkey
Local time: 21:50
Member (2006)
English to Turkish
+ ...
Turkish dotless small i Oct 15, 2012

AFAIR, another similar bug (but in Studio 2009 and 2011) is the Change Case function.

Turkish dotless small i is not correctly converted to UPPER CASE, e.g. Diyarbakır should become DİYARBAKIR but it is converted as DIYARBAKIR

Or DİYARBAKIR should become Diyarbakır not Diyarbakir.

Unfortunately Turkish dotless small i is correctly converted by 3 CAT tools only: Transit, CafeTran and Swordfish (not mentioning CAT tools working on Word, e.g. Trados 2007 WB, Wordfast Classic and Metatexis).


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem with Turkish characters with Winalign

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs