Mobile menu

Adding multiple translation issue in Translator's Workbench
Thread poster: Andy Liu
Andy Liu
English
Mar 13, 2008

I am new to SDL Trados and my question may seems stupid to all of you.

I have built a local TM with serveral TUs and the TM allows multiple translations. Now, I am translating a Word document with the help of Translator's Workbench. TW finds a 100% match TU for a source segment and I want to add a new translation for it. Then, I modify the translation in the target segment and click "Set/Close" button to update my TM. I suppose it will add a new TU but in fact it overwrite the existing TU. I tried to use "Add as new translation" in the Trandos add-ins toolbar and it works perfect.

Also, No custom text and attribute field has been added in my TM.

Does it mean that I can only use "Add as new translation" to add new translation?

Thanks in advanced.


Environment: WinXP SP2, SDL Trados 2007 SP2, Translator's Workbench 8.2.0.835 (Build 835), MS Office 2003 SP3

[Edited at 2008-03-13 10:44]


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 10:42
English to French
+ ...
Options Mar 13, 2008

In Workbench, under Options > Translation Memory Options > General, at the bottom of the window, there is an option called "Do not create new translation units if only text fields differ". If that box is checked, that may be the problem. I'd try unchecking it.

Otherwise, check under Options > Translation Memory Options > Tools to see if the option "Always add new translation unit when target segments differ" is checked. If this is not checked, that may be the problem, so try checking it.

Finally, your TM should also be set up in a way that allows different target segments to exist for the same source segment. When you create the TM, there is an option called "Allow multiple translations for identical source segments". If you did not check this, then your TM most likely won't behave the way you want it to even if you checked the correct options under Options > Translation Memory Options. In case you did not check this option when creating the TM, you can fix this by exporting your current TM, creating a new TM (same settings, like language pair, etc.) where you check the above mentioned option and finally importing the previously exported TM back into the newly created one. You will end up with the same TM you had except that having multiple translations for the same source segment will now be possible (but you will still have to set the other two options above after having created the new TM).

I hope this helps. If you have more questions concerning this issue, please do post again.


Direct link Reply with quote
 
Andy Liu
English
TOPIC STARTER
checked Mar 14, 2008

Thanks Viktoria Gimbe.

I have double-checked the issues you mentioned and all of them are in correct way.

1. "Do not create new translation units if only text fields differ" option (unchecked).
2. "Allows add new translation unit when target segments differ" option (checked).
3. my local TM - Allow Multiple Translations (Yes).

However, "Set/Close" will always update the existing TU instead of add a new TU.

Do you meant that "Set/Close" can also add a new translation (just like "Add as New Translation") if I have the correct settings?

Thx.

[Edited at 2008-03-14 03:08]


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 10:42
English to French
+ ...
Yes, that is correct Mar 14, 2008

Yes, Andy, if the correct settings are used, then using the Set/Close or Set/Close - Open/Get commands are supposed to add a new TU, same source segment but different target segment. I have plenty of source segments with different target segments in my TMs - when you translate into French, this is indispensable, because French heavily relies on gender and number, and because of this, French sentences are full of agreements.

You may already know this (please don't feel insulted if I propose this to you), but I would like to check just in case. In Workbench, when you get a match for a segment, there are left and right arrow buttons at the lower left. Are you using these? Do they turn up results? It may be that you think that you are only updating segments, when in fact you are adding them (Workbench starts by proposing the most recent translation of a source segment, leading you to believe that it has replaced the old TU with the new TU, when in fact the old TU is still there but you would need to scroll to it using the little arrow buttons). Often, when you get a 100% match that you then modify, thereby creating a new TU, the next time you come across the same source segment, Workbench will initially propose the old TU, and you have to "scroll" to the new TU using these little arrow buttons. I am not sure now what determines if it is the new or the old TU that shows up first (I use lots of different settings to have Workbench do exactly what I want, and with such complicated settings, it is hard to see what exactly influences what else), but usually, if you use the settings you seem to be using, that will create new TUs for the same source segment - Workbench usually proposes them all, but not necessarily in the order that is most logical to you.

Please, open a segment that you have modified and that is supposed to have different target segments. Then, use the arow buttons to see if anything turns up when you scroll there.

By the way, are you using text fields? You can set them up in a way that will have Workbench display the right TU when you come across a segment that has several TUs with different translations. It will basically filter out the stuff you don't need, leaving you with only the TUs that you do need (for example, skipping the old translation of a segment and proposing only the new translation, and vice versa). You may want to check that - it can be really helpful.


Direct link Reply with quote
 
Andy Liu
English
TOPIC STARTER
no clue Mar 16, 2008

Viktoria Gimbe, thanks again for your detailed explanation.

I know the usage of these arrow buttons. In fact, I checked my TM with the help of Workbench's "Maintenance" function and found that multiple translation TU can only be added by "Add as New Translation". "Set/Close" will always overwrite the existing target segment with the new one.

I guess something has been overlooked. I will go through all the necessary settings and re-test. Hope it can be fixed.


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 10:42
English to French
+ ...
The use of text fields may explain this Mar 16, 2008

I think the reason why, in my case, Set/Close adds new TUs instead of overwriting the 100% match may be because I use text fields that are different for each document. Because text field values don't match among each of the identical 100% matches, Trados adds a new TU instead of overwriting the existing one.

I am not suggesting you use text fields from now on to fix this particular issue (that would be too complicated for a solution), but you may want to look into it all the same. It is my favorite CAT tool functionality when it comes to TM management, and it is also handy for distinguishing between identical 100% matches as I translate.

All the best!


Direct link Reply with quote
 
Andy Liu
English
TOPIC STARTER
Bingo! Mar 17, 2008

You are right, Viktoria Gimbe. "Set/Close" adds new TU instead of overwriting the existing TU when I use the text field in TW. As text field is a project parameter, it is more convenience for me to use "Add as New Translation" when i need to add multiple translations within the same document.

Thanks a lot for your advice.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Adding multiple translation issue in Translator's Workbench

Advanced search


Translation news related to SDL Trados





Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs