Mobile menu

**Urgent** Filter error: XML format violation - Can't export large file
Thread poster: Claudia Alvis

Claudia Alvis  Identity Verified
Peru
Local time: 01:19
Partial member
Spanish
+ ...
Jan 4, 2008

I'm translating a large file with Transit XV. The file is full of embedded/cross-linked objects, TOCs, so Trados was not an option. When I tried to exported I got a 'Filter error: XML format violation' and the file couldn't be exported. I tried creating a new project with just that file and re-translating the whole document, but I got the same problem. I'm panicking because I don't know what else to do.

The last export log says:

Export Project

Error:

File2 : Spanish :
File2 : Spanish : [Filtering] Filter error: XML format violation. (Line: 1090 Position: 248)


Warnings:

File2 : Spanish :
File2 : Spanish : [Filtering] Warning: XML format violation. (Line: 1 Position: 23)

Please help!

Claudia


Direct link Reply with quote
 

Radek Ptak
Local time: 07:19
English to Polish
Fist w/o translation Jan 4, 2008

Hi,

Solving Urgent problems is very hard on our extremely-fast-moderated forum

Fist of all try to export your project without actually touching it. It will show us if problem is target related or general. So please do Import and then Export and see if you get same error.

Radek


Direct link Reply with quote
 

Andrej  Identity Verified
Local time: 09:19
Member (2005)
German to Russian
+ ...
Correct Jan 4, 2008

Go to the mentioned line and position and correct the error.

Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 01:19
Partial member
Spanish
+ ...
TOPIC STARTER
Screenshot Jan 4, 2008

Hello Andrej,

The problem is that in Line: 1 Position: 23, there's nothing that needs fixing. I don't know if I'm doing this right, I'm in the 4th view, full tags displayed, and the tags in both source and target are the same. I took a screeshot, the position of the cursor at L1P23 is marked in red. I'm thinking that's maybe that's not the same position the log is referring to, but I can't really tell.



Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 08:19
Member (2005)
English to Czech
+ ...
Try Transit diagnostics Jan 4, 2008

What happens when you go Options - Check Formatting Codes?

Antonin


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 01:19
Partial member
Spanish
+ ...
TOPIC STARTER
Thanks for your replies Jan 4, 2008

Radek:

"Fist of all try to export your project without actually touching it. It will show us if problem is target related or general. So please do Import and then Export and see if you get same error."

I pseudo translated the untouched doc, and it came out with no problems, which means I must have broken some tags.

I started over and used the previous project as a reference and it came out with the same error messages I don't know what to do now. I thought I could retranslate the document with the TM, but there's no TM in Transit and I don't know how to do it.

Antonin:

I get all kinds of error messages like , etc. I don't understand why? The tags were supposed to be locked. When I was first translating the doc, I could not always use the Copy Format tool, so I did the format manually. I supposed that was the problem.


Direct link Reply with quote
 

Andrej  Identity Verified
Local time: 09:19
Member (2005)
German to Russian
+ ...
Compare and copy Jan 4, 2008

Compare this line with the original one in order to find discrepancies. The best solution is to copy this line from the original window in Transit or to get back the original line (Ctrl+Alt+Back Space). Then try to export the project once again. BTW I do not understand why you get all the tags in long form. Do you use the layout 2 "Translation" while you are working on the project? And you said it was you who created the project, so you could not lock the tags by accident, could you? Or am I wrong here?

[Edited at 2008-01-04 19:15]


Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 08:19
Member (2005)
English to Czech
+ ...
Check Formatting Codes Jan 4, 2008

Claudia Alvis wrote:
Antonin:
I get all kinds of error messages like , etc. I don't understand why? The tags were supposed to be locked. When I was first translating the doc, I could not always use the Copy Format tool, so I did the format manually. I supposed that was the problem.


Well, the messages should tell you where the culprit is; ideally, there should not be any. You have probably no other way now but go through all the messages and correct the tags which cause them.

You can kind of interfere with tags only if you really know what you are doing.
In my exprience, though, if you do not unlock tags, Transit will only allow changing tags which are not critical for exporting.

I do not exactly undertand what you mean by "did the format manually" - do you know you can copy tags and do you know how to do it?

Antonin

P.S. 1 Transalting from reference will probably not help you since the reference is likely tocontain the broken tag(s)

P.S. 2 If your job is not confidential, you can send me the file to info@otahal.cz (the whole language pair, I mean) and I can try and have a look at it.


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 01:19
Partial member
Spanish
+ ...
TOPIC STARTER
I'll try that Jan 4, 2008

Thank you Andrej,

I'll try that.

Andrej wrote:

BTW I do not understand why you get all the tags in long form. Do you use the layout 2 "Translation" while you are working on the project? And you said it was you who created the project, so you could not lock the tags by accident, could you? Or am I wrong here?

[Edited at 2008-01-04 19:15]


I chose to display the tags just to try to find the differences, where the problem was. I had them shortened when I did the translation, and yes, I worked on layout 2.


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 01:19
Partial member
Spanish
+ ...
TOPIC STARTER
Found the problem not the solution Jan 5, 2008

The problem was---and still is caused by merged segments. Some of the tables have paragraph symbols to divide the lines within the cells. For instance, If the term 'Power Supply' is in a a cell, it shows up as 'Power¶" then below it, 'Supply'. So I merged some of the segments.


Now, here's what I did. I exported the file with the broken tags as a tmx and used it as a reference to translate it again. And it worked, kinda. All the segments were translated automatically, except for the broken segments. I translated them again and kept saving it every couple of hundred segments, making sure the file can be exported. But then again, when I get to some of the segments that need merging, it causes a tag issue like the one above.

Is the tag is supposed to be locked, and I'm making sure both target and source are synchronous for those segments, but still, if I reach certain point, something happens and the file gets ruined again.


Direct link Reply with quote
 

Andrej  Identity Verified
Local time: 09:19
Member (2005)
German to Russian
+ ...
So, the only Jan 5, 2008

solution is not to merge segments, even through it is really annoying to get a "broken translation" in some segments.

Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 08:19
Member (2005)
English to Czech
+ ...
Segment merging Jan 5, 2008

(1) If you imported your Word file yourself, you should have eliminated all unwanted paragraph marks in the Word itself, i.e., before the importing.

(2) If you really must, you can merge segments, but you have to be very careful to do exactly the same in both files of the language pair.

Antonin


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 01:19
Partial member
Spanish
+ ...
TOPIC STARTER
Eliminate paragraph marks Jan 5, 2008

Antoní­n Otáhal wrote:

(2) If you really must, you can merge segments, but you have to be very careful to do exactly the same in both files of the language pair.


As far as I know, that's what I did but since I'm new to Transit I probably left something out. I liked Transit when I first started using it but it's not very intuitive. I mean, there should be an easy way merge complex segments without leaving the marks unprotected.



(1) If you imported your Word file yourself, you should have eliminated all unwanted paragraph marks in the Word itself, i.e., before the importing.

Antonin


That is the logical and simple thing to do ... it completely slipped off my mind. That's what I should have done in the first place. Thanks!

Thanks to Andrej too

Claudia


Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 08:19
Member (2005)
English to Czech
+ ...
"proper" segment merging Jan 5, 2008

In the target file, right-click a segment, choose "Join Segment to Next"; then activate the source file window (by putting cursor into it), uncheck "Read Only" in the "View" menu. Right-click the same segment in the source as you did in the target anfd join it to the next in the same way; re-activate the "Read-Only" protection of the source file; you are done.

Do not unlock the tag protection at all.

Note: after joining a segment, you should close and re-open the language pair - in my experience, the fuzzy index usually needs this kind of refresh step to be usable again.

HTH

Antonin


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 01:19
Partial member
Spanish
+ ...
TOPIC STARTER
Merging Jan 5, 2008

I did all that, I even made sure the cursor was placed at the same place in both languages.

Antoní­n Otáhal wrote:

Note: after joining a segment, you should close and re-open the language pair - in my experience, the fuzzy index usually needs this kind of refresh step to be usable again.

HTH

Antonin


That's very useful, and probably doing that would've solved the problem.

Thanks again.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:

Moderator(s) of this forum
Maya Gorgoshidze[Call to this topic]

You can also contact site staff by submitting a support request »

**Urgent** Filter error: XML format violation - Can't export large file

Advanced search






PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs