Mobile menu

Pages in topic:   [1 2] >
Trados 6.5 problem with accented Hungarian characters while import/export TM
Thread poster: Dr. Janos Annus

Dr. Janos Annus  Identity Verified
Hungary
Local time: 16:02
Member (2005)
English to Hungarian
+ ...
Aug 24, 2008

Dear Collagues, I need an expert advice. I have Trados 6.5. I received an exported TM (English-Hungarian) to be used while translating into Hungarian, which I imported into a new TM. During the process all Hungarian accented characters (ö, á, é, etc.) were replaced by undreadable characters. Therefore the TM when I exported became useless. I tried to change the encoding format of the .txt file, but my Trados did not accept it in Unicode or ANSI format, i.e. it did not import. The original exported TM .txt file was saved in UTF-8 encoding.
The additional text, which I translated, had the correct characters when I exported it. Only the already existing segmenst had this problem.
I would appreciate your expert advice.
Many thanks,
Janos


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 10:02
English to French
+ ...
Try TMX Aug 24, 2008

I have had similar problems before, albeit with French accented characters. I don't know what the standard solution would be, but I fixed my problem by exporting the TM as TMX instead of a text file. That solved the problem for me.

You may want to ask the client for a TMX memory, which may be easier and faster than looking for the "real" solution.

However, I suggest you wait a bit to see if anybody posts. Others may well have the perfect solution - and maybe an explanation on why this problem tends to eventually occur. I'd be curious to know!

All the best!

[Edited at 2008-08-24 22:51]


Direct link Reply with quote
 

Pavel Blann  Identity Verified
Czech Republic
Local time: 16:02
Member (2005)
English to Czech
just convert it correctly Aug 24, 2008

you have to convert the original exported tm .txt from utf-8 to iso-8859-2 (aka iso latin-2) and then import it into trados 6.5, which supports ansi only (see TranslatorsWorkbench_en.pdf)

links: http://en.wikipedia.org/wiki/UTF-8 (includes unicode chars)
http://en.wikipedia.org/wiki/ISO/IEC_8859-2 (ascii/ansi chars)

cheers,
pavel

[Edited at 2008-08-24 23:20]


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 10:02
Member (2002)
English to Hungarian
+ ...
So, which file has the problem? Aug 25, 2008

Janos,
I am a bit confused as to at which point did the character corruption occur.
You said you got an exported TM in .txt (Workbench) format from your client.
I have a few questions:

1. Did the ő and ű characters show up OK in that txt file? (When you opened it with Notepad, for example?)

2. What Trados version did they use to export the txt file?
That is noted in the first line of the txt file.

3. Now, you imported that txt file into your TM, right?
Did the imported segments look OK in Workbench, or were they messed up at this point?
You can check in in Maintenence mode, just browsing through the entries.

4. From your message it seems that you used this TM and added your translations, then exported the updated TM, and then you saw the problem with some of the segments?

Please clarify what happened at each of these steps, and exactly at which point did the corruption occur (if you can pinpoint that).

5. One more question: what is your operating system? Windows XP by any chance?
If the corruption occurred when you imported the txt file, then you can try one thing (actually, you can try it anyway):
Open up your Control Panel, and go to Regional and Language Settings.
Go to the Advanced tab, where there is a field to specify the language to be used with non-unicode programs. Select Hungarian there. You will need to reboot your computer.

Then create a new TM, and try importing the txt file, and see if it is OK now.


Direct link Reply with quote
 

Dr. Janos Annus  Identity Verified
Hungary
Local time: 16:02
Member (2005)
English to Hungarian
+ ...
TOPIC STARTER
Many thanks Aug 25, 2008

Dear Friends,

Many thanks for the many useful advice. I have also tried a few tricks, somehow they did not work.
My Replies to Kati:
1. Did the ő and ű characters show up OK in that txt file? (When you opened it with Notepad, for example?)

YES

2. What Trados version did they use to export the txt file?
That is noted in the first line of the txt file.

THEY USED TRADOS 7, MINE IS 6.5

3. Now, you imported that txt file into your TM, right?
Did the imported segments look OK in Workbench, or were they messed up at this point?

NO, IN THE IMPORTED TM THEY WERE ALREADY CORRUPTED.

4. From your message it seems that you used this TM and added your translations, then exported the updated TM, and then you saw the problem with some of the segments?

AS IS WROTE, THE PROBLEM OCCURED EARLIER. I EXPORTED THE TM AFTER I FINISHED THE TRANSLATION, THE NEW SEGMENTS WERE EXPORTED CORRECTLY (I.E. WITH THE ACCENTED CHARACTERS) BUT THE OLD ONES WITH THE MESSED UP ONES.

5. One more question: what is your operating system? Windows XP by any chance?
If the corruption occurred when you imported the txt file, then you can try one thing (actually, you can try it anyway):

YES, I HAVE WIN XP PRO. THANKS THE ADVICE I WILL TRY IT.

Thanks again... I will work on it.
Janos


Direct link Reply with quote
 

Dr. Janos Annus  Identity Verified
Hungary
Local time: 16:02
Member (2005)
English to Hungarian
+ ...
TOPIC STARTER
Problem solved, thanks to you Aug 25, 2008

Dear Friends,

With the combination of two methods the problems is solved. First I used Kati's suggestion, changed the Unicode Handling to Hungarian. Then converted the exported file (originally saved in UTF-8 encoding) to ANSI, then the importing was perfect.

Many thanks again.
Janos


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 10:02
Member (2002)
English to Hungarian
+ ...
Trados 7 TM export is not backwards-compatible Aug 25, 2008

Dr. Janos Annus wrote:


2. What Trados version did they use to export the txt file?
That is noted in the first line of the txt file.

THEY USED TRADOS 7, MINE IS 6.5


That is the problem.
Trados exports file slightly differently in version 7 and above, an export from 7 is not backwards compatible.
When you do the export, you can see that you have two choices, export as Trados 2.x-6.x version, or Trados 7-8.

I am glad the trick helped, but in general, you should talk to the client before exchanging TM files so you would get the right one. They should be able to export it in Trados 6 format.


Direct link Reply with quote
 

Dr. Janos Annus  Identity Verified
Hungary
Local time: 16:02
Member (2005)
English to Hungarian
+ ...
TOPIC STARTER
Thanks Aug 25, 2008

Many thanks Kati,
great help... as always. I very much appreciate.
Have a good day
JAnos


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 10:02
English to French
+ ...
The moral of the story Aug 26, 2008

Katalin Horvath McClure wrote:

Trados exports file slightly differently in version 7 and above, an export from 7 is not backwards compatible.


I have the latest version of Trados, and every time I am required to produce a TM of my work, I export as 2.x-6.x - and I know this has been helping some of my clients. It is actually a super-lean solution to working on a translation team where everybody has different versions of Trados, and many agencies have trouble figuring this out. If not, why do some of them systematically specify that you have to have Trados 7?

People don't absolutely need to have the same version of the software - suffice to agree on a common export format.


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 10:02
Member (2002)
English to Hungarian
+ ...
That's what I said, too Aug 27, 2008

Viktoria Gimbe wrote:
People don't absolutely need to have the same version of the software - suffice to agree on a common export format.


Yes, that's what I said, too:
talk to the client before exchanging TM files so you would get the right one. They should be able to export it in Trados 6 format.



suffice to agree on a common export format


Yeah, as long as the common export format is the "least common denominator".
If the agency pushes Trados 7-8 format for whatever reason, and don't want to "agree" on 6, then Janos is stuck, because he would need tricks to use the TM (if at all), and the agency (if they are technically challenged) may get a fit about receiving a lower version export...



Direct link Reply with quote
 

Dr. Janos Annus  Identity Verified
Hungary
Local time: 16:02
Member (2005)
English to Hungarian
+ ...
TOPIC STARTER
Thanks and I agree Aug 27, 2008

Thanks for all the comments and help. In my case they did not insist on Trados 7 or higher, but this was just the situation.

I agree with Viktoria, that TMs should be saved in a format that "lower" versions can use it, too. And thanks to Kati, too. She is always so helpful.

Actually I purchased the licence for Trados 7.0, but there were many complaints about its installation in some of the fora here, so I finally did not install it. I wonder if this version is still available for download. Maybe I have to purchase the newest version. It is a shame that the developers make the new versions backward-incompatible. For my purposes Trados 6.5 is totally satisfactory. Why to go to higher and higher? Like the new mobile phones. Hundreds of features I never use. Yet I have to pay for it. Maybe I am wrong.

Cheers
Janos


Direct link Reply with quote
 

Maria Karra  Identity Verified
United States
Local time: 10:02
Member (2000)
Greek to English
+ ...
same problem with Greek Apr 21, 2009

Hi,
I've had a similar problem with Greek for a while and I haven't been able to solve it. I open a segment in a Greek file, and if there's a similar one in the translation memory it comes up in Workbench; but Concordance doesn't work. It doesn't recognize the terms in the open segment. And as soon as I type something in Greek in Concordance and hit Search, it is converted to question marks.
So I did what Katalin suggested, i.e. selected Greek as the language to be used with non-unicode programs (it was English before), and rebooted. With this, concordance works great. Unfortunately, MS Word doesn't. As soon as I open a Greek segment, it all changes to garbled characters. If I click on "Restore source" in word (to keep the original Greek segment without translating it), it is not restored, it's all garbled.
I don't suppose there is a way to make that setting for non-unicode programs apply only to Concordance, right? Any suggestions?


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 10:02
Member (2002)
English to Hungarian
+ ...
What is your system configuration, Maria? Apr 22, 2009

Classic questions for troubleshooting: What is your OS, version of MS Word, version of Trados? Do you only have one version of MS office installed on your computer? Do you have only one version of Trados installed?
Has it ever worked OK?
Does Tageditor work OK when Workbench does this funny thing?
Katalin


[Edited at 2009-04-22 01:31 GMT]


Direct link Reply with quote
 

Maria Karra  Identity Verified
United States
Local time: 10:02
Member (2000)
Greek to English
+ ...
answers Apr 22, 2009

Katalin Horvath McClure wrote:

Classic questions for troubleshooting: What is your OS, version of MS Word, version of Trados? Do you only have one version of MS office installed on your computer? Do you have only one version of Trados installed?
Has it ever worked OK?
Katalin


Hi, Katalin!

OS: WinXP
MS Word 2002
Trados 6.5

Yes, I only have one version of MS office and one version of Trados. It has never worked OK
Is there any hope?


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 10:02
Member (2002)
English to Hungarian
+ ...
Oh boy... Apr 22, 2009

I see, you are using old stuff (OK by me, but...)
I say your best bet is to forget MS Word+Workbench, and use Tageditor.
Tageditor is much better in terms of not messing up things.
I have been using Tageditor for MS Word documents for years now, after many occasions when I was pulling my hair out, trying to fix what stupid Workbench messed up.

Here are three articles from the SDL Trados Knowledgebase that I recommend to read.
1:
http://talisma.sdl.com/display/2n/kb/article.aspx?aid=1904&n=6&s=1

This one describes a problem similar to what you have now, after setting the non-Unicode language, except that this talks about Greek as the target language, and I understood you were translating FROM Greek, when this happened.

2:
http://talisma.sdl.com/display/2n/kb/article.aspx?aid=1740&n=5&s=1

In this one, the important point is to check what languages you have selected for support, and remove the unnecessary ones. At least, to try if that is the conflict. I am not sure where to find the Microsoft Office Language Settings on Office 2002 - I have 2007, and it has its own menu item under Programs->MS Office->MS Office Tools.

3:
http://talisma.sdl.com/display/2n/kb/article.aspx?aid=2095&n=8&s=1
This one requires you to edit the registry. It sounds scary, but it is not that bad. I remember this was the solution once way back when I had character corruption problems with Trados 6.5. (In fact I think I have a considerable part of having this article in the Knowledgebase - I had an intensive and extensive email exchange with Trados support about this and we tested the issue together.) I don't think it would apply to you, but as a last resort, it is also something to try.

The very last-last resort is to ask Trados support - although the very first knee-jerk response would probably be an upgrade...

Anyway, try Tageditor, you may be pleasantly surprised.
Katalin


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:

Moderator(s) of this forum
Maria Castro[Call to this topic]

You can also contact site staff by submitting a support request »

Trados 6.5 problem with accented Hungarian characters while import/export TM

Advanced search


Translation news





SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs