"check spelling as you type" feature in MS Word not powerful enough
Thread poster: Simon Bruni

Simon Bruni  Identity Verified
United Kingdom
Local time: 19:50
Member (2009)
Spanish to English
Sep 20, 2006

Dear Colleagues,

I rely heavily on the “check spelling as you type” feature in MS Word’s spellchecker (the one that underlines typos in red). I am a fairly wild typist so it really does help to have the right mouse button function to select correctly spelled words. Unfortunately, with large texts it tends to stop checking some way into the translation. I think it’s partly to do with having two languages on the page, as this gives the checker more “wrong” spellings and overloads it (particularly when using CAT).

Does anyone know any way around this problem or know of a more powerful tool that I could use?

Thanks in advance

Simon


Direct link Reply with quote
 

Marijke Singer  Identity Verified
United Kingdom
Local time: 19:50
Dutch to English
+ ...
Detect language automatically Sep 20, 2006

You could try selecting Detect language automatically under Tools -> Language -> Set language.

Once you have set it, the setting will apply to any document you open until you deselect it again.


Direct link Reply with quote
 

Simon Bruni  Identity Verified
United Kingdom
Local time: 19:50
Member (2009)
Spanish to English
TOPIC STARTER
Thanks Marijke Sep 20, 2006

I already have "detect language autimatically" selected, and unfortunately the target language is still being underlined in red (i.e., the computer corrects it using the source language dictionary).

Thanks very much anyhow!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:50
Member (2003)
Polish to German
+ ...
Select the proper language Sep 20, 2006

Deactivate the "Automatic language detection", as this does spoil more than it helps.
In document styles change the language to your target language.
Then select the whole document and via Tools - Language select once again the desired language you translate into.
This will tell the spell-checker (which is quite powerfull) which language should it use.

Should your document be longer and you get an error "To many spelling errors", you can select the whole document again, select the proper language and check the box "Do not spell check". Then select only a part of the document you are currently working on and uncheck this box ONLY for that part of the document.

Regards
Jerzy


Direct link Reply with quote
 
pidzej  Identity Verified
Poland
Local time: 20:50
Polish to English
+ ...
not quite, Jerzy Sep 20, 2006

Jerzy Czopik wrote:

Deactivate the "Automatic language detection", as this does spoil more than it helps.
In document styles change the language to your target language.
Then select the whole document and via Tools - Language select once again the desired language you translate into.
This will tell the spell-checker (which is quite powerfull) which language should it use.

Should your document be longer and you get an error "To many spelling errors", you can select the whole document again, select the proper language and check the box "Do not spell check". Then select only a part of the document you are currently working on and uncheck this box ONLY for that part of the document.

Regards
Jerzy


selecting the target language and unselecting automatic detection practically guarantees that Spellcheck will refuse to work due to "too many errors" in any text of more than say five pages. in other words, it de facto disables the "check spelling as you type" faculty. so that does not solve the asker's dilemma.
as for adding target language to style, it only makes sense if you only translate one way, which for many is not an option, and again would only work with short texts.
I once wrote a Word macro that did the trick: at the end of paragraph, instead of Enter, I hit a combination of keys (Control + . ) that: caused a period to be inserted, caused a paragraph break to be inserted anyway, selected the next paragraph of text, selected the target language, unselected the text and returned the cursor to the start of that next paragraph. that worked fine with automatic language selection inactive and "check spelling as you type" on.
my Word copes with automatic language detection but it--and presumably everybody else's--fails miserably when it has to guess if I want British or American spelling. that halfwit always assumes it is American. If you have a tip for - temporarily - removing or disabling US English (or UK English at other times) from the list of available languages so it would stop making those silly guesses, I would really be grateful.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:50
Member (2003)
Polish to German
+ ...
Well, this covers not exactly with my experience, though Sep 20, 2006

And it depends strongly on how do you translate.
I mostly use Trados and indeed I change the language of the whole text to my target language.
First of all I adapt styles, and the first thing I adapt is the language.

BTW, the macro you wrote does exactly the same task as I described above - selects a part of the text and selects then the proper - target - language for this chunk of the text.

Auto-selecting language does not do the trick, in fact it spoils really more - as it causes the keyboard language to be switched. In order to get rid of this you would need to deselect the automatic keyboard language selection - but this is a nice feature, which I prefer to have switched on.

There is no patent solution for every situation - you simply need to know how each feature works and chose the best solution for your current situation.
But the spell checker works certainly well with files even over 10 pages. Usually I get the error message when the file has more than 3k words.

Regards
Jerzy


Direct link Reply with quote
 

Henry Hinds  Identity Verified
United States
Local time: 12:50
English to Spanish
+ ...
Usually Works Sep 21, 2006

I can usually get it to work OK as Jerzy says, just select the text and reset the language to the target. Also make sure it is set to "show spelling errors" or whatever that little box is.

It bothered me at first, but once I tried doing the above, no problem. If it gives you more trouble, then just repreat the above and it should work.


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 20:50
Member (2006)
English to Afrikaans
+ ...
Mark checked text as "do not check" Sep 21, 2006

Simon Bruni wrote:
Unfortunately, with large texts it tends to stop checking some way into the translation.


Mark the entire document as "do not check" at the beginning, then mark the first couple of pages as your language. MS Word will then spellcheck only those pages. When you reach the pages that aren't being spellchecked, just mark the top pages as "do not check" and mark the next few pages as your language. Instead of "do not check" you can also mark the pages as some language that is not installed on your computer.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:50
Member (2003)
Polish to German
+ ...
@Samuel Sep 21, 2006

This is exactly what I tried to describe above - thank you!
Extremly well put, this is exactly how you can get Word to spell check very large documents, partially translated. Extremly usefull, when working with Trados for example, where both source and target text remain in the document.

Best
Jerzy


Direct link Reply with quote
 

Simon Bruni  Identity Verified
United Kingdom
Local time: 19:50
Member (2009)
Spanish to English
TOPIC STARTER
Thank you very much Sep 21, 2006

Thank you very much for the advice everyone.

I am currently working on some 8,000-word documents, but I'm not far enough in for the spellchecker to fail yet. I will implement the method described by Jerzy and Samuel, which seems logical and fail-proof, when it does happen.

Thanks again for your info.

Simon


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 20:50
Member
French to English
+ ...
Has anyone tried doing it this way? Sep 21, 2006

I can't say for sure if this works or not, as I haven't been able to try it out, but I have used a similar dodge in the past.

BEFORE starting to translate using a CAT, select all text and set to 'do not check spelling'

THEN make sure that your 'normal' style is set up with your target language + DO check spelling

THEN start translating, using the 'normal' style (or of course any other styles you may have thus set up)

This way, ONLY the translated target segments will be checked.

By the way, does anyone know what an odded dotted red underline means in Word? This is not the usual 'wiggly' 'query spelling' underline (not least because that function is turned off!), but I seem to get it occasionally with certain docs only, usually on unusual expressions, and as soon as I do any typing within them, it goes and doesn't come back.


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 20:50
Member (2004)
English to Slovenian
+ ...
an orthogonal Point of View Sep 21, 2006

... with large texts it tends to stop checking some way into the translation....


This means that you have a big chunk of the translated text (bilingual) in a wishy-washy form, specifically not just in the file itself, but in the translation memory as well.

That sort of goes against my grain - the translation memory should clean as a whistle, or at least close to this condition. Think of getting to 25% and you know you have 50% repeats. You can either:

1. pretranslate and then translate to the end - correcting the existing typos on the way etc, or

2. correct the spelling within 25% and the pretranslate to end up with the rest of the document without those ugly wiggly red lines.

regards

smo


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 21:50
Member (2003)
Finnish to German
+ ...
Happens only when the wrong language is selected Sep 21, 2006

I have translated fairly large documents with CAT tools and never any problem with the too many errors prompt. More than 100 pages at least.
But for VERY large documents one could split the file to solve the problem, if it occurs.


[Bearbeitet am 2006-09-21 12:17]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:50
Member (2003)
Polish to German
+ ...
SmartTAG most probably Sep 21, 2006

Tony -Dusty- wrote:

I can't say for sure if this works or not, as I haven't been able to try it out, but I have used a similar dodge in the past.

BEFORE starting to translate using a CAT, select all text and set to 'do not check spelling'

THEN make sure that your 'normal' style is set up with your target language + DO check spelling

THEN start translating, using the 'normal' style (or of course any other styles you may have thus set up)

This way, ONLY the translated target segments will be checked.

By the way, does anyone know what an odded dotted red underline means in Word? This is not the usual 'wiggly' 'query spelling' underline (not least because that function is turned off!), but I seem to get it occasionally with certain docs only, usually on unusual expressions, and as soon as I do any typing within them, it goes and doesn't come back.

If you point with the mouse to the start of such aprticular word, an drop-down field should appear. This is a SmartTAG.

Regards
Jerzy


Direct link Reply with quote
 
Abe4
English
thanks Oct 31, 2006

Hello everyone out there. I was also suffering with the problem. Thanks for your suggestions. Its working man. Thanks a lot.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:

Moderator(s) of this forum
Maria Castro[Call to this topic]

You can also contact site staff by submitting a support request »

"check spelling as you type" feature in MS Word not powerful enough

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs