Keyboard does not type the correct letter
Thread poster: Waleed Mohamed

Waleed Mohamed  Identity Verified
United Arab Emirates
Local time: 08:56
English to Arabic
+ ...
Sep 12, 2008

Hello,
Could someone please help. When I type certain keys on my laptop, the wrong letter wrong number comes up. For example if I try to type the letter o the number six will show up on the lcd. . Does any one know how to fix this?

I have Win XP Pro with SP2

Thanks in advance for your kind help!

Waleed


Direct link Reply with quote
 

AniseK  Identity Verified
Malaysia
Local time: 12:56
Japanese to English
+ ...
Chack your keyboard setting Sep 12, 2008

Hi,

I'm not sure what your OS language is, so this is just a suggestion. You can check the keyboard and language setting in your control panel. Sometimes toggling these two setting can correct the problem.

Usually the keyboard is set as a standard. If you are using other types of keyboard, then you may need to refer to your manual or online support.

Good luck.


Direct link Reply with quote
 

Henry Hinds  Identity Verified
United States
Local time: 22:56
English to Spanish
+ ...
Try this Sep 12, 2008

Press "Shift" and "Alt" simultaneously and see what happens. This changes keyboard language settings if that is the problem.

Direct link Reply with quote
 
xxxmediamatrix
Local time: 00:56
Spanish to English
+ ...
Function key? Sep 12, 2008

Waleed Mohamed wrote:

... For example if I try to type the letter o the number six will show up on the lcd. . ...


The same thing would happen on my laptop if I held down the [Fn] key and typed 'o' - it would display '6'. The [Fn] key switches the keyboard into numeric keypad mode, and letter 'o' and number '6' are on the same key. Likewise, 'i' would display '5', etc.

If you are not using the [Fn] key deliberately, maybe it has got stuck...?

MediaMatrix

[Edited at 2008-09-12 01:47]


Direct link Reply with quote
 
Tracey  Identity Verified
Mexico
Local time: 23:56
French to English
+ ...
Numerical keypad Sep 12, 2008

Maybe you've accidentally turned on your keyboard's embedded numerical keypad. I have an HP laptop and the "o" key is also the number 6 on the embedded keypad. You need to press the "fn" button and a button which says something like "num lk" at the same time to turn it off. My "num lk" key is at the top of the keyboard. Hope this helps.

Direct link Reply with quote
 

Manal chreidah  Identity Verified
Local time: 06:56
German to Arabic
+ ...
restart Sep 12, 2008

Hello,

it happened to me once, I typed a certain letter (especially in Arabic, my operating system is in German) and i got another letter on the monitor. I just restarted my PC and the problem disappeared, it is mysterious

Best wishes and Ramadan Kareem


Direct link Reply with quote
 

mariale125
Local time: 23:56
English to Spanish
Another option Sep 12, 2008

Check in your Control Panel as Anisek recommends you. There is an option in language settings where you can set up a new key combination for changing your keyboard language or at least you can see the default combination if you don't know which one is it.

In my laptop (Toshiba) pressing "Control" and "Shift" does the trick.

Hope you'll find the solution soon!


Direct link Reply with quote
 

Alvin Liu  Identity Verified
China
Local time: 12:56
Member (2007)
English to Chinese
+ ...
Definitely you enabled the Numerical keypad Sep 14, 2008

Hi Waleed,

You definitley have enabled the numerical keypad unconsciously. You can check this by seeing whether the NumLock indicator on the keyboard is on.

Normally, you can enalbe/disable numerical keypad by press Fn and NumLock keys simutaneouly. For IBM laptops, press Shift and NumLock keys.

Hope this helps.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Keyboard does not type the correct letter

Advanced search






CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs