Windows keeps switching languages randomly
Thread poster: Marina Aleyeva

Marina Aleyeva  Identity Verified
Ukraine
Local time: 07:56
English to Russian
+ ...
Jul 25, 2007

I use a (recently reinstalled) Windows XP HE SP2 and have three languages currently on my language panel (English, Russian and Ukrainian). Whatever I do, Windows (or is it something else that does it?) keeps switching languages randomly. For example, if I copy and paste a Russian search phrase in the Google search box and then need to add quotation marks before and after it, what I do is type the first quotation mark using Cyrillic keyboard layout (i.e. by pressing Shift+2), but when I go to the end of the phrase to put the closing mark, the language is suddenly changed to English and what is typed is @ instead of ".

Language switching happened twice as I was typing this forum post (unrelated to the use of quotation marks), and it keeps happening all the time when I go from segment to segment in Word, type emails, and even use Notepad.

It is so annoying!!

Any ideas how to fix it - once and for good?

Thanks!

[Edited at 2007-07-26 02:24]


Direct link Reply with quote
 
xxxmediamatrix
Local time: 00:56
Spanish to English
+ ...
Windows shortcuts? Jul 25, 2007

On my system (set up for eng/UK, eng/US, spa, fre and rus) I would have a similar problem if any of my languages required me to use "Left-alt + shift", which is the default Windows shortcut to switch to the next language in the list.

To check (or modify or remove) the shortcuts on your system, right-click the language icon (status bar) - Settings - Advanced Key Settings.

HTH
MediaMatrix


Direct link Reply with quote
 

Marina Aleyeva  Identity Verified
Ukraine
Local time: 07:56
English to Russian
+ ...
TOPIC STARTER
Re: Windows Shortcuts Jul 26, 2007

Thanks mediamatrix - In my previous Windows installation I used left Alt+Shift to switch between languages and had no problem. I now use Ctrl+Shift because it is easier on my fingers and have all these switching problems although I am unsure what the real cause is.

Direct link Reply with quote
 

Stefan Keller  Identity Verified
Germany
Local time: 06:56
English to German
Shortcut Jul 26, 2007

Marina Aleyeva wrote:
I now use Ctrl+Shift because it is easier on my fingers


... and easier to be triggered accidentally. Are you sure you don't switch languages yourself by accidentally pressing Ctrl+Shift?


Direct link Reply with quote
 

Marina Aleyeva  Identity Verified
Ukraine
Local time: 07:56
English to Russian
+ ...
TOPIC STARTER
Thanks Stefan and mediamatrix! Jul 26, 2007

You both were right - seems it happens accidentally the moment my fingers move from Shift (capitalising and inserting quotation marks) to Ctrl (moving between words). Plus Ctrl+Shift is also a Windows shortcut for selecting words which I also use extensively. I think I will have to go back to Shift + Alt - alas...

Thanks again for your help!

[Edited at 2007-07-26 13:32]

[Edited at 2007-07-26 13:47]


Direct link Reply with quote
 

Dorota Cooper  Identity Verified
United Kingdom
Local time: 05:56
English to Polish
+ ...
Arabic Mar 13, 2008

Reviving this thread as I seem to have a more complex version of this problem. I'm running Win XP HE, the default languages were Polish and English. I enabled Arabic in addition to those through Regional Settings and since then my language settings have been completely messed up. Although my language bar shows Polish as the language in use, I have the following problems:

- When I first log into Windows on system startup, the login scren works OK, but on the following logins (after screensaver's kicked in/hibernation etc.) I have to use Ctrl-Shift to switch languages
- I also have to switch every time I open an application - I open Word, switch the language (all the while the changes don't show on the language bar), close Word, open it again and have to switch again. Repeat for any application that requires typing...

Of course my first reaction to all this was to go back to Regional Settings and disable Arabic, however it didn't make any difference. I have tried disabling all keyboard layouts but one and it still didn't help.


Direct link Reply with quote
 
Barranco
Spain
Local time: 06:56
German to Spanish
+ ...
Right-to-left text direction shortcut Mar 14, 2009

Maybe the setting does not apply to all of Windows, but to Microsoft Office programs only?

Even if you have removed the support for right-to-left scripts in "Control Panel - Regional and language settings", MS Office might still be "supporting" you with the Ctrl+Shift shortcut.

To remedy this, please consider doing the following:
1. Go to the Microsoft Windows Start menu
2. Point to Programs | Microsoft Office Tools | Microsoft Office XP Language Settings.
3. From there, remove any right-to-left language you are not using any more.

I hope this helps.


[Edited at 2009-03-14 14:55 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Windows keeps switching languages randomly

Advanced search






BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs