Boost your career as a professional translator!

Boost your career as a professional translator! SDL hosts a virtual conference featuring a selection of free resources to help grow your freelance business, as well as an update on the new features of the world’s most trusted translation software - SDL Trados Studio 2017

Click for Full Participation

Wordfast beginner, some questions
Thread poster: Olivier Milla

Olivier Milla  Identity Verified
Local time: 16:51
English to French
May 18, 2008

Conf: Wordfast 5.52z & Word 2007

Hi,
I've given Wordfast a try and after some 10 000 words trying it with constant tweaking searching, trying, FAQ reading, there's still some stuff I can't get right so I'd like to ask all you gurus for some input. So, here are my questions :

- The fact that target segments aren't considered to be in French (my target language) right at the segment opening really annoyed me. I always have to start typing french before Words realize that my sentence is in French and stops underlying everything I type. Is there anything I can do to get the proper behaviour ?

- Wordfast never shows me any other match percentage than 0% or 100%. And so to a ridiculous point. For instance, there is the sentence "Some of Tracker's feature :" in my TM with it's associated target. now when I hit a few lines later "Some of Deskbar's feature :". I get a 0% match! What's wrong ?

- Wordfast changes some formatting : Because I didn't know, I didn't put ";" in the list of characters to be considered as "possible end of segment" and so many lists of my document which were looking like
" - A is the best ever ;
- B is catching up on A ;
- C is a lazy runner ;"

were considered as one unique segment. I translated them anyway, respecting in the target segment this formatting. But Wordfast said no, and changed formatting to " - A is the best letter ever ; - B is catching up on B ; - C is a lazy runner ;" in the target segment. While I understand my mistake and will not make it again, I find it strange that Wordfast figures such matters out by itself. Anything I can do about that ?

OK, I think it's enough for my first newbie serie. Thanks a lot for your input.

Olivier


Direct link Reply with quote
 

Iza Szczypka  Identity Verified
Spain
Local time: 16:51
English to Polish
+ ...
Hints May 18, 2008

- Target language: when creating a TM, did you specify the target language as French, using the code to be found in the manual?
- Percentages: in the Setup, you probably still have the percentage given as 100. Enter the Setup, doubleclick the line specifying Fuzzy treshold, and manually replace 100 with anything down to 50 (minimum accepted by WF). With French, which AFAIK has gender endings same as Polish, I'd say 50% is advisable to get round the gender differences while searching TM. The obvious disadvantage would then be ridiculous search results at times, but to me it's worth it.

[Edited at 2008-05-18 22:07]


Direct link Reply with quote
 

Olivier Milla  Identity Verified
Local time: 16:51
English to French
TOPIC STARTER
Thanks May 20, 2008

Hello Iza,
Thanks for your reply.

I did set up the french language correctly. Actually my description of the problem was not accurate. What happens is when you copy & paste text from the source segment to the target segment, Word seems to copy the language setting along and so when you get back to typing, what you write is considered to be in the source language. So Wordfast is in fact innocent.

About setting up the fuzzy threshold to 50%, that did it, it's just great, thanks a lot!

ciao,

O.


Direct link Reply with quote
 

Marie-Hélène Hayles  Identity Verified
Local time: 16:51
Italian to English
+ ...
That's normal May 20, 2008

unam_fr wrote:

What happens is when you copy & paste text from the source segment to the target segment, Word seems to copy the language setting along and so when you get back to typing, what you write is considered to be in the source language. So Wordfast is in fact innocent.


Don't worry about it - when you then click down to the next segment, WF will re-set the previous segment to the correct language, there's no need to re-set it manually. If it irritates you, there are two ways of avoiding it:

1) On the WF tool bar, use the second from left button to copy the source - it will transfer the source segment but leave the language as the target language;

2) If you just want to copy a couple of words (a name, or whatever), then type a space in the target segment and then paste your source text before the space - then use the right arrow or mouse click to get back to the other side of the space, where you'll be back in the target language.

These are both quicker than manually re-setting the target language, although it's only really necessary if you have autocorrect on in your Word settings (which I wouldn't advise anyway).

[Edited at 2008-05-20 12:01]


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 16:51
Member (2006)
English to Afrikaans
+ ...
Yes, but that is a function of Word, not Wordfast May 21, 2008

unam_fr wrote:
What happens is when you copy & paste text from the source segment to the target segment, Word seems to copy the language setting along...


Yes. That is the normal behaviour in MS Word. If you copy text with any type of character formatting, the character formatting is retained when you paste it. And the language setting is set per character. Ditto if you copy something in bold, in italics, in a different font etc -- the formatting is retained when you paste it.

What you can do, is to do a "Edit -> Paste special" and select "Unformatted text". Then the pasted text will inherit the formatting of the text where you paste it. A quick way to do this is to install AndoTools and select the setting in it that allows you to paste unformatted text using a single keyboard shortcut.


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 16:51
Member (2006)
English to Afrikaans
+ ...
Soft returns, perhaps? May 21, 2008

unam_fr wrote:
- Wordfast changes some formatting : Because I didn't know, I didn't put ";" in the list of characters to be considered as "possible end of segment" and so many lists of my document which were looking like
" - A is the best ever ;
- B is catching up on A ;
- C is a lazy runner ;"
were considered as one unique segment. I translated them anyway, respecting in the target segment this formatting. But Wordfast said no, and changed formatting to " - A is the best letter ever ; - B is catching up on B ; - C is a lazy runner ;" in the target segment.


Sometimes authors of documents use soft returns instead of hard returns. Wordfast will break a segment on hard returns, but not soft returns. If you don't include a soft return in your translation, then there will be no return.

To see hard and soft returns, click the paragraph sign in your MS Word toolbar (the one that displays all spaces as little dots). See how the soft return looks different from a hard return. I can't remember how to make a soft return... Shift+Enter, I think.


Direct link Reply with quote
 
Déesse
Local time: 16:51
French to Dutch
+ ...
Sorry to give the thread a bump! May 26, 2010

I've been searching in vain to find out how I can make Wordfast 5.61 end a segment on a soft return. I've got a couple of Excel files that need to be translated, and the author used alt + return all the way through the document. If I could make Wordfast end the segment after a soft return, I would have 25 % matches, while it only gives me 4 % now. Does anybody have a clue? Thanks!

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast beginner, some questions

Advanced search


Translation news related to Wordfast





SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums