Mobile menu

Numbers lost during translation in Excel
Thread poster: Marek Daroszewski (MrMarDar)
Marek Daroszewski (MrMarDar)  Identity Verified
Local time: 13:19
English to Polish
+ ...
Jul 1, 2008

I've been using WF successfully for ca. 4 years with Excel and PowerPoint and just now ran into a problem (or actually realized that there is a problem).

I found that WF changes numbers in the cells, e.g. the original cell contains 61,2352941176471% (cell formatting is percentage) which shows on the screen as 61%. In the translation process the value copied into Word is 61%, i.e. all digits after the decimal point are lost. Consequently, when the segment is 'translated' and copied back into Excel the fraction is lost. IMHO this is a serious bug.

It is bad enough to have to copy the number from source segment to target segment (Pandora Box CopySourceWhenNoMatch setting does that).

But changing cell contents with numbers is a disaster!

I went through the manual and forum posts but could not find anything useful.

Has anyone found a way out? Is there a setting which would tell WF to ignore cells with numbers altogether, actually without propagating the contents into Word and then back into Excel? Is there a setting I should use to keep the whole number, i.e. with the fraction?

Any help much appreciated.

System: WF 5.22u1, Word, Excel 2002, Vista Premium

Direct link Reply with quote
Ken Cox  Identity Verified
Local time: 13:19
German to English
+ ...
nasty problem Jul 1, 2008

IMO this is probably not the fault of WF, but instead due to how data is exported from Excel to other Office applications. The same effect occurs if you copy cells containing numbers displayed in truncated form on an Excel worksheet and paste them in a Word document. Whether it is possible to access the true numbers on the worksheet is a good question for MS technical support.

I suppose that the only easy way to deal with this is to select the relevant cell(s) on the Excel worksheet and set the number of decimal places to a suitable value before you start translation, and then restore the setting afterwards.

Good fun

PS: exporting the Excel worksheet in CSV format might also work (I haven't tried this), but even if it does it's not a particularly practical solution if the WS has complex formatting (conversion back to Excel could be difficult).

[Edited at 2008-07-01 12:14]

[Edited at 2008-07-01 12:15]

[Edited at 2008-07-01 12:21]

Direct link Reply with quote
Marek Daroszewski (MrMarDar)  Identity Verified
Local time: 13:19
English to Polish
+ ...
easiest solution Jul 1, 2008

The easiest solution would be to have a setting / hot-key / etc. which would ignore a given segment and move to the next one.

This would also solve the problem of translating bilingual Excel and PP files (which I do quite a lot). Wishful thinking though.

Anyway - I am really upset that the problem of changing cells without one's knowing about it is not mentioned in WF manual as a warning.

And yes - the sheets are heavily formatted, so I don't think conversion to another format would do the trick.

So far it just drives me nuts


Direct link Reply with quote

To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

Numbers lost during translation in Excel

Advanced search

Translation news related to Wordfast

The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
Want to earn more in your spare time? Monetize your knowledge!

Do you speak one or more foreign languages? Fluency in target language + willingness & ability to help people in everyday situations could earn you $45 / hour. Download “Quiick Angel” app & become a guardian angel today

More info »

All of
  • All of
  • Term search
  • Jobs