Unicode error
Thread poster: Edward Potter

Edward Potter  Identity Verified
Spain
Local time: 13:03
Member (2003)
Spanish to English
+ ...
Aug 12, 2008

When I hit the WordFast function button I get the following error:


Is in Unicode UTF-8 format.

Please open that file with a text editor (like Notepad) and use 'File / Save as...' to save it as either Unicode or Unicode-16, then try again.



So, I opened up the TM with Notepad and saved it as Unicode (or so I thought). It still wasn't working right so I figured I'd start from scratch, trashing the Unicode UTF-8 memory and the Unicode memory. After doing this I got the same error, so I restored the trashed files, but I cannot access the WordFast functions at all because this error is blocking me from getting in.

I suspect I might have to reinstall WordFast if I can't find a way to load in another memory.

Can anyone help?


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 14:03
Member (2006)
English to Russian
+ ...
Use a _good_ text editor! Aug 12, 2008

Such as jEdit, UniRed etc. that allows choosing the encoding explicitly. That's the answer.

Direct link Reply with quote
 

Edward Potter  Identity Verified
Spain
Local time: 13:03
Member (2003)
Spanish to English
+ ...
TOPIC STARTER
Not working Aug 12, 2008

It does not identify any file name. It basically hangs up when I try to get into the WordFast functions. The only thing I can do is click on "OK" and I'm back in Word.

I tried reinstalling but that hasn't worked.


Direct link Reply with quote
 

Edward Potter  Identity Verified
Spain
Local time: 13:03
Member (2003)
Spanish to English
+ ...
TOPIC STARTER
Problem solved: I tried saving it again as Unicode with Notepad Aug 12, 2008

I went and saved the TM "one last time" as a Unicode file.

Apparently I had not saved it as Unicode before and it was still saved as Unicode UTF-8.


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 13:03
Member (2006)
English to Afrikaans
+ ...
Can't help, but... Aug 13, 2008

Edward Potter wrote:
Apparently I had not saved it as Unicode before and it was still saved as Unicode UTF-8.


There is an overlap between UTF8 and Latin-1, which is why you think you save as one encoding but another program opens it as if it was in another encoding.

But... you're doing English and Spanish. There is no need for you to use a Unicode TM in Wordfast, unless I'm mistaken.


Direct link Reply with quote
 

Edward Potter  Identity Verified
Spain
Local time: 13:03
Member (2003)
Spanish to English
+ ...
TOPIC STARTER
Not mine Aug 13, 2008

The TM was created by someone else. And yes, this shouldn't be an issue if you are only using Latin character based languages.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Unicode error

Advanced search


Translation news related to Wordfast





Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs