Mobile menu

Importing non-breaking hyphen from Wordfast into Trados
Thread poster: hprescott
hprescott
German to English
Nov 4, 2008

I have a Wordfast TM (txt) with non-breaking spaces and hyphens that I want to import into Trados 8.

When I convert the Wf txt file into a tmx with Wordfast, all the non-breaking spaces and hyphens are deleted.

Olifant recognizes the Wordfast non-breaking spaces coding (&'A0;); however, the non-breaking spaces are not recognized by Olifant and thus deleted when the files is opened.

Is there a way to import the non-breaking hyphens into Trados?

My only solution until now: Search and replace of the non-breaking hyphen Wordfast coding (&'1E;) with the simple hyphen (-) in the Wordfast txt file and import to Trados via Olifant as a Trados txt file. At least then I have the hyphens, though not non-breaking.


Direct link Reply with quote
 

Roman Bulkiewicz  Identity Verified
Ukraine
Local time: 12:06
Member (2004)
English to Ukrainian
+ ...
try this Nov 4, 2008

hprescott wrote:
My only solution until now: Search and replace of the non-breaking hyphen Wordfast coding (&'1E;) with the simple hyphen (-) in the Wordfast txt file and import to Trados via Olifant as a Trados txt file. At least then I have the hyphens, though not non-breaking.


1) in the WF TM, search and replace the non-breaking hyphen code with some specific character string that does not occur elsewhere in the file (e.g., $$$, %%%%, etc.)
2) convert to Trados TM (tmx or txt)
3) in the Trados TM, search and replace that string to the Trados code for non-breaking hyphen, whatever it is.


Direct link Reply with quote
 
hprescott
German to English
TOPIC STARTER
editing Trados TM Nov 4, 2008

Thanks for the helpful advice.

One more question: when/where/how do I edit the Trados TM so that the "\_" Trados coding is processed properly by TWB and does not display this as text.

I tried to do this directly in the Trados txt file before importing, but in the TWB after the import, I am seeing "\_" the Trados non-breaking hyphen coding instead of just having the non-breaking hyphen.

SDL says that I have to do it before I import the TUs.

Interestingly enough, when I browse through the Trados 2.x-6.x txt file (windows-1252), none of the coding is displayed (e.g. for the non-breaking spaces). I suspect that the coding has already been processed by this point.

Does anyone know how to edit Trados TM coding?


Direct link Reply with quote
 

Roman Bulkiewicz  Identity Verified
Ukraine
Local time: 12:06
Member (2004)
English to Ukrainian
+ ...
I would suggest: Nov 4, 2008

1) creating a sample Trados TM containing a non-breaking hyphen
2) converting it to txt (or tmx)
3) seeing what the code looks like there
4) editing your txt (or tmx) TM accordingly

Not that I ever actually did anything like that...


Direct link Reply with quote
 
hprescott
German to English
TOPIC STARTER
non-breaking-hyphen import from Wordfast to Trados Nov 5, 2008

Here is a workflow for importing of non-breaking hyphens from Wordfast TM (Wf txt) to Trados TM (tmw) for anyone that might need this info.

Copy the Wordfast TM txt file under a new name and open it.
Replace all &'1E; codes with %%% in the Wordfast TM txt file (for example, with Notepad).
Save file (Note: do not use the "Save as" command in Notepad, otherwise the coding of the file will change and cause major problems).

Open the edited Wordfast TM txt file in TM editor/Olifant (I am using Version 0.2 build 15) (coding: windows-1252).
If desired, now is the time to edit the TM (language code, source = target, etc.).
Save the file as a Wordfast TM file with the "Save as" command so as not to delete the original file.
Then use the Export function (File menu).
In the Export window, select Trados Text TM under Format, click on Options and check that the coding is windows-1252 and that not more than 4 attributes field boxes are checked.
Under Path, rename the file by clicking on the "..." button.
After renaming the file and clicking "Save", the path is shown in the "Path" field.
Click OK to export this file. The file is exported.

After the file is exported, copy the Trados Text TM file under a new name and open it. (This allows you to keep a copy of the freshly exported file in case anything happens.)

Note again: Do not use the "Save as" command directly in Notepad to rename the file, as the formatting will change, and the file can then not be imported into Trados TWB.

After opening the renamed Trados Text TM file,
1. replace [space]%%% with [space]\_
Note: If a space is not included in the search and replace fields, the Trados import will fail (don't ask me why but it does).
After search and replace, search the file for %%% to find the %%% entries with a non-breaking space, or another character, before it.
Note: Notepad does not display the coding for the non-breaking space but is able to differentiate between a "normal" space and a non-breaking space.
Copy %%% with the non-breaking space in front of it into the search field:
2. replace all [non-breaking space]%%% with [non-breaking space]\_
Save the file (do not use the "Save as" command).

Open TWB and the corresponding TM.
Note: If you have more recent TUs in the TM that you could be overwritten, it is a good idea to export them at this point (as txt or tmx), so that in case they are overwritten, they can be re-imported.

Use the Import function. I was working with the import modus "overwrite".
Select the edited Trados Text TM file and press OK to import the edited TUs.

To ensure that the more recent TUs are intact, simply re-import them now from the file of TUs exported out of Trados with the "overwrite" modus.

It is always good to check to make sure this all worked. I usually go back to the original Wordfast TM txt and look for the first segment with &'1E; and check what this TU looks like in Trados TM (Maintenance-Edit TU-Advanced Edit displays the coding).

Comments: Why am I doing this? The tmx conversion function in Wordfast deletes all non-breaking spaces and hyphens, and the non-breaking hyphens are not automatically imported into Olifant from the Wordfast txt file.
According to Wordfast Support:
"If you make your Wordfast TM Unicode, Wordfast will export non-breaking spaces correctly. ... Unicode TMs won't record non-breaking hyphens at all, ...."


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Importing non-breaking hyphen from Wordfast into Trados

Advanced search


Translation news related to Wordfast





Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs