Mobile menu

Wordfast clean-up doesn't work
Thread poster: Magdalena Psiuk
Magdalena Psiuk  Identity Verified
Poland
Local time: 04:05
Member (2016)
English to Polish
+ ...
Sep 29, 2007

I have just installed Wordfast 5 on MS Office 2007. Everything works fine, except that I cannot force it to clean up the translated document. I have tried two methods: the 'quick cleanup" button, and also 'clean-up' button which is in the 'Tools" toolbar. The strange thing (strange for me) is that Wordfast actually seems to be doing the clean-up, and a clean-up report is even generated, but, what I end up with is only a .bak file, with both target and source text, except that purple delimiters are changed into black.

Any ideas, please?

Magda


Direct link Reply with quote
 

Andrea Erdmann
Germany
Local time: 04:05
French to German
+ ...
provisional segments left? Sep 29, 2007

is a reason given in the cleanup-Report? I had this problem once and finally found the solution: there was still a provisional segment in the uncleened text. I realized this when reading carefully the CleanUp-Report which said "could'nt clean because of provisional segment" or something similar.

Direct link Reply with quote
 

Ulf Samuelsson  Identity Verified
Mexico
Local time: 21:05
Member (2007)
English to Swedish
+ ...
What about the .doc file? Sep 29, 2007

You wrote that the .bak file had both source and translation, and that is to be expected. It shouldn't have changed the colors for the delimiters, though.

But what about the original .doc file, does it also have both source and target?

Ulf


Direct link Reply with quote
 
Magdalena Psiuk  Identity Verified
Poland
Local time: 04:05
Member (2016)
English to Polish
+ ...
TOPIC STARTER
It's not a provisional segment, I'm afraid. Sep 29, 2007

Andrea Erdmann wrote:

is a reason given in the cleanup-Report? I had this problem once and finally found the solution: there was still a provisional segment in the uncleened text. I realized this when reading carefully the CleanUp-Report which said "could'nt clean because of provisional segment" or something similar.


Andrea, thank you, but I'm afraid that's not it.

As I said, it all looks weird: I click "clean-up" icon, Wordfast actually IS DOING the clean-up, clean-up report is generated saying that no problem occurred, but the final document I get still contains both source and target texts, just that delimiters turned black and look just like part of normal text.

Any other ideas?

Magda


Direct link Reply with quote
 
Magdalena Psiuk  Identity Verified
Poland
Local time: 04:05
Member (2016)
English to Polish
+ ...
TOPIC STARTER
Thanks, everyone. Sep 30, 2007

I decided to remove Wordfast, and re-install it from the very beginning once again, and that has done the trick - everything's fine now.

I thank you once again for your help.

Magda


Direct link Reply with quote
 

Bogdan Dusa  Identity Verified
Romania
Local time: 05:05
English to Romanian
+ ...
Cleanup macro Sep 30, 2007

Here's a trick you can use if this situation happens again. It works with Trados, I think normally it should work with Wordfast, too.

1. In the uncleaned file, go to Tools menu - Macro - Macros.
2. Scroll down in the list until you reach tw4winClean.main
3. Click Run.

If you don't have the option at step 2, search in that list for a macro that contains Clean.
This macro actually removes the source text and leaves you only the translated segment. Still, pay attention, it does not update the TM.
You can use this option especially with large documents, documents containing lots of formatting stuff etc.

The error given by the regular Cleanup is caused by the conversion into and from Rtf file. When you select Cleanup, the documennt is first converted from .doc to .rtf, there it is cleaned and then converted back from .rtf into .doc. If the document is large or has lots of formatting stuff, or is bad formatted etc it will have errors upon this conversion, as the .doc formatting is not 100% similar to the .rtf formating. If the original document os bad formatted, then you will have big problems...
That's why in such cases it is good to use the Word cleanup macro and afterwards you have all the time to play with your TM in order to update it...

Good luck!

Bob


Direct link Reply with quote
 
lila23  Identity Verified
Local time: 22:05
English to French
I have the exact same problem Oct 2, 2007

I have been using Wordfast for a few months now and never had that problem before. I just updated my wordfast to the latest version and it seems to me that since I did that, the clean up funcion doesn't do its job. Do I really need to uninstall and reinstall the program again?

Direct link Reply with quote
 

Ulrike Glaese  Identity Verified
Local time: 04:05
Member (2006)
English to German
Same here - cleanup doesn't work Oct 2, 2007

I have updated to the new version and now the cleanup only turns the red markers black and makes them part of the text.

I have re-installed Wordfast, which doesn't help. How do you uninstall it, though?

Thanks


Direct link Reply with quote
 
lila23  Identity Verified
Local time: 22:05
English to French
I don't know if it comes from Oct 2, 2007

trans-tech wrote:

I have updated to the new version and now the cleanup only turns the red markers black and makes them part of the text.

I have re-installed Wordfast, which doesn't help. How do you uninstall it, though?

Thanks

the update, but the same happened to me. As soons as I updated Wordfast to the latest version, the cleanup stropped working properly.


Direct link Reply with quote
 

Ulrike Glaese  Identity Verified
Local time: 04:05
Member (2006)
English to German
Now it works!! Oct 2, 2007

Hello there. I threw out all files called anything containg 'wordfast' and then downloaded the English version, installed it - and lo and behold, now its running perfectly.

Direct link Reply with quote
 
lila23  Identity Verified
Local time: 22:05
English to French
Afraid of deleting worfast files Oct 2, 2007

trans-tech wrote:

Hello there. I threw out all files called anything containg 'wordfast' and then downloaded the English version, installed it - and lo and behold, now its running perfectly.

Hi tran-tech,
I'm afraid to delete the memory I have been building since I downloaded Wordfast.


Direct link Reply with quote
 

Ulrike Glaese  Identity Verified
Local time: 04:05
Member (2006)
English to German
No fear Oct 8, 2007

Hi lila23,

I didn't delete the TMs, I only deleted all files containing the word 'wordfast'. The TMs all start with Wf, so they aren't concerned.

HTH


Direct link Reply with quote
 

S.Paramesh Kumar  Identity Verified
India
Local time: 07:35
Member (2010)
French to English
+ ...
Clean-up problem Nov 6, 2007

Faced the same problem - through both "Quick clean-up" & Tools "clean-up". In this case the clean-up action was carried out but was not able to save the file.
Was using an older version of Wf.

A nightmare, after completion of a rush job. There were no provisional segments too.

Finally used the cut/paste (of the unsavable cleaned document) onto a new document, where had to redo some minor changes.

Pam


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 22:05
Member (2008)
English to Dutch
+ ...
This is 3 years later but anyway... Jul 9, 2010

I have the same problem. I usually use quick clean to clean my documents, but I heard today that a printer running my file through their software saw both source and target appear in their document along with the code. So obviously my file was not clean. I decided today to 'try' the regular clean tool. I don't know what went wrong, but it did not clean the document, at least not the way I expected. Same as above: source and delimiters are still all there.

What I understand is that the clean tool reorganizes the TM. It makes changes to the TM file along with analysis notes. Maybe that's why I can't do a quick clean over top of the already cleaned file?

I tested a new file and that quick-cleaned fine. WF doesn't have to be reinstalled.
But the clean tool doesn't work, and that is probably why I never tried it again and always use the quick clean tool.

So how do I go from here? Who can explain to me how the clean tool should work, and why it isn't?

I use WF only for segmentation and of course to build up TM's for repetitions, and to apply the glossary. The rest of my skills with it are still rudimentary. Tagging... concordance...fuzzy settings...how to best update the documents and TM when I make changes... I don't know.

I am really disappointed/frustrated with my 1 hour deadline for these 4000 words and a document that I have to manually clean.

If anyone has suggestions... I'd much appreciate it.

thanks.


[Edited at 2010-07-09 04:14 GMT]


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 04:05
Member (2006)
English to Afrikaans
+ ...
It sometimes happens Jul 9, 2010

Lianne Van De Ven wrote:
I have the same problem. I usually use quick clean to clean my documents, but I heard today that a printer running my file through their software saw both source and target appear in their document along with the code. So obviously my file was not clean.


1. You should always check yourself before sending to the client:
* Do Ctrl+comma a few times to see if there is hidden text.
* Scroll to the bottom of the document to make sure it cleaned all the way.
* Do a search for { or for }.

2. Sometimes it just happens, and there is very little you can do about it. You just have to do it manually. There are two ways of doing it manually:

* Deleting hidden text

If your document has no hidden text except for the text that WF created, you can simply delete all hidden text. First, make sure you can see the hidden text (Ctrl+comma a few times). Then do this find/replace operation:

Find what: * [hidden]
Replace with: [nothing]
Wildcards: enabled

To do "hidden" in the Find box, click "More" on the Find/Replace dialog, click in the Find field, click Format -- Font -- Hidden.

* Deleting the source text and markers manually

If you had forgotton to save a copy of the file before attempting to do the cleanup (so that you now have WF tags that aren't hidden anymore), or if you have hidden text apart from the WF code, you can use two searches to do the cleanup:

Find what: ( \ { 0 \ > ) ( * ) ( \ { \ > ) [remove spaces]
Replace with: [nothing]
Wildcards: enabled

Find what: < 0 } [remove spaces]
Replace with: [nothing]
Wildcards: not enabled


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast clean-up doesn't work

Advanced search


Translation news related to Wordfast





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs