Mobile menu

Table of Contents with Wordfast
Thread poster: Ali Al awadi
Ali Al awadi  Identity Verified
Romania
Local time: 15:33
English to Arabic
+ ...
Mar 11, 2008

Dear all,

I have a file starting with a table of contents. But every time I start the translation session, the first segment is always the one below the Table of Contents.

Any ideas how to translate a table of contents using wordfast?

Many thanks in advance.

Ali Al-awadi


Direct link Reply with quote
 

Claire Cox
United Kingdom
Local time: 13:33
French to English
+ ...
Word should do it automatically Mar 11, 2008

If you translate the body of the text using Wordfast as normal and ignore the table of contents, then go back to the contents page when you've finished and right click, you should be given an option to update the contents list and/or page nos. When you click on update, the titles you've translated in the text should appear in the list. Assuming that the contents list has been generated automatically in Word, that is.

Direct link Reply with quote
 

Gregory Flanders  Identity Verified
France
Local time: 14:33
Partial member (2007)
French to English
+ ...
Shift F9 Mar 11, 2008

Yes, proceed as Claire has described -- once everything has been translated, you can update the table of contents by typing Shift+F9, I believe. (Or Alt+F9?)

Direct link Reply with quote
 
Ali Al awadi  Identity Verified
Romania
Local time: 15:33
English to Arabic
+ ...
TOPIC STARTER
Table entries and contents not found! Mar 11, 2008

Thanks a lot Claire and gflan for your prompt response.

Unfortunately, Wordfast skips the table and its contents completely as if they were not there at all. In other words, Wordfast does not handle the table entries and/or its contents text.

Having finished the file translation, I got an error message, every time I did as shown in your response, that the table entries could not be found .
PS. the table is automatically generated in the source text.

Am I missing something?

Thank you very much for your time and consideration

Ali Al-awadi


Direct link Reply with quote
 

Christel Zipfel  Identity Verified
Partial member (2004)
Italian to German
+ ...
Try this way Mar 11, 2008

I thought the way that was described before was much simpler than what I usually do.

Anyway, if it doesn't work, that's the way that I normally use when TOCs are present in the translation:

I translate anything of the text BUT the TOC. When finished, I go back to the TOC, have it translated (at this point, you have all the titles anyway in the TM) and then clean. You should so have a perfect Table of Contents. If not, go to the beginning of the Table of Contents, click on "insert" in the menu, and everything should be ok.

HTH!


Direct link Reply with quote
 

Claire Cox
United Kingdom
Local time: 13:33
French to English
+ ...
Hmmm Mar 11, 2008

I've just been searching for a document with a table of contents to check what I do and it is as I thought. Translate the file with Wordfast - it will ignore the table of contents but you will be translating each heading in the text anyway. When you've finished, go back to the contents and right-click at the side. You should get a drop-down menu with Update field, and when you click on that the option to just update page nos or all entries. Click on update all and the titles you've translated in the text should magically appear in your contents table. This is nothing to do with Wordfast, just Word. If it doesn't work, it sounds as though the table of contents hasn't been set up properly. It might be worth copying all the text into a new document and trying again - sometimes they can be corrupted.

Another thought - are you absolutely sure you haven't deleted any of the codes when translating the headings. If you've inadvertently deleted the codes that link the heading back to the table, they won't be linked. Could you try again with the source file, run it through the TM and see if that helps? It could be that you've deleted something vital when editing.....

Good luck!

[Edited at 2008-03-11 23:36]


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 16:33
Member (2006)
English to Russian
+ ...
I wouldn't translate TOC Mar 12, 2008

I'd advise to delete the TOC in the document, translate, clean up and create a TOC in translation.

Direct link Reply with quote
 
Ali Al awadi  Identity Verified
Romania
Local time: 15:33
English to Arabic
+ ...
TOPIC STARTER
Finally Done! Mar 12, 2008

Thanks a lot
Claire,
Christel,
gflan,
esperantisto

for your prompt response and highly-appreciated support.

Have a lovely day!

Best regards
Ali Al-awadi


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Table of Contents with Wordfast

Advanced search


Translation news related to Wordfast





LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs