The need to set character set to Unicode to view ProZ.com (on Macs, etc.)
Thread poster: Maria Nicholas
Maria Nicholas  Identity Verified
Local time: 17:29
Greek to English
+ ...
Feb 27, 2006

I have worked on a Macintosh for over 15 years and have been a member of Proz for the last three. Since the migration to Unicode, I have been unable to view any forum postings or Kudoz questions in Greek. The text appears as gibberish without encoding, and turns into further jibberish after Greek encoding has been applied. It looks like a case of double-encoding but I am not sure.

I have no problems on any other Greek sites I visit or interact with. I am unsure why this change has occurred but it has made my Proz experience most unpleasant. I would like to know if any fellow Mac Proz members working in non-Roman alphabets are having problems. This doesn't seem to be a problem for users working on PCs.

Thanks very much,
Maria

[Subject edited by staff or moderator 2006-02-28 11:58]


Direct link Reply with quote
 

Henry Dotterer
Local time: 17:29
SITE FOUNDER
You have tried the Unicode encoding? Which browser? Feb 27, 2006

Thanks for this report. Which browser do you use? Have you tried Unicode encoding? Are you having trouble with any other Unicode sites showing Greek?

Thanks in advance.


Direct link Reply with quote
 
Maria Nicholas  Identity Verified
Local time: 17:29
Greek to English
+ ...
TOPIC STARTER
Unicode encoding works! Feb 27, 2006

Hi Henry,

Thanks a lot for the speedy reply. I just applied Unicode encoding and it seems to have worked. However, I don't need to do this on any other site with Greek text. If this is what I have to do to work with the site though, so be it -- I would much rather do that than not be able to view anything! It's just a little strange because I don't see it anywhere else and I apply Greek encoding for 99% of the sites I interact with. Old habits die hard.

Thank you very much again, I really appreciate it.

Maria


Direct link Reply with quote
 

Henry Dotterer
Local time: 17:29
SITE FOUNDER
Thank you. Feb 27, 2006

Maria Nicholas wrote:

Hi Henry,

Thanks a lot for the speedy reply. I just applied Unicode encoding and it seems to have worked. However, I don't need to do this on any other site with Greek text. If this is what I have to do to work with the site though, so be it -- I would much rather do that than not be able to view anything! It's just a little strange because I don't see it anywhere else and I apply Greek encoding for 99% of the sites I interact with. Old habits die hard.

Thank you very much again, I really appreciate it.

Maria

Thank you. It may be that most Greek sites use the most common local encoding (Windows-1253?). We are making the change to Unicode so that we can show a variety of languages in a standardized way, even in the same page.

Thanks for posting.


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 00:29
Member (2003)
Finnish to German
+ ...
Problems on PC too viewing Proz.com Feb 28, 2006

This has been discussed befor, but nothing has been done so far. One has to change the character coding manually to UTF-8 also on a PC, at least with Firefox browser. Otherwise the German umlauts don't look as they should.
Regards
Heinrich


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:29
Member (2003)
Polish to German
+ ...
Please set your automatic encoding selection to "enabled" Feb 28, 2006

This works very fine for Firefox, while it doesn´t in Internet Explorer.
In particular for Firefox you need to go to View, Character Encoding, Autoselect and chose "Universal" (or at least it works so in the German version of Firefox).

Regards
Jerzy


Direct link Reply with quote
 

Jack Doughty  Identity Verified
United Kingdom
Local time: 22:29
Member (2000)
Russian to English
+ ...
To Jerzy: how about Thunderbird? Feb 28, 2006

You don't happen to know a similar trick for Thunderbird, do you?
See my recent posts in topic http://www.proz.com/topic/43091


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 00:29
Member (2003)
Finnish to German
+ ...
Auto-select? Feb 28, 2006

I have the English version of Firefox, but there is only Auto-detect, which is (off) no matter what I try.
Perhaps my version is a bit old (1.0.7).


Direct link Reply with quote
 

Henry Dotterer
Local time: 17:29
SITE FOUNDER
The home page is in transition Feb 28, 2006

Heinrich Pesch wrote:

This has been discussed befor, but nothing has been done so far. One has to change the character coding manually to UTF-8 also on a PC, at least with Firefox browser. Otherwise the German umlauts don't look as they should.

The home page is in transition (because to make the home page Unicode, we have to make some adjustments to login/authentication.) But you don't have to go to the trouble of setting encoding on pages such as http://www.proz.com/kudoz - do you?


Direct link Reply with quote
 
xxxMihai Badea  Identity Verified
Luxembourg
Member (2004)
English to Romanian
+ ...
Auto-Detect Feb 28, 2006

Heinrich Pesch wrote:

I have the English version of Firefox, but there is only Auto-detect, which is (off) no matter what I try.
Perhaps my version is a bit old (1.0.7).


I use the same version of Firefox: 1.0.7. The respective function is called indeed Auto-Detect in Firefox (it is Auto-Select in Internet Explorer) and in order to uncheck Off you should select “Universal”, as Jerzy suggested.

But, I’m not sure this setting is actually required. My browser is set on Off and I still can view correctly all the special characters, for the Romanian at least.


Direct link Reply with quote
 
Maria Nicholas  Identity Verified
Local time: 17:29
Greek to English
+ ...
TOPIC STARTER
Unicode encoding needs to be set on home page (Mac/Safari) Feb 28, 2006

Henry, to answer your question, yes, I do have to switch the encoding to Unicode (Mac 10.4.5 on Safari). Once I do that though, everything is viewed normally.

Direct link Reply with quote
 

Sandra C.
France
Local time: 23:29
English to French
+ ...
Can't view accented latin characters Feb 28, 2006

I run Mac OS X as well, using Safari as a browser.
Even with the unicode encoding turned on, I can't view accented latin characters anymore; they show up either as question marks, or as gibberish.
(My language pairs: ENFR)


Direct link Reply with quote
 

Kevin Pfeiffer  Identity Verified
Germany
Local time: 23:29
Member (2004)
German to English
+ ...
Autodetect also fails with ProZ.com in Konqueror (3.4.0) Mar 1, 2006

Here, too, (in the default KDE/Linux browser) the auto-detection does not seem to be working properly for Proz.com. I'm hoping that a pending software upgrade might take care of this.

-K


Direct link Reply with quote
 
xxxtlmurray
Local time: 17:29
English
A flaw on the list of forums? Apr 3, 2006

URL = http://www.proz.com/?sp=bb/new&topic_id=&forum_id=-1&action=Overview&cat_group=tech

In Safari, the DejaVu item has a problem with the 'e' and the 'a' depending on the encoding:

auto -> two black diamonds with question marks.
ISO Latin 1 -> correct, acute accent e, grave accent a
UTF-8 -> diamonds+?

If you examine the HTML code, it says charset=utf-8, and the word DéjàVu (with the accented e and a) was typed directly as shown ... and it should have worked fine!

I've been playing around with the HTML and I think there is something wrong in the header, even though I can find only one charset declaration. As I make various modifications to the code, the "problem" tends to change on me. But it's getting late here, and I will have to mess with it later.


Direct link Reply with quote
 
xxxtlmurray
Local time: 17:29
English
Update: Enabling ATSU fixes the characters Apr 3, 2006

I find that if I enable ATSU (Apple Type Services for Unicode Imaging) via the Debug menu, the characters are okay. This deserves more experiment, but I have to earn a living tomorrow....

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

The need to set character set to Unicode to view ProZ.com (on Macs, etc.)

Advanced search






SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search