Cafetran deletes entire word
Thread poster: Tom in London

Tom in London
United Kingdom
Local time: 14:31
Member (2008)
Italian to English
Aug 23

When I am editing a segment in Cafetran I often want to select one letter of a word and replace it. Annoyingly, Cafetran deletes the entire word. Is there a way to stop this nuisance?

 

Samuel Murray  Identity Verified
Netherlands
Local time: 15:31
Member (2006)
English to Afrikaans
+ ...
Confirmed Aug 23

Tom in London wrote:
When I am editing a segment in Cafetran, I often want to select one letter of a word and replace it. Annoyingly, Cafetran deletes the entire word.


I don't use CafeTran but I do have it installed. In my version (10.6.6), when I select a single letter using the keyboard, CafeTran selects only that letter, and if I then type another letter, CafeTran replaces the selected letter with the new letter. However, when I select a single letter using my mouse, CafeTran waits a fraction of a second and then selects the entire word. It does not delete the word, but it does select the entire word, so that any character typed would replace the entire word.


 

Jean Dimitriadis  Identity Verified
English to French
+ ...
Disable "Automatic selection of whole words" Aug 23

CafeTran > Preferences > Workflow > untick "Automatic selection of whole words".

If this occurs when using the auto-complete feature, Preferences > Prompter > try unticking Replace whole words or disabling Prompter ("Prompt phrases" checkbox) altogether.


Vadim Kadyrov
 

Tom in London
United Kingdom
Local time: 14:31
Member (2008)
Italian to English
TOPIC STARTER
Ah but.... Aug 23

Jean Dimitriadis wrote:

CafeTran > Preferences > Workflow > untick "Automatic selection of whole words".

If this occurs when using the auto-complete feature, Preferences > Prompter > try unticking Replace whole words or disabling Prompter ("Prompt phrases" checkbox) altogether.


Thanks Jean but on many occasions I DO want to select whole words - and I find the "prompter" very useful. So there has to be another solution....


 

Jean Dimitriadis  Identity Verified
English to French
+ ...
  Aug 23

No need to touch the Prompter settings then, but have you tried the first suggestion, CafeTran > Preferences > Workflow > untick "Automatic selection of whole words"?

If not, please try it first before seeking another solution as this is the option that allows you to toggle the behavior.

"Automatic selection of whole words" does not mean that you cannot select whole words (with the relevant keyboard shortcuts or a precise mouse selection) if the feature is not enabled,
... See more
No need to touch the Prompter settings then, but have you tried the first suggestion, CafeTran > Preferences > Workflow > untick "Automatic selection of whole words"?

If not, please try it first before seeking another solution as this is the option that allows you to toggle the behavior.

"Automatic selection of whole words" does not mean that you cannot select whole words (with the relevant keyboard shortcuts or a precise mouse selection) if the feature is not enabled, just that such a selection is not automatic (when using the mouse).

[Edited at 2020-08-23 13:45 GMT]
Collapse


 

Tom in London
United Kingdom
Local time: 14:31
Member (2008)
Italian to English
TOPIC STARTER
OK Aug 23

Jean Dimitriadis wrote:

No need to touch the Prompter settings then, but have you tried the first suggestion, CafeTran > Preferences > Workflow > untick "Automatic selection of whole words"?

If not, please try it first before seeking another solution as this is the option that allows you to toggle the behavior.

"Automatic selection of whole words" does not mean that you cannot select whole words (with the relevant keyboard shortcuts or a precise mouse selection) if the feature is not enabled, just that such a selection is not automatic (when using the mouse).

[Edited at 2020-08-23 13:45 GMT]


OK thanks Jean- I'll give it a try -although not being able to automatically select whole words is a drawback. Long-term I think this is something that should be fixed in Cafetran.

[Edited at 2020-08-23 13:48 GMT]


 

Hans Lenting  Identity Verified
Netherlands
Member (2006)
German to Dutch
Use the keyboard Aug 24

Tom in London wrote:

When I am editing a segment in Cafetran I often want to select one letter of a word and replace it. Annoyingly, Cafetran deletes the entire word. Is there a way to stop this nuisance?


Isn't selecting one character typically a task to perform with your keyboard?

Click in the word, use the left/right key to navigate to the correct position. Use backspace or delete or press shift and use the left/right key to correct the letter?


 

Tom in London
United Kingdom
Local time: 14:31
Member (2008)
Italian to English
TOPIC STARTER
Yes but Aug 24

Hans Lenting wrote:

Tom in London wrote:

When I am editing a segment in Cafetran I often want to select one letter of a word and replace it. Annoyingly, Cafetran deletes the entire word. Is there a way to stop this nuisance?


Isn't selecting one character typically a task to perform with your keyboard?

Click in the word, use the left/right key to navigate to the correct position. Use backspace or delete or press shift and use the left/right key to correct the letter?


Yes Hans but it is much more convenient for me use the mouse because I always have it in my hand when translating.


 

Hans Lenting  Identity Verified
Netherlands
Member (2006)
German to Dutch
Modifyer key Aug 24

Tom in London wrote:

Hans Lenting wrote:

Tom in London wrote:

When I am editing a segment in Cafetran I often want to select one letter of a word and replace it. Annoyingly, Cafetran deletes the entire word. Is there a way to stop this nuisance?


Isn't selecting one character typically a task to perform with your keyboard?

Click in the word, use the left/right key to navigate to the correct position. Use backspace or delete or press shift and use the left/right key to correct the letter?


Yes Hans but it is much more convenient for me use the mouse because I always have it in my hand when translating.



Perhaps it's a good idea to implement a modifyer key, like ALT, to override selection of whole words? Press ALT and drag, to select one character at at time?


 

Jean Dimitriadis  Identity Verified
English to French
+ ...
  Aug 24

Even with Automatic selection of whole words enabled, when I perform a simple left click inside a word with the cursor (not left click and drag to select), the cursor is placed and blinking at that character, with no selection made, so that I can effectively delete a character and replace it.

If the auto-complete (Prompter) pop-up is shown when the issue happens, try disabling "Replace whole words" in Preferences > Prompter as explained in the first reply.


 


To report site rules violations or get help, contact a site moderator:

Moderator(s) of this forum
Natalie[Call to this topic]

You can also contact site staff by submitting a support request »

Cafetran deletes entire word

Advanced search






PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search