Déjà Vu X2 - "copy next code" does not work
Thread poster: Timothy Gregory

Timothy Gregory  Identity Verified
Local time: 23:44
Arabic to English
Oct 7, 2015

Hello,

I very rarely use any translation memory tools because most of my work comes to me as non-editable text (image-based PDFs and the like), and with Arabic as a source, OCR is hopeless.

Recently, however, I decided to start working with TM tools and get to know them better before working on finding clients who can send me real "text" to work from.

I was fortunate enough a couple of years ago to win a copy of Déjà Vu X2 from Facebook, so that is where I am getting started. I have version 8.0.641 installed.

I've created a new TM, Termbase, and imported a file to get working. CTRL+down arrow sends the segment to the memory, CTRL+[number] inserts the item from the termbase, so my keyboard is working. However, neither CTRL+D or F8 inserts the next code. I even went into the customization and added a "Copy Next Code" button to my tool bar; clicking it has no effect. I have also 'reset all shortcuts', even though this was a fresh install on a computer where it had never been installed before less than an hour before noticing the problem.

There is a space inside the 'code' item, and parts of the code are grey, e.g. {49 }, where the opening brace and 4 are grey, the 9 and closing brace are black (or the opposite). In the target, after manually copying them from the source, the space is on the other side of the number, e.g. { 49}.

Even more strange; when I copy the codes (using copy/paste) from the source and paste them into the target, after confirming the segment an extra 9 is added - e.g. {49 } becomes {499 } in the source (but not the translation).

Dealing with punctuation and going from a right-to-left language to a left-to-right language often has challenges, and the display issues with where the spaces appear might come down to it being a right-to-left punctuation or space that changes position when copied into a left-to-right string. That doesn't explain "Copy Next Code" failing to work using either keyboard shortcuts or the button.

Has anyone seen anything like this?

Thanks,

Tim


 

Timothy Gregory  Identity Verified
Local time: 23:44
Arabic to English
TOPIC STARTER
Multiplying "9"s Oct 7, 2015

Now I've finished translating this file and I am trying to export it. Word gives me an error;
"We're sorry, we can't open [the document] because we found a problem with its contents"
Clicking details shows:

"The name in the end tag of the element must match the element type in the start tag".

This sounds like an XML error in the Word document created by Déjà Vu X2, so I give a try at opening the file with Word Pad. It opens, but only displays up to ... where the first formatting tag appeared in the file. I go back to DV and re-copy the tags into the translation - but now the 9s are multiplying every time I commit the segment to memory, my first three tags are now:

{ 1999999} إيمان علي { 2999999}04.10.2015 { 3999999}
{ 199999} Iman Ali { 299999}04.10.2015 { 399999}

Notice that the source tags all of one '9' more than the target tags. Every time I modify the translation, both sides get an extra '9'.

I went through this process (Word won't open the file, open with WordPad to see where the text display fails, back to DV to re-copy the codes - and multiply the 9s - export - word won't open the file...) several times until I came to a segment that includes tags 58(99..) - 61(99..) that just won't fix. I ended up copying the contents from WordPad into a fresh Word document, and then copying the last couple of paragraphs from the translation one line at a time.

Pretty frustrating.

EDIT:
I should also mention that the translated document is formatted right-to-left rather than switching to left-to-right!

[Edited at 2015-10-07 05:52 GMT]


 

Atril_TEAM
France
Local time: 08:44
Member (2015)
Dear Thimothy Oct 7, 2015

Please send your project and source file to support@atril.com

Did you try to repair your installation?
http://helpdesk.atril.com/index.php?pid=knowledgebase&cmd=viewentclient&id=118

Kind regards,
Atril TEAM


 

Timothy Gregory  Identity Verified
Local time: 23:44
Arabic to English
TOPIC STARTER
Repaired, got it once... Oct 8, 2015

I've sent the files.

I ran the repair as advised, and then imported another Word document. This time when I got to where I needed to insert the first code, which was {679} in the source, I pressed CTRL+D. It copied in the next code, {689}, instead of the first one. Then, after typing the term I tried to add the next code - which should have been the 'close' or 'return to previous format' or something - and CTRL+D went back to having no effect.

It also continued to fail to insert codes when I scrolled down in the document to the next segment with codes ({699} - {719}). I'm including the code numbers in case the fact that there is a "9" appended to them means anything.

Thank you for your help!


 

Atril_TEAM
France
Local time: 08:44
Member (2015)
Hello Oct 8, 2015

The fact that you could not insert the tags pressing F8 was caused by DVX2 not importing them correctly on this specific file. Some tags were not open/closed properly which make it impossible (or very difficult) for you to insert them.

The workaround is the following:

- I sent all your translations in a temporary TM
- I pretranslated a copy of the source file
- Tags were handled automatically by DVX
- The file could be exported and open normally

I sent this file to you from our support platform.

We will fix this.

Kind regards,
Etienne


 


To report site rules violations or get help, contact a site moderator:

Moderator(s) of this forum
Pavel Tsvetkov[Call to this topic]

You can also contact site staff by submitting a support request »

Déjà Vu X2 - "copy next code" does not work

Advanced search






CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search