TM: internal tags removed, extra spaces
Thread poster: Heike Behl, Ph.D.

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 11:55
Member (2003)
English to German
+ ...
Oct 4, 2007

DVX saves TMs without internal tags, the argument being that the number of matches is increased. Makes sense to some extent.

But...
What happens is that if the removed tag is preceded or followed by a punctuation mark, parenthesis or (R) symbol, an extra space is added in the text. (Since I am working to some extent simultaneously in DVX and Trados, this problem might only show up in the TM exported as Trados .txt file.)

If this segment now results in a 100% match, the extra space is of course introduced into the new translation. The consequence: Even 100% matches need to be closely scanned to make sure there is no superfluous space.

Is there an option to save the TM with all internal tags in place? Or a way to prevent this behavior?


Direct link Reply with quote
 

Judy Schoen  Identity Verified
Local time: 20:55
English to German
DVX saves Tags as placeholders Oct 4, 2007

DVX saves the tags, but as placeholders without any content.
kind regards
Judy Ann


Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 11:55
Member (2003)
English to German
+ ...
TOPIC STARTER
:( Oct 4, 2007

I tried some other export options, and they all create TMs that are severely "handicapped" for being used in Trados and they all contain the extra spaces.

Am I missing something here or is this a bug?

How do you handle this or do you simply not have any clients that expect an exported Trados tm or uncleaned files from you?


Direct link Reply with quote
 

Klaus Herrmann  Identity Verified
Germany
Local time: 20:55
Member (2002)
English to German
+ ...
Exporting for Trados Oct 5, 2007

Heike Behl, Ph.D. wrote:
How do you handle this or do you simply not have any clients that expect an exported Trados tm or uncleaned files from you?


If you need a Trados TM, the best option is to use Workbench and translate the file(s). Make sure to check the "Segment unknown sentences" option. For the actual translation, import the segmented file into DVX. Then, export the project and clean the resulting bi-lingual file into a Trados TM using Workbench.


Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 11:55
Member (2003)
English to German
+ ...
TOPIC STARTER
tag problem Oct 5, 2007

Klaus Herrmann wrote:

If you need a Trados TM, the best option is to use Workbench and translate the file(s). Make sure to check the "Segment unknown sentences" option. For the actual translation, import the segmented file into DVX. Then, export the project and clean the resulting bi-lingual file into a Trados TM using Workbench.


That was the original plan, but Trados couldn't open the TTX file due to a missing tag, presumably some external tag since all internal tags/placeholders were OK.

And since I couldn't isolate the problem I had to export and apply the SVX tm on the original TTX file. No fun... and the additional spaces definitely didn't help.


Direct link Reply with quote
 

KSL Berlin  Identity Verified
Portugal
Local time: 19:55
Member (2003)
German to English
+ ...
One method for identifying and fixing TTX tag problems Oct 5, 2007

>> That was the original plan, but Trados couldn't
>> open the TTX file due to a missing tag

In such cases, you can try changing the TTX extension to XML and opening the document with Internet Explorer. Scroll to the bottom of the window, and you'll find the troublesome part of the file indicated by an error message. Then open the file with a text editor, correct the tag problem, close the file, change the extension back to TTX and Trados should be able to deal with it again.


Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 11:55
Member (2003)
English to German
+ ...
TOPIC STARTER
Thanks! Oct 5, 2007

Thanks, Kevin. That's a great tip!

I couldn't see anything wrong with the tags in xml, though, but I ran the passage in question through DVX again and then the export/opening in Trados worked. A little bit bizarre, but maybe there was a little hickup in the export.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:

Moderator(s) of this forum
Pavel Tsvetkov[Call to this topic]

You can also contact site staff by submitting a support request »

TM: internal tags removed, extra spaces

Advanced search






SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search