problem with csv files (XP/Office 2003)
Thread poster: nordiste

nordiste  Identity Verified
France
Local time: 00:50
Member (2005)
English to French
+ ...
Dec 3, 2008

I have a problem with csv files.
The separator are commas ( , ) .
Every row includes a number, the English version, the Italian, the French, the German ans so on.
When I receive them only the English txt is available, and I can see no separated columns
as in sample:
1,hello,,,,

The PM says that whan I open the file I should see the columns:
A : 1
B : hello
C (blank-for Italian)
D( for the French - where I am supposed to write my translation).

I try to rename as txt, then open with repair, selecting separator = comma, .
So I get an Excel file where I write my translation in column D
I saved as "CSV separator semi-colon" which is the only choice proposed by Excel.

But then when he opens it the PM sees no separated columns...


I am lost. Is this an Office version issue ? Presumably the PM uses Office 2007 (not sure about it).
What are the other ways to deal with a csv file ?

Thanks for any help.


 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:50
Member (2003)
Polish to German
+ ...
Most probably the system separator is the problem Dec 3, 2008

Language settings on your PC and on the PMs PC are most probably different.
While in German the list separator is semicolon (;), in his system this might be set to comma. Maybe you simply switch your system setting termporarily to comma or advise the PM to select semicolon instead of comma while opening your file in Excel.

BR
Jerzy


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 00:50
Member (2005)
English to Spanish
+ ...
An easy solution Dec 3, 2008

Open the file in Word, replace all commas with a tab (^t in Word's Find and Replace dialog box), save the file. The tab will be unmistakably identified as a column separator when you open the file in Excel.

 

esperantisto  Identity Verified
Local time: 02:50
Member (2006)
English to Russian
+ ...
What is PM, by the way? Dec 3, 2008

Whatever it be, did you notify him(her,them) that your CSV files now come with semicolons as separators?

 

nordiste  Identity Verified
France
Local time: 00:50
Member (2005)
English to French
+ ...
TOPIC STARTER
PM = agency Project Manager Dec 3, 2008

esperantisto wrote:

Whatever it be, did you notify him(her,them) that your CSV files now come with semicolons as separators?


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

problem with csv files (XP/Office 2003)

Advanced search






TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search