Odd Word behavior
Thread poster: Patricia Lane

Patricia Lane  Identity Verified
France
Local time: 22:50
French to English
+ ...
Jul 15, 2007

Hello techies,

This is a strange one...

I am translating a Word document using WF.

Whenever I type a word that begins with an "i", Word puts the "i" in uppercase and will not let me change it to lower case. The only solution I have found is to start with another letter and delete that first letter afterwards. This is obviously slowing things down!

No other Word document behaves this way and I see nothing in the autocorrect parameters that could cause such behavior.

No other letter is involved...

Any brilliant ideas??

Thanks

Patricia


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 00:50
Member (2004)
English to Armenian
Hi Patricia Jul 15, 2007

If this is a Word and not WF problem, than probably due to the language set for this file, Word interprets lowercase "i", as some symbol that is usually changed, like the copyright symbol. Try changing the language of the file. If this doesn't help, turn off the "Replace text as you type" function which you can find in Tools > Autocorrect Options > AutoCorrect tab and see if it helps.

Direct link Reply with quote
 

Patricia Lane  Identity Verified
France
Local time: 22:50
French to English
+ ...
TOPIC STARTER
Thanks! Jul 15, 2007

Thanks Henrik, turning that off seems to have done the trick.

Other interesting quirk in this file -- though I set the default language to UK English, it keeps flipping to Australian English (which I have never used), though this source file is in French!!!

I checked my calendar, we are not April Fool's day!

Patricia


Direct link Reply with quote
 

PAS  Identity Verified
Local time: 22:50
English to Polish
+ ...
replace as you type Jul 15, 2007

No need to turn this off. Just scroll through the list of words that are auto-corrected, find "i to I" and remove it. If I recall correctly, you need to do this for every flavour of English that you use.

As for the document changing to different languages - whenever I work on documents that are known to have "travelled" extensively, I see all kinds of things - I've seen the document language on CV's changed to Finnish, Spanish, Czech, and I only work EN-PL!

When you start working on your target document, mark the whole text using ctrl + A and change the language to target.
Also, you want to turn off the "detect language automatically" feature, because in my experience Word has never handled it too well.

HTH,
Pawel Skalinski

[Edited at 2007-07-15 10:45]


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 00:50
Member (2004)
English to Armenian
Do you select all text (Ctrl+A) before setting the language? Jul 15, 2007

If you do, and it still changes to Australian English when you type, uncheck the "Detect Language Automatically" checkbox in the language dialog-box. This may help, though I am not sure. Recently I have an impression that Word lives its own life, and sometimes you need to be very careful to guess what Word wants you to do, not to mention that it never does what you want.

It's not April Fool's day but it's very hot, at least here, in Armenia:)


Direct link Reply with quote
 

Patricia Lane  Identity Verified
France
Local time: 22:50
French to English
+ ...
TOPIC STARTER
CLT+A Jul 15, 2007

Yup, did that, and selected UK EN as well as instructing to use that as the default language. It is still reverting! Do you think it may be a macro?

Thanks for the help, you two!

Patricia


Direct link Reply with quote
 

Patricia Rosas  Identity Verified
United States
Local time: 13:50
Spanish to English
+ ...
me, too! Jul 15, 2007

Patricia Lane wrote:

Whenever I type a word that begins with an "i", Word puts the "i" in uppercase and will not let me change it to lower case. The only solution I have found is to start with another letter and delete that first letter afterwards. This is obviously slowing things down!


Patricia,
Last week, I was using Word (alone, without Word Fast) but with Dragon Naturally Speaking (and a Spanish file into English). I have an autotext entry for the pronoun "I" set so that "i" (a single word) is automatically reset to "I". However, in two files I was working on, ANY word that BEGAN with "i" was automatically changed to "Ixxxx".

The documents were short so I just went ahead and backspaced out the wrong letter. But now that I've read your post, I'm really wondering and a bit worried! I'll try removing "i" --> "I" from the autotext list if it starts again, but could something else be going on?

Best,
(another) Patricia


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 00:50
Member (2004)
English to Armenian
Try these Jul 15, 2007

I've noticed that sometimes Word doesn't keep the assigned language, especially when there are many styles and different formats in the document. Check the styles, maybe the problem is there. Word may be retaining their features and ignoring the overall formatting. Open the styles panel - Format > Styles and Formatting, and at the bottom, in the "Show" filed select "Formatting in use". Then keep the mouse over each style and check the language. If the problem is in one of the styles, you can change the settings of that style.

If this doesn't help, you may need to assign the language in portions. Select one small portion of the text that has identical formatting and assign the language. See if it works. If yes, select a larger portion and do the same. Right after hitting OK check the language, before typing anything. If it has retained the language, than it's fine. If it hasn't, than you have to select a smaller portion.

If this doesn't help, save the file as RTF (Rich text format) document, close and re-open it.

And finally, if nothing helps, you can just get rid of formatting, which will probably resolve this problem too. If retaining the original formatting is not essential, you can do this: select all (Ctrl+A), then hold down the Ctrl key and hit the spacebar. See if it works. And finally, if this one also fails, just copy the whole text, open a new blank document and Paste Special > Unformatted text, or save the file in plain text format, close and re-open again.


Direct link Reply with quote
 
Ken Cox  Identity Verified
Local time: 22:50
German to English
+ ...
another WF tip Jul 16, 2007

If you are working on a document with WF (WF active) and you open another Word document and position the cursor anywhere in the other document, when you return to the first document WF will often 'lose context' and start applying default styles to target text (and who knows what else it does in this case). The solution to this is to stop WF, select 'Service' in the WF dialog, and click 'Reorganise'. After the TM has been reorganised, WF will behave properly again (i.e. apply the local style attributes of the source text (paragraph formatting and font settings) to the target text and (presumably) apply the TM target language attribute to the target text).

Direct link Reply with quote
 

Patricia Lane  Identity Verified
France
Local time: 22:50
French to English
+ ...
TOPIC STARTER
thanks all Jul 16, 2007

This file is definitely strange.. But it finally decided to accept the UK English language as default (my stubbornness in repeating the process maybe helped!! -- the styles were not an issue apparently..), the "I" issue got solved thanks to Henrik, but I can't wait for this project to be done. Even with only this file open, just Word and WF running, it takes up all the computers resources and the unit heats up like crazy. This does not happen with any other Word file - or even when I am doing something creative with heavy graphic programs running concurrently.

Does anyone know how to check if there is a hidden macro somewhere in this Word file? I remember once a long time ago some similar memory hogging behavior and it was indeed caused by an undesired macro.....

Time to let the computer cool....

Patricia


Direct link Reply with quote
 
llnnhh
Local time: 03:50
English
Fix the error Jul 17, 2007

Hi Patricia, pls try to do the following steps then you will get the result
In a Word document, go to Tool-> AutoCorrect a window will appear. In Replace box, type i the u will see the some lines with i in the window below. Choose a line that have i in replace box and I in "with" box, choose Delete button then press enter. Press OK to close the window then u try to type again.

Hope this tip will help u.
BR


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Odd Word behavior

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search