Cyrillic website not displaying right in my browser
Thread poster: BrianHayden

BrianHayden
United States
Russian to English
Dec 19, 2013

Today when I tried to access this website (http://www.frazeologiya.ru/) all I saw was Latin-script gibberish with a lot of weird diacritics. I've seen Cyrillic transformed into what looks like someone randomly pounding on an Estonian keyboard before, but I've never seen an entire website display like this. I'm using Google Chrome as my browser; I also tried it using Internet Explorer 8. Weird thing is, I found the website through Яндекс, where a search result from the website displayed as completely normal Russian Cyrillic. Go figure.

 

Valery Shapovalenko  Identity Verified
Ukraine
Local time: 17:28
English to Russian
+ ...
Strange, Dec 19, 2013

'cause I read it with my Chrome as usual - Cyrillic...icon_wink.gif

Seriously, try to set CodePage 1251 in your IE8. Or ask Google Team to help you. In your Chrome Settings add Russian Language.


 

Paulinho Fonseca  Identity Verified
Brazil
Local time: 13:28
Member (2011)
English to Portuguese
+ ...
Weird Dec 19, 2013

I used Chrome and the result was the same. Very confusing.

icon_smile.gif


 

Recep Kurt  Identity Verified
Turkey
Local time: 18:28
Member (2011)
English to Turkish
+ ...
Try utf-8 Dec 20, 2013

Your source code shows the page encoding as "cp-1251"

I would change that to "utf-8"...



[Edited at 2013-12-20 06:31 GMT]


 

esperantisto  Identity Verified
Local time: 18:28
Member (2006)
English to Russian
+ ...
Problem on their side probably Dec 20, 2013

BrianHayden wrote:

Today when I tried to access this website (http://www.frazeologiya.ru/)


Now, it says: ‘SQL error’. Thus, perhaps, they’re experiencing technical problems. Anyway, try forcing cp-1251 for the encoding.

[Edited at 2013-12-20 08:21 GMT]


 

esperantisto  Identity Verified
Local time: 18:28
Member (2006)
English to Russian
+ ...
Hardly Dec 20, 2013

Recep Kurt wrote:

I would change that to "utf-8"...


UTF-8 on Russian sites is a very rare exception.


 

Rolf Keller
Germany
Local time: 16:28
English to German
The other way round Dec 20, 2013

Recep Kurt wrote:

Your source code shows the page encoding as "cp-1251"

I would change that to "utf-8"...


The web page uses cp-1251, definitely. So you have to set the browser either to "automatic" or to "cp-1251". If you set it to "utf-8", you'll get gibberish.


[Bearbeitet am 2013-12-20 08:32 GMT]


 

BrianHayden
United States
Russian to English
TOPIC STARTER
How would I do that? Dec 20, 2013

Rolf Keller wrote:

Recep Kurt wrote:

Your source code shows the page encoding as "cp-1251"

I would change that to "utf-8"...


The web page uses cp-1251, definitely. So you have to set the browser either to "automatic" or to "cp-1251". If you set it to "utf-8", you'll get gibberish.


[Bearbeitet am 2013-12-20 08:32 GMT]


How would I set Chrome to automatic or cp-1251? I'm not very computer-savvy.


 

Rolf Keller
Germany
Local time: 16:28
English to German
Help is at your fingertips Dec 20, 2013

BrianHayden wrote:

How would I set Chrome to automatic or cp-1251? I'm not very computer-savvy.


http://www.googlechrometutorial.com/google-chrome-initial-settings/Google-chrome-page-settings.html#GoogleChromeEncoding

A similar setting exists in MS Internet Explorer (see View menu).


 

BrianHayden
United States
Russian to English
TOPIC STARTER
I think you accidentally included the "/" at the end Dec 20, 2013

esperantisto wrote:

BrianHayden wrote:

Today when I tried to access this website (http://www.frazeologiya.ru/)


Now, it says: ‘SQL error’. Thus, perhaps, they’re experiencing technical problems. Anyway, try forcing cp-1251 for the encoding.

[Edited at 2013-12-20 08:21 GMT]


...because without that forward slash at the end, it displays the same gibberish that it did last time.


 

BrianHayden
United States
Russian to English
TOPIC STARTER
Thanks Dec 20, 2013

Rolf Keller wrote:

BrianHayden wrote:

How would I set Chrome to automatic or cp-1251? I'm not very computer-savvy.


http://www.googlechrometutorial.com/google-chrome-initial-settings/Google-chrome-page-settings.html#GoogleChromeEncoding

A similar setting exists in MS Internet Explorer (see View menu).


Thanks for linking to that tutorial. I changed Chrome's settings to Auto-Detect, and now the website is displaying coherent Cyrillic. Problem solved.


 

Skallagrimson  Identity Verified
United Kingdom
Local time: 15:28
Latvian to Russian
+ ...
Cyrillic website not displaying right in my browser Dec 20, 2013

I am using Mac OS X 10.9.1 | Safari 7.0.1

Usually Russian websites are displaying OK without changing Text Encoding, but this one I can read with «Cyrillic (Windows)».

Same with Firefox: Character Encoding ––> Cyrillic (Windows-1251)

Cheers, Egils


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Cyrillic website not displaying right in my browser

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search