Bungled tables in bilingual files
Thread poster: Vitor Souza

Vitor Souza
English to Portuguese
May 30, 2009

Hello,

I am working on a fairly large project consisting of several tens of Word files with tables (training materials for a company, text only). I imported everything to MemoQ and started translating. To make sure that everything goes well, I exported the first file right after translating it. When I exported is as a monolingual file (Export (stored path)), it was all right - I got a beautiful file that looked exactly the way it should.

Unfortunately, my client wants me to deliver Trados files (they don't even know I am not using Trados for this job). So I also exported a bilingual file and tried to open it. I got an error message saying something about corrupted tables. The message suggested that I go to Table and choose Convert table to text (sorry if the English names of the commands are not accurate; my MS Office is not in English). So I did it, and one of the tables (the one were my cursor was) changed to horribly formatted text.

The error message offered another option:

You can recover the contents of the document and the table by closing the document and reopening it using the Open and Repair option of the Open dialog (File menu). To find the Open and Repair option, select the down arrow next to the Open button. The Open and Repair option is at the bottom of the menu. After the file is repaired, the corruption or incorrect formatting of all tables in the document should be corrected.

I tried it, too. What I got was a file with tables but with totally bungled column widths and other problems. It would take me ages to fix it.

Any ideas as to what went wrong? I should add that I used CodeZapper before importing the files into MemoQ. Compared to the analysis performed by the agency (my client), the number of repetitions was much higher, so I was very happy. But could CodeZapper possibly have caused my problem?

Another possible problem: As I said, there were two tables in that file. The difference between this them (which got messed up) is as follows:
- each table cell in the first table contains several lines separated by the new line symbol: http://img40.imageshack.us/img40/9814/symboln.png,
- each table cell in the second table contains several lines separated by the Enter key.

I know that the new line symbol causes trouble in Wordfast so I guess it could be problematic here as well. If someone believes this is indeed the cause of my trouble, don't you know an easy way (I have tens of files to translate!) to replace it with enters? I know that I can replace ^l by ^p but I would like something that would work for many files at once.

Edit1: The new line symbol does not appear to be a problem, after all. I replaced it by enter in one file and got exactly the same results.

[Edited at 2009-05-30 16:28 GMT]

Edit2: I would like to report that CodeZapper was not the cause of my problem either. I translated an unzapped file in MemoQ and got the same problem. What I would really like to know is whether the following makes sense: translate everything in MemoQ, export the TM as TMX, import it into Trados and pre-translate it. I would really like to translate in MemoQ but I am afraid I will get a lot of trouble when I try to use my memory in Trados (incompatible segments etc.)...

[Edited at 2009-05-30 17:27 GMT]

Edit3: I guess I will give up and simply use Trados fo this project. I pre-translated one of the files in MemoQ with an empty memory, hoping that I could tarnslate everything in MemoQ first, export my memory and translate MemoQ-segmented files in Trados. But when I do it, I get the same error message as above, and large parts of the tables are blank.

[Edited at 2009-05-30 18:40 GMT]


 

Gergely Vandor
Hungary
Local time: 06:59
English to Hungarian
a known problem May 30, 2009

Dear Vitor,

I beleive a table in your document contains another table, and our bilingual DOC exporter is known to have problems with that situation. Can you confirm that there is a table inside a table in your document? Or, better yet, send the document to our support address? Thank you.

We haven't really had complaints about this, but now that there is one, we'll take a look at it. I can't promise a quick fix though.

Best regards,
Gergely Vandor

Kilgray


 

Vitor Souza
English to Portuguese
TOPIC STARTER
Yes, embedded tables May 31, 2009

Hi Gergely,

You are right - there seems to be one big table with three smaller ones inside. I will be sending one of the files to your support shortly.

Does anyone know how I could separate the tables easily? I opened a new Word file and wanted to manually copy each of the tables so they would be under each other. However, they completely lost their original dimensions, and the first one would not even fit on the page although it is neat in the original file. Actually, I guess it would probably involve too much additional work. I will simply grit my teeth and use Trados for this job.


 

KSL Berlin  Identity Verified
Portugal
Local time: 05:59
Member (2003)
German to English
+ ...
Suggestion May 31, 2009

Vitor Souza wrote:
I will simply grit my teeth and use Trados for this job.


Or do it as a TTX and translate it in MemoQ anyway. Working with many tables in Trados with the Word macros is a pain anyway.


 

Vitor Souza
English to Portuguese
TOPIC STARTER
Tried it out May 31, 2009

Hi Kevin,

Thanks for the suggestion. I tried it out but as I am not a very experienced Trados user, I did not exactly get what I wanted.

My problem: I created a TTX file and uploaded it in the Translate menu in Workbench. I ticked "Segment unknown sentences" and pretranslated the file. When I uploaded it to MemoQ (I chose Use uninterpreted formatting (tags) to represent Trados tags), I found out that for segments that I didn't have in my memory, Trados copied the original. So in order to translate it in MemoQ, I will have to delete the English text and replace it with the Portuguese translation. This is too much clicking for my taste. (What is worse, I was not be able to filter away confirmed segments - I love this MemoQ feature - because even segments with the English text were all green/confirmed.) Is there anything I can do to avoid this problem? I've checked the manual but since my threshold was 100%, I really do not understand why it happened.

Another trouble: When I export the file as a bilingual Trados-compatible file, I can see quite a few red (MQ) tags. CodeZapper removed most of them but apparently not all. I am not sure I can deliver the file with those tags, can I? They remain there even after I clean the file.

A new edit: I found out that I should probably not use bilingual export but Export (stored path). I got a perfect TTX file that yielded a perfect Portuguese file when I cleaned it up. This is great.

So now I need to find a solution to the segment problem above.

[Edited at 2009-05-31 14:23 GMT]


 

Gergely Vandor
Hungary
Local time: 06:59
English to Hungarian
explanations May 31, 2009

It seems you successfully sorted this out, but this might be useful information for others.

Exporting into Trados segmented bilingual Word (DOC) files can serve two main purposes:

-Returning a document as Trados "unclean" bilingual Word files to a client/agency. This only applies to documents which were originally in Word format (DOC or RTF).

-Letting someone without MemoQ work on a document originating from a MemoQ project. Let's assume you have a team of tranlsators and would like to prepare the project in MemoQ, but one of the translators uses some other tool. You can export their documents into Trados bilinguals, and let them work on them in the other tool or Word, and when they return it, you can "update" the MemoQ translation documents with the content in the bilinguals. This is what we call an "external route". (The other, more robust option for an external route is XLIFF.) Also, if the documents were originally Word DOCs, you need to check the "Simple formatting option at export for this to work.

None of the above applies to you in this case when you work on a Trados TTX (TagEditor) file. Your client expects you to return TTX files, so you need to use the "Export (stored path)" or the "Export (dialog)" command, which gives you just that.

Gergely

(Edited to take out the unneccessary quote)

[Edited at 2009-05-31 20:01 GMT]


 

Gergely Vandor
Hungary
Local time: 06:59
English to Hungarian
you can quickly empty the non 100% targets in MemoQ May 31, 2009

I assume what you have now is a bunch of 100% matches and the rest of the segments in the document are just copies of the source side.

In MemoQ, you can use the segment filtering/sorting functions (from the toolbar above the translation grid) to access all the non 100% segments quickly. Sorting the segments of the document by match rate is probably the easiest, after which you can select all the non 100% matches, right click on them, and use the "Clear translations" function to clear the target side for those segments.

There are several other ways to do this in MemoQ. You could also click the funnel icon, and filter for segments that are "Not started", because that should be the status of the non 100% segments after importing the TTX file. Then you get a subset of the segments of the document, without the 100% matches, and again you can clear the translations with a few clicks. Or you can clear the target for the whole document, and pretranslate again with the translation memory migrated from Trados through TMX.

After the fact, don't forget to update the folks in the Trados forum how easily and elegantly MemoQ solved this problem for you.icon_wink.gif I see you started a thread there as well about this, but I thought I'd better answer here.

Best regards,
Gergely Vandor

Kilgray support team


 

Gergely Vandor
Hungary
Local time: 06:59
English to Hungarian
"tables inside tables" problem solved Jun 9, 2009

We have solved the problem of tables inside tables in the bilingual DOC exporter. That will be working okay from the next build on, which will be released very soon.

Best regards,
Gergely


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Bungled tables in bilingual files

Advanced search






CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search