Pages in topic:   [1 2] >
Importing pretranslated bilingual RTF files
Thread poster: Tobias Werner

Tobias Werner  Identity Verified
Local time: 14:18
English to German
Nov 19, 2009

Hi,

I've a problem during the import of pretranslated RTF files into MemoQ. Usually I translate these files with Trados but I would like to try to do it in MemoQ. But not all text is imported.

During import in MemoQ I use the bilingual DOC/RTF filter to handle the files. Unfortunately only 99 and 100% matches are imported, but not the no matches and fuzzies. Is there another way of doing it?

Regards
Tobias


 

István Lengyel
Hungary
Local time: 14:18
English to Hungarian
+ ...
Have you presegmented? Nov 19, 2009

Hi Tobias,

Have you presegmented the no match content too? Just like in the case of TTX files, it's a requirement for Word files as well.

I hope this helps.

István


 

Tobias Werner  Identity Verified
Local time: 14:18
English to German
TOPIC STARTER
Where to find Nov 20, 2009

Hi István,

can you please tell me step by step how to do it? I haven't used this function before and don't know where to find it.

Tobias


 

Noe Tessmann  Identity Verified
Local time: 14:18
English to German
+ ...
Presegmented Nov 20, 2009

Hello,


is the file entirely translated or pretranslated, what means do you have the curly purple Trados tags all over the text? You can also open and save the word file in TagEditor and the import it into MemoQ. While importing MemoQ doesn't see any diffence between fuzzy and other tags, all it needs is the tags. Fuzzy or not is a question of the Trados TM.


Regards

Noe


 

Tobias Werner  Identity Verified
Local time: 14:18
English to German
TOPIC STARTER
pretranslated Nov 22, 2009

Hi Noe,

the file is partly pretranslated so there are Trados tags everywhere. I'll try to process it in TagEditor.

Regards
Tobias


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 14:18
Member (2005)
English to Spanish
+ ...
Presegmentation is a must too... Nov 22, 2009

Indeed in MemoQ if you import a DOC or RTF file that has a single segment translated with Trados, MemoQ for some reason won't see the segments that are still untranslated, i.e. with no Trados codes.

In the case of DOC or RTF files, it is best to use normal files with no Trados pretranslation. For the translation itself, use MemoQ. You can feed the memory with an export from your previous Trados memory in TMX format. This way you will be more efficient translating the file.

[Edited at 2009-11-22 16:28 GMT]


 

Tobias Werner  Identity Verified
Local time: 14:18
English to German
TOPIC STARTER
still a bit lost Nov 22, 2009

Unfortunately I do not have "normal" files. I already received pretranslated files from my customer and have to use these.

What exactly is meant by this presegmentation everyone is talking about? Is this a special function or does it mean to open the (not pretranslated) files in TagEditor? Hope this is not a silly question.


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 14:18
Member (2005)
English to Spanish
+ ...
In Translator's Workbench > Tools > Translate ... Nov 22, 2009

Tobias Werner wrote:
Unfortunately I do not have "normal" files. I already received pretranslated files from my customer and have to use these.
What exactly is meant by this presegmentation everyone is talking about? Is this a special function or does it mean to open the (not pretranslated) files in TagEditor? Hope this is not a silly question.


And then make sure to check the "Segment unknown" checkbox. This creates a RTF file in which all sentences, known and unknown, are segmented so that MemoQ finds all the segments to be processed.

I cannot access my office computer right now and cannot test this for you, but I think this process should respect the pretranslations already present in your RTF file. Give it a try and let us know!icon_smile.gif


 

Tobias Werner  Identity Verified
Local time: 14:18
English to German
TOPIC STARTER
thanks Nov 25, 2009

Sorry for my late reply. I was able to import the files in MemoQ but the word count was completely different. So I ended up using Trados again. Maybe next time.

 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 14:18
Member (2005)
English to Spanish
+ ...
Wordcount will be different Nov 26, 2009

Tobias Werner wrote:
Sorry for my late reply. I was able to import the files in MemoQ but the word count was completely different. So I ended up using Trados again. Maybe next time.

Indeed MemoQ's wordcount is about 5% lower than Trados', even when selecting the Trados-style wordcount in the Statistics function. I would prefer to have wordcounts that mimicked Trados' wordcounts better, but apart from the fact that I have to analyse the files with Trados to match my customers' figures more closely, MemoQ does save a lot of effort in the process.


 

Gergely Vandor
Hungary
Local time: 14:18
English to Hungarian
Trados like statistics Nov 26, 2009

Hello All,

Based on all the feedback we have received, it is quite likely that we will improve the Trados-like-ness of the Trados-like statistics when we get the time (in a few months).

Tobias, I suggest that you take a look at memoQ anyway.icon_smile.gif Even though the wordcounts are different, you might find some useful features in the tool. And you can base your quotes on the Trados wordcounts.

By the way, the main difference is that if there is a punctuation character between two letters, Trados will always count that as two words, while memoQ will always count it as one word. Some examples: Sally's, a/c, taxi-cabs, cranberry-flavored, co-worker etc. All of these are counted as one word for memoQ, and two words for Trados. I've listed mixed examples to show that both approaches are oversimplifications, and are about equally wrong, at least if we look at English. The truth is somewhere between.

Word counting is not only less trivial than it looks, it is also very unfair in many cases. For example many English multiword expressions are translated into single longer compund words in German or Hungarian for example. This means that if the basis for payment is the wordcount, those that translate from German or Hungarian immeditatelly lose a significant amount compared to the more lucky ones whose source language is English. Therefore, shocking as it may sound, Kilgray always suggests using character counts to measure the translation effort when we are asked for advice. (memoQ provides all the same breakdowns and details for character counts and wordcounts in staistics: words and characters are equal citizens for memoQ.)

Translators are probably more used to the Trados wordcounts, but this does not make the Trados wordcounts any more "scientific" or "accurate". They are in fact just approximate in both memoQ and Trados. And there are also many other factors that should taken into account when quoting for a job, but are often ignored: What is the quality of the source text? Is it possible to segment it correctly at all? How heavily is it formatted? Is it some more straightforward format like Word, or in a more technical one like FrameMaker?

Best regards,
Gergely Vandor

Kilgray


 

Tobias Werner  Identity Verified
Local time: 14:18
English to German
TOPIC STARTER
wordcount Nov 26, 2009

Hi again,

I already had a look at MemoQ and like it quite a lot but from my point of view there are still too many workarounds for using different tool formats.

My main problem were the 95-99% matches. In the Trados analysis I had around 92,000 100% matches and 2,000 95-99% matches, in MemoQ it was 74,000 100% matches and 13,000 95-99% matches. That makes quite a difference. Also the other matches were different, so as far as I can see MemoQ counted more words than Trados in this particular case. I guess it would have been much more work for me to look through all the 99% matches.

Tobias


 

Albatros  Identity Verified
Italy
Local time: 14:18
Member (2007)
English to Italian
Proposed workaround Nov 26, 2009

Hi Tobias,

as memoQ users who deal with Trados files on a regular basis, we often face exactly the same situation that you described.

As I understand it from several tests I ran personally and from the feedback I received from Kilgray support, the main cause are the tags contained in the TagEditor files. If you export a TMX file from Trados and import it into memoQ, not all the tags contained in the TMX are imported successfully into memoQ, so all those nice 100% matches will "degrade" to high fuzzies.

According to Kilgray (and I am inclined to think that this is the correct explanation), this is caused by the rather obscure format of some of the tags contained in the TagEditor files. They are already doing a good job of importing TMX files created by Trados, but the process is not perfect yet. I suppose that if Kilgray once again took a good look at some of those TagEditor tags and at the way they are converted into TMX, they could decrease the percentage of those imperfect matches.

For the time being, we work around this problem by using the following procedure:

1. Pretranslate all your TagEditor files using your most complete TM in Trados (you may consider setting all the penalties to 0% but that's up to you).
2. At the same time, presegment the files by using the "Segment unknown sentences" in Trados
3. Import all the pretranslated files into memoQ and create a view that includes all the files
4. Sort the view by match rate or create a filter that only shows 100% matches
5. Confirm all those 100% matches. From now on, they will be considered as such by memoQ, tags included
6. Run a new analysis in memoQ and you will obtain much better match rates.

I'm not completely sure that this workaround can be applied to your specific situation, but I hope it helps.
--
Roberto Savelli
Albatros Soluzioni Linguistiche

[Edited at 2009-11-26 11:18 GMT]


 

Grzegorz Gryc  Identity Verified
Local time: 14:18
French to Polish
+ ...
Partially pretlanslated Word files Nov 26, 2009

Tomás Cano Binder, CT wrote:

Indeed in MemoQ if you import a DOC or RTF file that has a single segment translated with Trados, MemoQ for some reason won't see the segments that are still untranslated, i.e. with no Trados codes.


In theory, you can import partially presegmented files but you should use the Add documenst as... function, select the Bilingual DOC/RTF filter and uncheck the case Do not import unsegmented content.

The quirk is MemoQ exports only cleaned text, so it's a one way ticket.

Cheers
GG

[Edited at 2009-11-26 13:21 GMT]


 

Tobias Werner  Identity Verified
Local time: 14:18
English to German
TOPIC STARTER
thanks Nov 26, 2009

Thanks a lot guys for all your tips and workarounds. Personally for me there is too much workaround and uncertainty if I'll be able to deliver usable files.

So for now I won't use MemoQ for this kind of translation work, only for "normal" translations.

@Grzegorz: I did import the files as you described.


 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Importing pretranslated bilingual RTF files

Advanced search






Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search