Skipping error check when exporting; splitting a file
Thread poster: Carl Freire
Carl Freire
Japan
Local time: 17:18
Japanese to English
Jan 3, 2010

Hi,

I'm experimenting with MemoQ on a project. I like the termbase management, but don't like the fact that I'm going to have waste a lot of time telling it to ignore supposed errors involving numbers, for example, just to get my project exported (hello, "12-month" in Japanese is "December" in English . . . and I can't enter these things in the termbase due to formatting tag interference on this document). I prefer to edit my text documents for quality control in Word, but it does not look like I can avoid this productivity-killing step so I can see already that I'll be much less inclined to use MemoQ in the future unless there's some way I can tell MemoQ to skip this check and just export the file. Anyone?

Second, a more pressing issue also related to exporting is that the client told me after I started the project that the end client has decided they don't need me to translate the last 15 pages or so (given that these are citations that include a lot of Russian and Chinese--two languages that I do not handle--I'm quite happy to hear this). Toward that end, I would like (=need) to delete all of the segments corresponding to those pages from the project. I have not come across anyway to do this, however. Can someone point me in the right direction? Of course, if I can get MemoQ to just export my documents without interference the need to do this becomes less pressing, but it still would be helpful to know if there is a way to do this.

Thanks.

Carl

[Edited at 2010-01-03 10:49 GMT]


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 10:18
Member (2005)
English to Spanish
+ ...
Avoiding QA issues when you want Jan 3, 2010

Carl Freire wrote:
I'm experimenting with MemoQ on a project. I like the termbase management, but don't like the fact that I'm going to have waste a lot of time telling it to ignore supposed errors involving numbers, for example, just to get my project exported (hello, "12-month" in Japanese is "December" in English . . . and I can't enter these things in the termbase due to formatting tag interference on this document).

I think I can help you with the number thing. Indeed, there are two things I find annoying or useful depending on the project: number check and terminology use check. You can enable and disable each feature (and many others) in your project as follows:

1. Open the project.
2. In the Project Manager (the list of files to be translated), select the Settigs pane. There, you will see "Project QA Settings".
3a. For number check (to disable it), uncheck the "Check for mismatched numbers" checkbox in the "Numbers" tab.
3b. For terminology consistency, uncheck the "Check for consistent use of terminology" in the "Terminology" group of the "Consistency and length" tab.

These same settings exist as global settings for all projects: In MemoQ's main menu, choose Tools > Options, select "QA Configuration" in the left handside pane, and there you see the same tabs as in the project settings. So depending on your usual work you can enable a feature globally and disable it on a project basis or the opposite.

I would read the online help of the QA settings tabs as they might give you more insight of how well you can configure the application based on your needs. I hope this helps!


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 10:18
Member (2005)
English to Spanish
+ ...
Replace the file Jan 3, 2010

Carl Freire wrote:
Second, a more pressing issue also related to exporting is that the client told me after I started the project that the end client has decided they don't need me to translate the last 15 pages or so (given that these are citations that include a lot of Russian and Chinese--two languages that I do not handle--I'm quite happy to hear this).

Indeed replaced files (or new instructions about parts to remove from a file) is normal business with any CAT tool. In this situation, I would simply edit the source file (to delete the unwanted parts as instructed by the customer) and would replace the file in the MemoQ project by simply removing the old file and adding the new one. As MemoQ contains positional (contextual) information, you can easily pretranslate the new file (from the editor after opening the new file in MemoQ, choose "Translation" > "Pre-translate" and enable the "Exact match with context" radio button), and you will see all your work there again up to the point where you had left it when you got the new instructions from the customer.

You will only have to confirm your previously translated segments after pretranslation. You do that by choosing "Translation" > "Confirm and Update Rows", making sure you enable the "100% or 101% pre-translated" checkbox only and leave "Edited", "Confirmed" and "Proofread" unchecked.

With a tiny bit of practice, the whole process of replacing the file, pretranslating, and confirming it to your previous progress should not take you more than one minute.

By deleting your file from MemoQ and adding the new file without the unnecessary bits, you will not be forced to copy the source text of the unneeded part to the target segments, which would yield a memory containing unnecessary segments in Russian and Chinese that you don't need in your memory at all.

I hope this helps!

[Edited at 2010-01-03 14:52 GMT]


Direct link Reply with quote
 

Jabberwock  Identity Verified
Poland
Local time: 10:18
Member (2004)
English to Polish
No need to... Jan 3, 2010

Tomás Cano Binder, CT wrote:
By deleting your file from MemoQ and adding the new file without the unnecessary bits, you will not be forced to copy the source text of the unneeded part to the target segments, which would yield a memory containing unnecessary segments in Russian and Chinese that you don't need in your memory at all.


There is no need for that - unlike DVX, MemoQ allows to export a file with empty target segments. Then the untranslated fragments will be missing in the target document, which is what is needed in this case.

If this does work, as it sometimes (rarely) happens, you can try another procedure - just copy source fragments to empty segments. As long as they are not confirmed (or confirmed without update, to be exact), the segments will not end up in your TM and you still can export the document.


Direct link Reply with quote
 
Carl Freire
Japan
Local time: 17:18
Japanese to English
TOPIC STARTER
Re: Avoiding QA issues when you want Jan 4, 2010

Tomás Cano Binder, CT wrote:

1. Open the project.
2. In the Project Manager (the list of files to be translated), select the Settigs pane. There, you will see "Project QA Settings".
3a. For number check (to disable it), uncheck the "Check for mismatched numbers" checkbox in the "Numbers" tab.


I was afraid someone was going to point this out, afraid because I quickly discarded it as a solution. The reason it doesn't work is simply that sometimes there really are wrong numbers (it found I had mistyped 3,456 as 3,465, for example).

However . . .


3b. For terminology consistency, uncheck the "Check for consistent use of terminology" in the "Terminology" group of the "Consistency and length" tab.


. . . this may solve some misreported error issues. For example, the issue of dates is a bit complicated in the document (which I finished), since some dates were in the lunar calendar and some dates were in the solar calendar. When referencing lunar calendar dates, "5-month" needs to be rendered as some variation of "5th month", but in the solar calendar we are free to use "May."

I have a few more historically related projects in the pipeline, so I may get to give this a test again. As you say, the utility of these settings can vary from project to project.


Direct link Reply with quote
 
Carl Freire
Japan
Local time: 17:18
Japanese to English
TOPIC STARTER
An export solution, and a documentation issue Jan 4, 2010

Jabberwock wrote:

There is no need for that - unlike DVX, MemoQ allows to export a file with empty target segments. Then the untranslated fragments will be missing in the target document, which is what is needed in this case.


How to do this was not immediately apparent. I discovered it accidentally after . . .


If this does work, as it sometimes (rarely) happens, you can try another procedure - just copy source fragments to empty segments. As long as they are not confirmed (or confirmed without update, to be exact), the segments will not end up in your TM and you still can export the document.


. . . first going through this time-consuming procedure to export my document. I subsequently learned that using "Export All Documents" allows you to export all documents and ignore the error-resolution procedure, while "Export Active Document" does not. I do not see this clearly noted anywhere in the documentation. If it is, someone please point it out. Otherwise, sounds like another item to add to the next iteration of the manual.

Incidentally, I like OmegaT in this regard, since it simply exports with no questions asked (as does WordFast, although the interface paradigm of course is different). However, MemoQ has features OmegaT lacks, so what are you going to? Technology is always forcing us to adapt to it rather than the other way around. Sigh.

As to tinkering with the source file as Tomás suggested, while it has possibilities the problem with using it on this particular document would have been that MemoQ experienced numerous "hiccups" in properly segmenting the original file, due to a combination of Japanese punctuation quirks and author punctuation quirks. Many of these segmentation errors had already been dealt with by the time a split became necessary, so it may have become rather . . . "interesting" to see how MemoQ would have reapplied the translations.

Anyway, thanks to both of you for the tips.


Direct link Reply with quote
 

Jabberwock  Identity Verified
Poland
Local time: 10:18
Member (2004)
English to Polish
It is rather inconsistent... Jan 4, 2010

The first test I ran was with "Export active document", so it does work sometimes... Not always unfortunately, as I found out now.

This time I tried to export active document with tags - this prevents exporting the document with empty segments. While I do see the logic behind it (exporting a document without appropriate tags is a bad idea most of the time!), there should be an option to ignore it specifically...

I was wondering whether MemoQ could use a "prefill" function, like the one some of the localization packages have. This would allow to fill the empty segments with gibberish, specified strings or another lore ipsum text. Naturally, this would require yet another segment marker, as they need to be cleaned (semi-)automatically afterwards.

Of course, this goes beyond the case described originally in this thread - exporting the target document before it is completely translated is quite useful and should not involve too many manual operations...


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Skipping error check when exporting; splitting a file

Advanced search






Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search