Angle quotes instead of straight quotes
Thread poster: Profdoc

Profdoc
Local time: 15:31
Swedish to English
Mar 1, 2011

A colleague of mine, translating from Swedish to Norwegian in memoQ, has run in to the following problem: she gets angle quotes (») instead of straight style quotes (") when she presses the quotation mark key (shift+2). She wants straight style quotes. How do you solve this?

 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 15:31
Member (2005)
English to Spanish
+ ...
Easy Mar 2, 2011

Just disable the angle quotes in memoQ as follows:

Menu Translation > AutoCorect > disable the "Replace straight quotes with smart quotes" checkbox.

This should do it!


Ana Cardoso
 

Profdoc
Local time: 15:31
Swedish to English
TOPIC STARTER
Thanks! Mar 2, 2011

That did it!

 

Epameinondas Soufleros  Identity Verified
Greece
Local time: 16:31
Member (2008)
English to Greek
+ ...
The next step Mar 2, 2011

The next step would be to add regex support in Find & Replace, so that the translator can convert the straight quotes to the correct typographic ones, as needed. For example, the 'normal' quotes in Greek (and in other languages) are «». However, when you need to enclose a foreign word in quotation marks, you'd better use those: “”. So, the "Replace straight quotes with smart quotes" checkbox is not of much help in such situations. This could be easily fixed once regexes are supported in Find & Replace or once memoQ becomes so intelligent as to recognize whether the character following an opening quotation mark and preceding a closing quoation mark is of the Greek or of the Latin alphabet, and change the quotation marks accordingly. This 'language-awareness' and 'language-adaptiveness' would also allow memoQ to check your translation using the dictionaries of more than one language. It should check for spelling errors using at least two dictionaries: the one of your target language and the one of your source language. I can't see why this hasn't happened so far. Word does it with "detect language automatically", and so should a CAT tool, given that all too often we have to copy parts of the source text into our translations.

 

ahmet alpan  Identity Verified
Turkey
Local time: 17:31
English to Turkish
+ ...
Thanks! Dec 10, 2016

Thanks!

 

Michael Beijer  Identity Verified
United Kingdom
Local time: 14:31
Member (2009)
Dutch to English
+ ...
also very useful: Dec 10, 2016

http://www.translatortools.net/word-quotationmagic.html

Michael


 

Deniz Atlas Erbil  Identity Verified
Turkey
Local time: 17:31
Member (2011)
English to Turkish
+ ...
Thanks! Jan 16

Tomás Cano Binder, BA, CT wrote:

Just disable the angle quotes in memoQ as follows:

Menu Translation > AutoCorect > disable the "Replace straight quotes with smart quotes" checkbox.

This should do it!


 

Anthony Rudd

Local time: 15:31
German to English
+ ...
Regex support in Find/Replace Feb 6

Newer versions of memoQ support regexes in Find/Replace (as of memoQ 2015, Build 171)

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Angle quotes instead of straight quotes

Advanced search






WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search