Which NET framework?
Thread poster: Piotr Bienkowski

Piotr Bienkowski  Identity Verified
Poland
Local time: 15:42
Member (2005)
English to Polish
+ ...
Jun 25, 2011

Does MemoQ use a specific version of the NET framework or does it use the latest available version?

I installed MemoQ 4.5 bought recently on Windows 7 and it runs smoothly, but on Win XP SP3 I can only get as far as trying to open a file I added to the project. An error is thrown and I guess it has something to do with NET. So, the translation grid does not display.

The computer with Win XP SP3 has microsoft .NET 3.5

I guess it's a question to be put to sup
... See more
Does MemoQ use a specific version of the NET framework or does it use the latest available version?

I installed MemoQ 4.5 bought recently on Windows 7 and it runs smoothly, but on Win XP SP3 I can only get as far as trying to open a file I added to the project. An error is thrown and I guess it has something to do with NET. So, the translation grid does not display.

The computer with Win XP SP3 has microsoft .NET 3.5

I guess it's a question to be put to support at Kilgray but it is not very urgent (I can use MemoQ on Windows 7), and maybe there are other people with a similar situation who may benefit from the answers given.

Regards,

Piotr
Collapse


 

Dominique Pivard  Identity Verified
Local time: 16:42
Finnish to French
I think it's v. 2.0 Jun 25, 2011

Piotr Bienkowski wrote:
Does MemoQ use a specific version of the NET framework or does it use the latest available version?

I seem to remember it's v. 2.0, but you probably want to ask Kilgray for confirmation.


 

Piotr Bienkowski  Identity Verified
Poland
Local time: 15:42
Member (2005)
English to Polish
+ ...
TOPIC STARTER
The error I get is Jun 25, 2011

Dominique Pivard wrote:

Piotr Bienkowski wrote:
Does MemoQ use a specific version of the NET framework or does it use the latest available version?

I seem to remember it's v. 2.0, but you probably want to ask Kilgray for confirmation.


Code:

TYPE:
System.MissingMethodException

MESSAGE:
Method not found: 'Boolean System.Threading.WaitHandle.WaitOne(Int32)'.

SOURCE:
MemoQ.Controls

CALL STACK:
at MemoQ.Controls.MainTabHeader.ScrollToRightEnd()
at MemoQ.Controls.MainTabControl.ScrollHeaderToRightEnd()
at MemoQ.ApplicationFramework.WindowManager.OpenTab(Document document, Boolean activate, Object initData)
at MemoQ.ApplicationFramework.WindowManager.OnShowDocument(Document document, Object initData)
at MemoQ.Project.ProjectDocument.ShowTranslationDocument(DocumentInfo tdi, Boolean activate, Boolean refreshResources)
at MemoQ.Project.ProjectDocument.ShowTranslationDocument(TranslationDocInfo tdi)
at MemoQ.Project.TranslationProjectSettingsControl.handleOpenTranslationDocument()
at MemoQ.Project.TranslationProjectSettingsControl.gvTranslations_CellMouseDoubleClick(Object sender, DataGridViewCellMouseEventArgs e)
at System.Windows.Forms.DataGridView.OnCellMouseDoubleClick(DataGridViewCellMouseEventArgs e)
at System.Windows.Forms.DataGridView.OnMouseDoubleClick(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.DataGridView.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)



 

Selcuk Akyuz  Identity Verified
Turkey
Local time: 16:42
Member (2006)
English to Turkish
+ ...
Version 2.0 SP2 Jun 25, 2011

http://kilgray.com/files/user-guide/memoQ_InstallingActivating_4_5_EN.pdf

Version 2.0 SP2 required, version 3.5 SP1 or newer recommended.

-------------------

In case of any problem with .net version this tool may help: .NET Framework setup verification tool

For details see See more
http://kilgray.com/files/user-guide/memoQ_InstallingActivating_4_5_EN.pdf

Version 2.0 SP2 required, version 3.5 SP1 or newer recommended.

-------------------

In case of any problem with .net version this tool may help: .NET Framework setup verification tool

For details see http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx


[Edited at 2011-06-25 15:43 GMT]
Collapse


 

István Lengyel
Hungary
Local time: 15:42
English to Hungarian
+ ...
you met our worst enemy :) Jun 25, 2011

Hi Piotr,

Please install .NET Framework 3.5 SP1 - the problem will go away.
Unfortunately we did not find an easy way to detect this, because it works fine on some computers, does not on others without .NET Framework 3.5 SP1. SP1 is needed, and 4.0 does not always solve the problem.
We're still trying to brainstorm for ideas how to incorporate this into the installation process, but it's not easy. Solving it is much easier than communicating it, but I am sure this has al
... See more
Hi Piotr,

Please install .NET Framework 3.5 SP1 - the problem will go away.
Unfortunately we did not find an easy way to detect this, because it works fine on some computers, does not on others without .NET Framework 3.5 SP1. SP1 is needed, and 4.0 does not always solve the problem.
We're still trying to brainstorm for ideas how to incorporate this into the installation process, but it's not easy. Solving it is much easier than communicating it, but I am sure this has already caused a lot of people to give up on using memoQ (rather than turning to support).

István
Collapse


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Which NET framework?

Advanced search






Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search