MemoQ keeps reverting to an old version of TM and termbase
Thread poster: gzevspero
gzevspero
Local time: 22:21
Hebrew to English
+ ...
Jul 6, 2011

Hi all,

I have a computer which I used to translate a few jobs on MemoQ some months ago, and then copied the TM and termbase to another computer, and have been working on that second one since then. Now I want to copy the TM and termbase back to the first computer and continue working from there. The TM and termbase both have had the same names throughout all this time, and are stored in the same path on both computers.

The problem is that when I copy the newer versions back onto the first computer, it only sees the entries I made on that computer several months ago. All the new additions I've made from the second computer, to both TM and termbase, are being ignored. I've tried removing them from the resource console and doing "register local" again - same problem. Tried deleting the TM and termbase folders from windows explorer and copying them over fresh - no help. Tried removing and reinstalling MemoQ on the computer - same thing. Tried changing the name of the TM / TB folders in windows explorer and then doing register local again - no help. Both computers are using the same version of the program (standard 4.5.68 - using this old version because newer builds run much slower on my computer for some reason).

I'm positive that the TM and termbase files I copied over to the first computer are the current versions though - I copied them into the appropriate folder where MemoQ is configured to look in Tools>Options>Locations, and have confirmed that they show the exact same file sizes, modify dates, etc., as the versions that I've been using on the second computer.

So for some reason MemoQ insists on reverting back to the old versions of these resources, and won't see any of the additions I've made all these months.

How can I clear out MemoQ's recollection of the old versions, and allow it to "start clean" and accept the updated versions?

MTIA,
Gadi


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 21:21
Member (2005)
English to Spanish
+ ...
Some information is stored outside of the memory directory Jul 6, 2011

I think memoQ contains information about the resources in places other than the TM itself. Your best solution is to:

1. Export the source memory to TMX format.
2. Delete the TM in the target machine, and create it anew.
3. Import the TMX.

This will make 100% sure you have the fullest memory. I think you cannot replace the memory files and expect memoQ to assume the new contents automatically. Does not work that way as far as I am aware.


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 21:21
Member (2005)
English to Spanish
+ ...
Location of information Jul 6, 2011

I am not sure this is any use to you or whether you can find a way to replace the TM without reimporting it, but the list of available memories is in the "Program Data" directory of your machine. For instance, in Windows XP it is in C:\Documents and Settings\All Users\Program Data (or whatever it is in your language)\MemoQ, more exactly in an XML file called "TranslationMemories.xml".

Please notice however that I have noticed that these XML files van vary from one memoQ revision to another, so you cannot simply copy the file or chunks of it from one machine to the other if they have different revisions.

[Edited at 2011-07-06 16:16 GMT]


Direct link Reply with quote
 
gzevspero
Local time: 22:21
Hebrew to English
+ ...
TOPIC STARTER
Problem solved! Jul 7, 2011

Excellent - I imported the TM as TMX and the termbase as CSV, and now both of them display the current data.

Thanks a lot!

Gadi


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 21:21
Member (2005)
English to Spanish
+ ...
You're most welcome! Jul 7, 2011

Yes, I think in this situation is best to import/export.

You can do the same with termbases, but with one important caveat: if you have images inserted in your termbase, they don't get imported in the new place. I think Kilgray might add some way of moving the images as well in the case of termbases.

Good luck!


Direct link Reply with quote
 

Roy Williams  Identity Verified
Austria
Local time: 21:21
German to English
Importing termbase from wordfast Jul 27, 2011

On a somewhat related topic, I'm currently working with MemQ on a trail basis. I recently tried to import my .txt termbase from wordfast to MemQ to find that only the field I desginated for the german terms (F0) was imported. The definition field (F1) was not however.

This is problematic, as I have over 260 terms and I don't want to manually retype the english definitions in for them. Wordfast Pro only offers two options for exporting a termbase: as .txt or .tbx. Since the .txt file is not importing correctly and MemQ does not support .tbx, what else can I try.

Any ideas would be greatly appreciated.


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 21:21
Member (2005)
English to Spanish
+ ...
What are the language fields? Jul 27, 2011

Roy Williams wrote:
On a somewhat related topic, I'm currently working with MemQ on a trail basis. I recently tried to import my .txt termbase from wordfast to MemQ to find that only the field I desginated for the german terms (F0) was imported. The definition field (F1) was not however.

To me this looks like the import was not carried out correctly. What columns do you have in your exported TXT file?


Direct link Reply with quote
 
rmackay
Local time: 20:21
Excel? Jul 27, 2011

Could you export it or convert it to an excel spreadheet file?

It may be that the answer lies there, as it is an easy import to memoq from an excel sheet.

not sure if that is an easy option though?

all the best - slàinte!


Direct link Reply with quote
 

Roy Williams  Identity Verified
Austria
Local time: 21:21
German to English
Re: Importing termbase from wordfast Jul 27, 2011

Tomás Cano Binder, CT wrote:

Roy Williams wrote:
On a somewhat related topic, I'm currently working with MemQ on a trail basis. I recently tried to import my .txt termbase from wordfast to MemQ to find that only the field I desginated for the german terms (F0) was imported. The definition field (F1) was not however.

To me this looks like the import was not carried out correctly. What columns do you have in your exported TXT file?


In the exported file, both the german column and english column are shown when opened in MemQ, however, the english column is completely empty. In the german column, all the german terms are listed. I have noticed though the the umlaut characters were not imported correctly.

Also, when I change the language in the english column to german, the german terms appear and I have two german language columns.

[Edited at 2011-07-27 10:11 GMT]


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 21:21
Member (2005)
English to Spanish
+ ...
What do you see in a text editor? Jul 27, 2011

Roy Williams wrote:
In the exported file, both the german column and english column are shown when opened in MemQ, however, the english column is completely empty. In the german column, all the german terms are listed. I have noticed though the the umlaut characters were not imported correctly.

OK, OK, but I mean: if you open your TXT file (the one you exported from Wordfast) in a text editor, do you see the English and German terms, plus your definition? If you do, it is just a matter of assigning the fields (F0, F1, etc.) correctly when you import the TXT file. If your TXT file only contains the German terms, the issue is more on the Wordfast side: you must have exported something incorrectly.

As for the encoding, the first you want to do in the import dialog is to choose the right encoding. memoQ assumed UTF-8 by default, but most Windows-based applications export in Latin 1. Choose the Latin 1 encoding when importing the file.


Direct link Reply with quote
 

Roy Williams  Identity Verified
Austria
Local time: 21:21
German to English
Yes Jul 27, 2011

In the TXT file in tab delimited form (opened in a normal text editor), the German term is visible plus the english translation thereof and the notes/comentary that I made regarding said term.

After selecting the file for import through the Term bases window:

In the import dialog box, the preview field at the bottom shows the German term in F0, the english definition in F1 and my comments in F2. I therefore assign the fields accordingly: F0 as the term, F1 as the definition and F2 as note. I hit OK and with Latin 1 selected, I see two import progress bars. Once completed I click the OK button next to both progress bars and close the dialog box.

However when I open the termbase by clicking edit, there are two columns; a german column and an english column. The german column is filled with the german terms but the english column is empty.

An additional note: I don't think it's possible to export incorrectly from word fast (unless theres some kind of bug I'm not aware of). One goes into terminology, selects the glossary then presses the export button. A dialog box then appears whereby one chooses the format; the options are tab delimited (TXT) or TBX. The file is exported in the selected format and that's basically it.

If something went wrong during the export, it was not detected.

[Edited at 2011-07-27 13:48 GMT]


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 21:21
Member (2005)
English to Spanish
+ ...
Definition? Jul 27, 2011

Roy Williams wrote:
In the import dialog box, the preview field at the bottom shows the German term in F0, the english definition in F1 and my comments in F2. I therefore assign the fields accordingly: F0 as the term, F1 as the definition and F2 as note. I hit OK and with Latin 1 selected, I see two import progress bars. Once completed I click the OK button next to both progress bars and close the dialog box.

Sorry but there is something I don't quite get: your termbase in memoQ must have the two fields activated, German and English.

Both for the German term AND the English term, you have to choose the option "Import as term". For German, choose "Import as term", and in the drop-down language list, choose the German language (it should appear at the top of the list).

Now you have what you call the "English definition", i.e. I assume that the English term. For that one as well, choose the "Import as term" option and choose the language.

For the notes, you want to add it as a description to either the German or the English language. To do so, choose the field, choose "Import as definition", and in the language list choose the language you want to assign this as a definition too.

Doesn't this resolve the problem? I suspect you are adding the English term as a "definition" when in fact should be a "term.


Direct link Reply with quote
 

Roy Williams  Identity Verified
Austria
Local time: 21:21
German to English
Aha! Jul 28, 2011

Tomás Cano Binder, CT wrote:


I suspect you are adding the English term as a "definition" when in fact should be a "term.


That's exactly what I did, as I was under the impression that term was meant to indicate the souce language word and definition meant the translation thereof in the target language.

All is well now. Thanks for your help!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

MemoQ keeps reverting to an old version of TM and termbase

Advanced search






Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search