Tags in memoQ Pro 4.5.77
Thread poster: Pablo Bouvier

Pablo Bouvier  Identity Verified
Local time: 00:00
German to Spanish
+ ...
Aug 27, 2011

Dear colleagues: I am using a MemoQ trail version to translate a TTX file of middle complexity. This file contains some tag formatting like "field" "cf" and sometimes when i press CTRL+ENTER all these tags disappear from the destination segment and I need to copy them one by one frome teh sorce text to the destination text. Someone knows how I can avoid this behaviour or how can I protect such tags? Thanks in advance for your kind support.

[Edited at 2011-08-27 18:53 GMT]


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 00:00
Member (2005)
English to Spanish
+ ...
Do you mean... Aug 28, 2011

Do you mean that, when you confirm one segment and that segment is reused in another segment, the new segment does not contain the tags that were contained in the translation you had done previously?

If this is what you mean, unfortunately this is a normal behaviour. MemoQ will only keep the tags that are exactly the same as in a previously translated segment. This means that tags like "/cf" (closing tag) should be preserved, but the opening cf tag will most probably not be preserved since it contains parameters that, very often, change from one segment to the next.


 

Pablo Bouvier  Identity Verified
Local time: 00:00
German to Spanish
+ ...
TOPIC STARTER
Tags in memoQ Pro 4.5.77... Aug 28, 2011

Tomás Cano Binder, CT wrote:

Do you mean that, when you confirm one segment and that segment is reused in another segment, the new segment does not contain the tags that were contained in the translation you had done previously?

If this is what you mean, unfortunately this is a normal behaviour. MemoQ will only keep the tags that are exactly the same as in a previously translated segment. This means that tags like "/cf" (closing tag) should be preserved, but the opening cf tag will most probably not be preserved since it contains parameters that, very often, change from one segment to the next.


Hi Tomas, thanks for your help. Maybe, I didn't noticed if this occurs with repetitions or fuzzies, but I believe it happens randomly or at least it happens also with segments that have exactly the same content and formatting.

Is there no way to protect the tags like in Trados WB or Tageditor? As I am not translating, but reviewing someone else's text this is an enormous waste of time.




[Edited at 2011-08-28 11:51 GMT]


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 00:00
Member (2005)
English to Spanish
+ ...
¡Ah! Aug 28, 2011

Pablo Bouvier wrote:
Is there no way to protect the tags like in Trados WB or Tageditor? As I am not translating, but reviewing someone else's text this is an enormous waste of time.

This explains it all! I did not quite get it.

Now, all you need to do is to select all segments (you have an option in the menus) and confirm all segments before proceeding to do the review. This will store the translator's segments in the memory.

What happened in your case was that, since the segment you were going to review was not present in the memory, memoQ replaced the translation with the closest translation in the memory, which probably did not have the tags.

I hope this helps!!


 

Gergely Vandor
Hungary
Local time: 00:00
English to Hungarian
explanation of this interesting problem Aug 29, 2011

(typo corrected)

Dear Pablo,

Let me add a few words to Tomas's explanation. A TTX document does not contain status information for the segments, and memoQ currently imports all the segments with "not started" status from TTX files. You can see it as gray color to the right of the segment.

The "not started" status means that memoQ feels free to overwrite the current translation with the best TM result at some points, including the point when you enter the segment after confirming the previous segment.

Tomas's suggestion works: if you confirm all the segments, memoQ will not overwrite the current translations anymore. Also, you can turn the whole "automatic insertion" feature in Translation menu > Automatic lookup and insertion. The setting you need to turn off is "Autromatically insert best result after confirming segments".

I think there's something we can do about this: memoQ shouldn't use the "not started" status for these segments, but the "edited" status.That would make this problem go away. I'll check this with the team. Thank you for your input!

Best regards,
Gergely



[Edited at 2011-08-29 13:39 GMT]


 

Pablo Bouvier  Identity Verified
Local time: 00:00
German to Spanish
+ ...
TOPIC STARTER
Tags in memoQ Pro 4.5.77 Sep 1, 2011

Hi Tomás and Gergely,

sorry for the delay answering to you. I had a health problem between; nothing serious, but painful.

Thanks a lot for your explanations. Nevertheless, I think that to be able to protect the tags in a reviewing mode or at least to be able to insert them easely in the target segment with F8, as like with the standard tags will be a better idea as to check all the segments as accepted before.

Imho, there are two reasons to do so:

a) a reviewing mode should be intended not to consider incorrect or changed segments as accepted until the translator has accepted or denied the corrections.

b) with very large texts it is quite easy to forget until wich segment has been revised, if all segments have been accepted before.

Have a nice time!

[Edited at 2011-09-01 19:29 GMT]


 

Gergely Vandor
Hungary
Local time: 00:00
English to Hungarian
insert easilyby pressing F9, for protection, there is QA Sep 1, 2011

Hi Pablo,

Please try F9 for inserting an inline tag. Also, the quality assurance module will warn you if you forget to insert a tag and confirm a segment, I recommend that you take look at QA if you haven't done so yet.

"Tag protection" inside segments is too limiting to my taste, this is one Trados feature that I always turned off. There are cases when you don't want a tag in the translation, for example.

Best regards,
Gergely


 

Angel Llacuna  Identity Verified
Spain
Local time: 00:00
English to Spanish
Gergely, ... May 19

Gergely Vandor wrote:

....................................................

"Tag protection" inside segments is too limiting to my taste, this is one Trados feature that I always turned off. There are cases when you don't want a tag in the translation, for example.

Best regards,
Gergely



how do you turn off and on the tag protection on the target segments ?
I use the latest version : memoQ 8.3

[Edited at 2018-05-19 05:36 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Tags in memoQ Pro 4.5.77

Advanced search






PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search