General error when opening MemoQ
Thread poster: GreenUK
Aug 17, 2012

Hello,

I installed MemoQ (initially version 6 but I have since also tried version 5) on my new laptop and haven't been able to open it since. It installs absolutely fine, but when I try and open it I get the following general error message:

TYPE:
System.InvalidOperationException

MESSAGE:
There is an error in XML document (0, 0).

SOURCE:
System.Xml

CALL STACK:
at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
at System.Xml.Serialization.XmlSerializer.Deserialize(Stream stream)
at MemoQ.Common.SerializationHelper.DeserializeXML(Type objType, String filePath)
at MemoQ.Common.Application.AppPreferences.load()
at MemoQ.Common.Application.AppPreferences.get_Instance()
at MemoQ.TranslationMemory.TranslationMemoryManager..ctor()
at MemoQ.TranslationMemory.TranslationMemoryManager.get_Instance()
at MemoQ.Application.MemoQApp.InitHeavyResourceManagers()
at MemoQ.Application.MemoQApp..ctor()
at MemoQ.Application.MemoQApp.InitGlobalSettings()
at MemoQ.MainWindow.mainCore(String[] args)
------------------ Inner exception ------------------

TYPE:
System.Xml.XmlException

MESSAGE:
Root element is missing.

SOURCE:
System.Xml

CALL STACK:
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlTextReader.Read()
at System.Xml.XmlReader.MoveToContent()
at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderAppPreferences.Read3_AppPreferences()

This always seems to happen when the loading screen says "Loading settings... Loaded DLL: Genuine Channels.dll"

I never had this problem on my previous laptop and have searched around online for a solution but haven't managed to find anything. As I have only just installed MemoQ on my laptop there are obviously no current projects saved on here.

Any help in solving this issue would be very much appreciated. My laptop is running Windows 7 64-bit and I have downloaded all available updates.

Many thanks in advance.


Direct link Reply with quote
 

Textklick  Identity Verified
Local time: 05:39
German to English
+ ...
Go Kilgray Aug 17, 2012

Maybe you should have loaded 5 first? Who knows?

Support@kilgray.com provide detailed help (which you obviously can't see) and excellent site support with 'misbehaving' files.

In this case (general error) I'd guess they are are unavoidable - and you will find them refreshingly prompt and useful.

Good luck
Chris


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 07:39
Finnish to French
Delete TranslationMemories.xml Aug 17, 2012

GreenUK wrote:
Any help in solving this issue would be very much appreciated.

FWIW, here is the advice provided by Kilgray's Gábor Ugray on the memoQ mailing list, when someone encountered the same error message:

please delete this file when memoQ is not running:
C:\ProgramData\MemoQ\TranslationMemories.xml

After this, memoQ will start up, but the resource console will not show any TMs. Don't worry, the TMs are all there, you can put them back on the list by using Register local.


Direct link Reply with quote
 
GreenUK
TOPIC STARTER
Suggestion unfortunately did not work Aug 17, 2012

Many thanks for your replies!

I got in touch with MemoQ support and they suggested deleting the AppPreferences.xml file but unfortunately this did not solve my problem. I have now just deleted the TranslationMemories.xml file but MemoQ will still not open and is displaying the same error message.

Thank you anyway. I'm hoping that if nobody has anything else to suggest here, then MemoQ support will contact me again on Monday with further suggestions.


Direct link Reply with quote
 

Simon Mountifield  Identity Verified
Local time: 06:39
French to English
Same problem Aug 19, 2012

Hi,

I've had a similar problem twice.

This first time, I had been working on a project where the translation memories and everything else were saved on an external hard drive. The next time I opened MemoQ, I had forgotten to plug the external hard drive back in, and since MemoQ obviously couldn't find the last project and TMs that I had been working on, it refused to open with a General Error. After reconnecting the hard drive, MemoQ opened straight away.

The second time, I was using MemoQ when my computer suddenly crashed. Ever since, I've been unable to get MemoQ to work and I get an identical error code to yours. I've scoured the Internet in search of possible workarounds (including the ones posted in this thread), all to no avail. I've even tried deleting and reinstalling MemoQ, but still no joy, which makes me think I must have a corrupt file somewhere (either a MemoQ file or a Windows system file).

I must admit that I haven't had time yet to contact Kilgray, but if you do get a solution to your particular problem, could you post it here please?

Good luck!

Simon


Direct link Reply with quote
 
GreenUK
TOPIC STARTER
Reply with answer Aug 19, 2012

Hi Simon,

Thanks for your reply.

I still haven't managed to get MemoQ to work but am aiming to get back in touch with the support team tomorrow to try and resolve my issue. I'll be sure to post any suggestions I receive from them on here as it seems I'm not the only one having this problem.


Direct link Reply with quote
 
GreenUK
TOPIC STARTER
Solution Sep 2, 2012

Hi everyone,

Apologies for the delay but I've been on holiday and only just had chance to get my issue with memoQ resolved. In the end the support team were extremely helpful and took remote control of my laptop and solved the issue themselves. It seemed to be a matter of reinstalling the software and deleting a specific file (unfortunately I didn't catch which file in particular). My advice to anyone still experiencing problems is to contact the support team directly as they are extremely helpful and efficient.


Direct link Reply with quote
 

Simon Mountifield  Identity Verified
Local time: 06:39
French to English
Kilgray support Sep 3, 2012

Hi,

Glad to hear you've got the problem sorted. Thanks for the feedback - I'll have to get in touch with Kilgray to get my version running again.

Simon


Direct link Reply with quote
 
olgarudic
Moldova
English to Romanian
+ ...
it worked in my case Aug 28, 2014

http://kb.kilgray.com/article/AA-00643/0/General-error:-Corrupt-Monolingual-review-xml-file.html

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

General error when opening MemoQ

Advanced search






TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search