"Placeables" in memoQ
Thread poster: John Fossey

John Fossey  Identity Verified
Canada
Local time: 21:00
Member (2008)
French to English
Aug 19, 2013

I am trying out memoQ and attempting to set up what would be called a "placeable" rule in WF. There are evidently "auto-translation" rules for numbers, with regexes that identify the numbers and replace commas with decimal points, etc. The numbers in the source text are bracketed with a blue underscore and pressing Ctrl brings up the list of source strings that match the search expressions.

So I have set up an auto-translate rule regex, /\b([A-Z][a-z]+)\b/, which correctly identifies proper nouns that start with a capital. But I can't find out how to have the proper noun strings in the source text that should be identified by the regex included with the underscored list. I have checked "Recognize terms, auto-translateables and non-translateables" in the AutoPick tab as well as "Always show AutoPick markers in the source text", but no luck.

Can someone shed some light on how to do this?

[Edited at 2013-08-19 19:47 GMT]


 

Tomasz Sienicki  Identity Verified
Denmark
Local time: 03:00
Member (2007)
Danish to Polish
+ ...
Works in 6.5.11 Aug 20, 2013

If it's any help, it works for me in 6.5.11 (the terms are both highlighted in green and underlined in blue -- available both in the resulats pane and in the AutoPick list). Double-check everything.

BTW, this regex is better:


(?<=[^<])\b(\p{Lt}|\p{Lu})\p{Ll}+\b


as it excludes the first word in a segment and includes upper-case national characters, that is words like Świnoujście or Ærøskøbing (city names).


 

John Fossey  Identity Verified
Canada
Local time: 21:00
Member (2008)
French to English
TOPIC STARTER
Still doesn't work Nov 15, 2013

In the meanwhile, I have purchased memoQ 2013 and still haven't found how to make this work. Googling the problem just brought me back to my own question here. Can anyone help?

I have set the Auto-Translation rule as suggested, checked "Recognize terms, auto-translatables and non-translatables" in the AutoPick tab, Enabled AutoPick amd "Always show AutoPick markers in the source text", but nothing happens. What am I doing wrong?


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"Placeables" in memoQ

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search