Error: "Failure to add entry to translation memory"
Thread poster: Jenny Duthie

Jenny Duthie  Identity Verified
France
Local time: 19:17
French to English
Jan 28, 2014

Hello, I'm using an upgrade of MemoQ, MemoQ 2013 R2, which I recently received; the previous version was MemoQ 6.2. I have just started using this upgraded version; I've started a new project today for an existing client. I already have the TMs and projects from the old version of MemoQ, which are accessible in this new version, but it looks like the old TM is not loaded into this new version of MemoQ, because whenever i confirm a segment I get the following error message:

MESSAGE:
Cannot add a new TM entry if the TM is not loaded.

SOURCE:
MemoQ.TranslationMemory.GUI

CALL STACK:
à MemoQ.TranslationMemory.LocalHandler.AddEntry(TMProjectInfo projectInfo, TMEntry entry)
à MemoQ.Translation.DelayedTMConfirmer.doOneItem(DelayedTMConfirmItem item)

When I click on "Translation Memories" in "Project Home" I can see the TM for this project it is ticked as the Primary TM, however when I click "Repair resource" for example it says "the translation memory cannot be indexed: the TM has been deleted"....

Any suggestions, please? Thank you.


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 19:17
Member (2005)
English to Spanish
+ ...
Project migrated? Jan 28, 2014

I reckon that it's best that you email Kilgray, but my first thought is that somehow the definition of the memory in your project no longer matches that of memoQ 2013. While in your project, have you tried going to the Translation Memories pane, deselect the memory you had, and then select the memory again? This way the project will contain a link to the memory after the migration to 2013.

I hope this helps!


 

Jenny Duthie  Identity Verified
France
Local time: 19:17
French to English
TOPIC STARTER
The TM has now disappeared!! Jan 28, 2014

Thanks Tomas, however, I just deselected that particular memory, and it has disappeared! I can't get it back, any suggestions?? Help!!

 

Jenny Duthie  Identity Verified
France
Local time: 19:17
French to English
TOPIC STARTER
WORKING NOW THANKS!! Jan 28, 2014

I created a new TM and re-loaded the .tmx file and it's now working, thanks for your help Tomas!

 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 19:17
Member (2005)
English to Spanish
+ ...
Did you install 2013 and then R2? Jan 28, 2014

I think I remember that the change from 6.2 to 2013 (which is 6.5 in reality) means a migration of the databases with the memories etc. Do you remember having done such a migration (it should happen automatically when you install 2013).

When I read that you installed 2013 R2 on 6.2, I immediately wondered whether you should have installed 2013 first, and then R2.


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 19:17
Member (2005)
English to Spanish
+ ...
That's great news! Jan 28, 2014

Jenny Duthie wrote:
I created a new TM and re-loaded the .tmx file and it's now working, thanks for your help Tomas!

Glad to hear that!icon_smile.gif Just in case, you might want to export your memories to TMX and re-create them with that in the new version when you have a quieter moment.


 

Daniel Fernandes  Identity Verified
Brazil
Local time: 14:17
French to Portuguese
+ ...
Open the old MemoQ version and execute the Repair Resource option Jan 7, 2015

Hi!

I had this same problem and the last version of MemoQ wasn't allowing me to export the Translation Memory to a .TMX file nor allowing me to execute the "Repair Resource" option. The "broken" Translation Memory is very big and it'd be a huge loss if I couldn't get it repaired... Then — Eureka! — I opened the previous version of MemoQ, reached the "broken" Translation Memory through the Console and clicked on "repair resource" option. It worked smoothly. I'd exported the "repaired" Translation Memory to a .TMX file — just in case the repair hadn't worked, then I'd have at least a .TMX file to import to a new Translation Memory —, but it was needless. I closed the previous version of MemoQ and reopened the last version and the now "fixed" Translation Memory was working well!

Have a nice repair!icon_smile.gif


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Error: "Failure to add entry to translation memory"

Advanced search






WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search