Continuous issue with numbers in MemoQ
Thread poster: Marinus Vesseur

Marinus Vesseur  Identity Verified
Canada
Local time: 16:03
English to Dutch
+ ...
Jan 25, 2015

Does anyone else have this annoying issue with numbers in MemoQ? It gives me up to 99% hits despite the fact that the number often is totally different. Why is it so hard to have MemoQ recognize numbers and repeat them EXACTLY as they are in the source, dammit? That's the first and most basic of all rules for a CAT tool: NEVER change the numbers.

Anything you know that can be done about it? Support just shrugs. They'll pass it on, is what they say.

Numbers%20troubles_4.jpg


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 01:03
Member (2005)
English to Spanish
+ ...
Numbers are replaced automatically Jan 25, 2015

Numbers in segments (or segments containing only numbers) are replaced automatically with the source when you stop at the segment, as long as they have the same number of digits. They show up as 99% matches. With memoQ 2014 I have noticed that they do not get adapted when you pretranslate with "Good match", as happened previously in memoQ 2013.

In any case, if you have lots of figures or non-translatable bits and pieces in your files, you always have the option to sort the list alphabetically by source (or by source length if that helps better) using the sorting method list in the grid, select all rows containing non-translatables, copy source to target and confirm. You would have these solved in seconds!


 

123Translations
Venezuela
Local time: 19:03
Member (2008)
Dutch to English
+ ...
Looks like an add-in Jan 26, 2015

Hi Marinus,

If I look at the screenshot you posted, I see that MemoQ actually gives the correct result. Most of the results that show up, however, seem to come from some sort of add-in. (I have no MT or add-ins active on MemoQ, so I don't recognise any of them, sorry)

Have you tried de-activating the add-ins?

Good luck with it.

Cheers,


Peter


 

Marinus Vesseur  Identity Verified
Canada
Local time: 16:03
English to Dutch
+ ...
TOPIC STARTER
Sorting was great, but where is it now? Jan 26, 2015

Thank you, Tomás. Sorting really helped, but today I noticed that the button for sorting has disappeared. There is a search filter in the same spot now. Any idea how I can bring the sorting option back?




Tomás Cano Binder, CT wrote:

In any case, if you have lots of figures or non-translatable bits and pieces in your files, you always have the option to sort the list alphabetically by source (or by source length if that helps better) using the sorting method list in the grid, select all rows containing non-translatables, copy source to target and confirm. You would have these solved in seconds!



 

Marinus Vesseur  Identity Verified
Canada
Local time: 16:03
English to Dutch
+ ...
TOPIC STARTER
MemoQ results window cannot be trusted for numbers Jan 26, 2015

Hi Peter. Thanks, but that is not the issue. The results window shows me all the numbers that are in the TM, LiveDocs or Muse, but MemoQ does its own thing when it comes to numbers. The number that is in the target segment was put there by MemoQ - it is not connected to the source number in the Search Results window, yet that is what was entered. Weird? Absolutely! Helpful? To the contrary.

Peter van der Hoek wrote:

Hi Marinus,

If I look at the screenshot you posted, I see that MemoQ actually gives the correct result. Most of the results that show up, however, seem to come from some sort of add-in. ..

Peter


[Edited at 2015-01-26 18:51 GMT]


 

Bogdan Dusa  Identity Verified
Romania
Local time: 02:03
English to Romanian
+ ...
You could try filtering Feb 12, 2015

Hi Marinus,

The easiest way to deal with numbers in memoQ is to display them using the filter drop-down field, then copy them all in to the target side and confirm the segments (with or without updating the TM, it's up to you).

So, you don't use the filter funnel, but the Sort drop-down field next to it. The default option is No sorting. Choose Source text length (shorter first). The shortest segments will be displayed first and that includes, of course, number-only segments. Unfortunately, memoQ has no Number-only display feature as in SDL Studio, for instance, nor does it allow displaying them using Regex codes inside the file. But the Source text length (shorter first) option will do just fine.

Good luck!

Bogdan


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Continuous issue with numbers in MemoQ

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search