Capital letter issue in the Term Base
Thread poster: Zeki Guler

Zeki Guler  Identity Verified
Ireland
Local time: 02:33
Member (2012)
English to Turkish
Aug 20, 2015

Hi,

I want to enter just once, and to see it works in all cases above, regardless of whether there are any capital letters or not. In other words, I dont want to enter the same term several times to the TB, by changing the letters to the capital and vice versa. For example:
Xyz > Xyz
xyz > xyz
XYZ > XYZ
xYZ > xYZ

How can I do it?

Thanks,


Direct link Reply with quote
 

Stepan Konev  Identity Verified
Russian Federation
Local time: 04:33
English to Russian
New term defaults Aug 20, 2015

You can disable the case sensitive mode for all new entries:
Select your TB => Properties => New term defaults => Select source or target language => Select 'No' for 'Case sensitivity'.

However the result (target) from TB will always be the same case (as you typed it when adding term).
E.g. if you add Xyz > Xyz, you will have
xyz > Xyz
XYZ > Xyz
xYZ > Xyz

This is because you may have more than one word in a TB entry with different number of words in source and target.
For example, three English words 'Permit to Work' become two hyphen-separated words in Russian: 'наряд-допуск'.
In this case, memoQ just cannot identify how to behave with capitalization.


Direct link Reply with quote
 

Zeki Guler  Identity Verified
Ireland
Local time: 02:33
Member (2012)
English to Turkish
TOPIC STARTER
How about %100 case sensitivity ? Aug 20, 2015

Is there a way to enter just one term, but get various versions of it depending on what I type (with capital letters) ?

I mean I want to enter just xyz>xyz, but when I type the same word with a capital letter, I want to view its capital version like these :
e.g. xyz > xyz, Xyz> Xyz , XYZ>XYZ ...etc.

Does setting case sensivity to %100 provide me with these results ?


Direct link Reply with quote
 

Stepan Konev  Identity Verified
Russian Federation
Local time: 04:33
English to Russian
Nope Aug 21, 2015

No, you can't. I've explained above why this is not possible. memoQ (like any other CAT tool) is not a crystal ball to forsee which words need capitalization.

The only way to do so is adding all capitalization variants as synonyms. But if you do so each time, you may have your TB clogged with messy variants.
Use shift+F3 for capitalization as a possible solution.

[Edited at 2015-08-21 07:56 GMT]


Direct link Reply with quote
 

Châu Nguyễn  Identity Verified
Vietnam
Local time: 08:33
English to Vietnamese
+ ...
I did not manage to do it Aug 23, 2015

Stepan Konev wrote:

You can disable the case sensitive mode for all new entries:
Select your TB => Properties => New term defaults => Select source or target language => Select 'No' for 'Case sensitivity'.

However the result (target) from TB will always be the same case (as you typed it when adding term).
E.g. if you add Xyz > Xyz, you will have
xyz > Xyz
XYZ > Xyz
xYZ > Xyz

This is because you may have more than one word in a TB entry with different number of words in source and target.
For example, three English words 'Permit to Work' become two hyphen-separated words in Russian: 'наряд-допуск'.
In this case, memoQ just cannot identify how to behave with capitalization.


I set New term defaults to No for both languages. I entered the term as xyz > abc. And MemoQ still did not suggest the term when I typed Abc, I have to type abc before MemoQ gives suggestion. This is a minor but really frustrating issue. I don't want to clog my TB with variants of different cases of the same term.


Direct link Reply with quote
 

Stepan Konev  Identity Verified
Russian Federation
Local time: 04:33
English to Russian
If you entered xyz > abc... Aug 23, 2015

...what term do you expect from memoQ TB when typing 'Abc'?

It works so that when you have Xyz or xYz or xyZ or XYz or XyZ... in the source part, you will always have 'abc' as a result from TB.

memoQ suggests you 'abc' (which is a target term) when you type 'abc' and does not suggest 'abc' when you type 'Abc' _becuase_, in this case, it uses Autosuggest mechanism, but not the Termbase.

If you want to disable the Autosuggest case-sen'ty, go to Translation -> Predictive typing... -> Uncheck Suggestions are case-sensitive.

[Edited at 2015-08-23 22:56 GMT]


Direct link Reply with quote
 

Haralabos Papatheodorou  Identity Verified
Greece
Local time: 04:33
Member (2008)
English to Greek
+ ...
Disabling capitalisation of terms Apr 25

To ignore case sensitivity, you need to set the case sensitivity attribute of each and every term in the term base to No. Go to Tools > Resource Console, and select Term bases, then select the term base you want to edit and click Edit. After this select all terms by pressing Ctrl+Shift+A. At the bottom of the screen you see the two selected languages. Under the language where you want to ignore case sensitivity select Case sensitivity and select No. A dialog appears, click Yes. Now your terms will be recognised regardless of their case.

(Source: http://kb.memoq.com/article/AA-00425/0/Disabling-capitalisation-of-terms.html)


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Capital letter issue in the Term Base

Advanced search






BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search