Error message while importing Word file with a chained filter
Thread poster: Pargeo
Pargeo
Russian Federation
Local time: 09:57
English to Russian
+ ...
Aug 24, 2015

Hi,
A question from a newbie (studying the programme during the trial period):

I tried to import a Word file using a filter which removes portions of the text (namely, beginning-of-line dashes, numbers etc.). The filter works ideally on the preview file, but when I try to use it on the actual document, the following error message comes out:
Inline tags and memoQ {tags} are allowed to appear only after the last chained filter. Unsupported tag "rpr" found in the previous filter's output.:"
... and the file fails to import.

The cascaded filter (Regex text filter) is configured as follows - in "Include / Exclude":
1. \-\s (with "^" in "before") - to remove beginning-of-paragraph dashes
2. \d{1,}\.\d{1,}[\s\t]* (with "^" in "before") - to remove legal style numbering
3. \(?[a-zA-Z0-9]+[\.\)][\s\t]* (with "^" in "before") - to remove the remaining numbering.

As I said, this works on the preview and on my Excel test file, but it fails to import the actual file containing various formatting.

What am I doing wrong? Is there any way to make this cascading filter work properly not only on the test file?

(MEMOQ version 7.8.53)


Direct link Reply with quote
 
Manuel Arcedillo
Spain
Local time: 10:57
English to Spanish
It works for me in simple docx and xlsx file Aug 25, 2015

Hi,

Those rules worked fine for me. I tested docx and xlsx files with these three lines:

- Text
2.1 Text
A. Text

And only "Text" was imported in all cases. Have you tried importing the file without the regex filter? If it does import fine, try each rule one by one to see if only one of them causes the problem.

You can also try contacting memoQ support and sending them your file so they can fix the filters in case it is a bug with specific formats.

[Edited at 2015-08-25 10:47 GMT]


Direct link Reply with quote
 
Pargeo
Russian Federation
Local time: 09:57
English to Russian
+ ...
TOPIC STARTER
Kilgray answered... Aug 25, 2015

I've got a reply from Kilgray - which I should have figured out by myself, unfortunately.

Essentially, only the LAST-IN-CHAIN filter may generate any tag, but not the first one. So, if the primary filter (the one which imports the file) encounters ANY formatting tag, this error message is generated. This means that in order for this filter to work, the document to be imported essentially may not contain any change in formatting within the segments. That is why these filters worked on my sample Word and Excel documents and refuse to work on the actual document I need to import for translation.

The Kilgray engineer said this is 'by design' (Why???) and advised me to mark up the original document (sure, and what about the Excel and PowerPoint docs which don't even have the ability to mark up the text as hidden???)

Very disappointed, tbh...


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Error message while importing Word file with a chained filter

Advanced search






WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search