Importing Excel files with "select ranges in Excel" fails
Thread poster: Vito Smolej

Vito Smolej
Germany
Local time: 10:53
Member (2004)
English to Slovenian
+ ...
Jan 6, 2016

On importing Excel files, I have been using extensively the feature in "Document import settings" that allows one to select ranges in the Excel. Since recently however the option "select ranges in Excel" returns with "Failed to open file" message box. This happens

i) for different Excel file extensions (xls, xlsx)
ii) for different (and all) excel files
iii) different filter (plain excel and excel for .... 2013) in the settings
iv) both for MemoQ 2014 R2 and 2015 (! - both performed correctly and as expected week or two ago)

The Office version used is office professional 2016, installed middle of December - saying MemoQ worked correctly already with this version (could of course be some silent upgrade, who th knows...)

remains only my (oh well, yes, I know, well, can we stick to the subject?) windows 10 OS as a possible source of "misunderstandings". I tried compatibility set-up for "as suggested" and for win7, without any effect.

Note that I can work around by typing in the range(s) (e.g. Sheet!B200:B255) but that sucks - I know and like the rationale for "Select ranges in Excel" - and miss it.

"When everything else fails" suggestion by Kilgray - "Deinstall MemoQ and reinstall it again" just does not make much sense in this situation.

Any suggestions?

TiA

smo

PS: no, the excel files are not R/O. And, no, I do not have them opened while doing the import.


 

Andriy Yasharov  Identity Verified
Ukraine
Local time: 11:53
Member (2008)
English to Russian
+ ...
Multilingual delimited text filter Jan 6, 2016

Instead of Microsoft Excel 2007, 2010 and 2013 filter try using the multilingual delimited text filter selected from a drop-down list during import of an Excel file. Then press Change filter and configuration and select Columns tab. Then you can select which columns must be translated.

I use memoQ 7.8.116 and if I need to use Microsoft Excel 2007, 2010 and 2013 filter, the Select ranges in Excel option is there in Importable ranges and general options tab.


 

Vito Smolej
Germany
Local time: 10:53
Member (2004)
English to Slovenian
+ ...
TOPIC STARTER
Practical workaround - Thx! Jan 7, 2016

As my excel files always have a column "translated", where I initially place the source text, the suggestion works nicely. THX!

I still - of course - would welcome suggestions, how to solve the problem of failing "select ranges in Excel" feature in ExCel filters.

Regards

smo


 

Leopoldo Gurman
United States
Local time: 03:53
Member (2004)
English to Spanish
Check the files path Jul 15, 2017

Hi Vito,

I've run into the same problem you have and thought I'd post my solution (took a while to figure it out). The error message isn't very helpful but it describes the problem perfectly: memoQ can't open the file. Next time you encounter this issue, try moving the file to a location with a shorter path, it did the trick for me.

Leo


Gusztáv Jánvári
 

Elena Carbonell  Identity Verified
Netherlands
Local time: 10:53
Member (2007)
English to Spanish
+ ...
Same problem Jun 6

In my case it happened when I migrated to a new computer. Everything else works except that. It's very frustrating because it's one of the best features in memoQ and I use it almost every week.
I have tried what is suggested here (short path name, change the file so it's more compatible, try with 20 different files, change filters, deactivate preview). The column solution is not an option since some cells in the columns are translatable and some not.
The Excel version I use is the latest, Office 365.

What it feels like is like memoQ cannot detect the Excel exe file. It can import Excel documents and export them but it doesn't detect the program from the Import cells menu...

MemoQ 8.4
Windows 10
Microsoft Office 365


 

Epameinondas Soufleros  Identity Verified
Greece
Local time: 11:53
Member (2008)
English to Greek
+ ...
It happened ever since the first build of 8.4 was released Jun 6

The problem was there since the first build of version 8.4, which I tried as a demo, and still exists in the current build: build 8.4.10.

The workaround is to type in the ranges instead of selecting them, i.e. press the Add button and type something like Sheet1!A1:B100.

Until, of course, someone decides to report this bug and they decide to fix it.


 

Tomasz Sienicki  Identity Verified
Denmark
Local time: 10:53
Member (2007)
Danish to Polish
+ ...
It works in 8.4.10 Jun 6

It works perfectly fine here in 8.4.10.

 

Epameinondas Soufleros  Identity Verified
Greece
Local time: 11:53
Member (2008)
English to Greek
+ ...
Office version Jun 6

With what version of Microsoft Office does it work?

 

Tomasz Sienicki  Identity Verified
Denmark
Local time: 10:53
Member (2007)
Danish to Polish
+ ...
2007 Jun 6

With what version of Microsoft Office does it work?


MS Office Enterprise 2007


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Importing Excel files with "select ranges in Excel" fails

Advanced search






Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search