How to ignore text in square brackets on import
Thread poster: Michael Burgess

Michael Burgess  Identity Verified
Denmark
Local time: 14:37
Danish to English
Jan 11, 2016

Hi - I am working in the latest version of MemoQ. I have a lot of text in a file that does not need to be translated and it is all marked in square brackets throughout the file. I have attempted to find an explanation of how to ignore this text during import, but without luck. Could somebody provide an explanation of how to do this, or a link to how to do this?

Thanks for your help!icon_smile.gif

/Michael


 

Mikhail Kropotov  Identity Verified
Russian Federation
Local time: 15:37
Member (2005)
English to Russian
+ ...
Apply a RegEx filter or tagger Jan 11, 2016

One way to 'ignore' text in square brackets would be to create a RegEx filter apply it during file import, or create a RegEx tagger and apply it immediately after import. If using a filter, text fragments in brackets would be skipped during import. Is using a tagger, they would be marked as tags (possibly as non-required tags, which may be skipped in the target if you don't need to retain the text in brackets in your target).

For additional details on RegEx (regular expressions) and how to use them in MemoQ, please see the built-in product help.

[Edited at 2016-01-11 13:47 GMT]


 

Michael Burgess  Identity Verified
Denmark
Local time: 14:37
Danish to English
TOPIC STARTER
Thanks, but I tried that. I need the idiot-proof version. Jan 11, 2016

Admittedly, I'm no expert in the more complex aspects of MemoQ.

I found the help instructions here (http://kilgray.com/memoq/60/help-en/index.html?regex_text_filter.html) but I still am not having any luck.

I've tried import with options and changing the filter to regex and adding a rule, but it ends up importing nothing from the file. And I'm not sure what I did wrong.

So I'm hoping for more specific step-by-step instructions, if somebody would go to the trouble, or can point me in a certain direction.

Thanks.

Btw source file is in Word.

[Edited at 2016-01-11 13:49 GMT]


 

Michael Burgess  Identity Verified
Denmark
Local time: 14:37
Danish to English
TOPIC STARTER
Jan 11, 2016



[Edited at 2016-01-11 16:32 GMT]


 

Stepan Konev  Identity Verified
Russian Federation
Local time: 15:37
English to Russian
1. Import your file as is (no filter) Jan 11, 2016

2. Format-> Run Reggex Tagger...
3. In 'Regular expression', insert this: \[(.*?)\]
4. In 'Display text', leave $0
5. Click 'Add' and Ok

All text in [ ] will turn to tags.
Once finished with translation and exported the active document back to Word, you will see those tags as normal text in [ ] as before running the Reggex Tagger.

[Edited at 2016-01-11 14:42 GMT]


 

John Fossey  Identity Verified
Canada
Local time: 08:37
Member (2008)
French to English
Use MS Word Hide Jan 11, 2016

Another thing you could do is to open the text in MS Word and do a Find/Replace All using wildcards for all text between square brackets - the search string is \[*\] . Leave the target textbox blank but set it to "Hidden" (Format > Font > check Hidden). Save the document and import it into memoQ. The text between square brackets will appear as a tag. After finishing the job, open it in Word, click Show hidden text (¶) and use Find/Replace to replace all hidden text with unhidden text. You could also just Select All (Ctrl + A) and use Font > clear Hidden format checkbox.

I do this frequently because I find Word's Find/Replace wildcards much easier to use than RegEx. Might be just a personal preference.

[Edited at 2016-01-11 16:00 GMT]


 

Michael Burgess  Identity Verified
Denmark
Local time: 14:37
Danish to English
TOPIC STARTER
Solution from Kilgray Jan 11, 2016

Thanks for your suggestions! I'm sure that they would also work, but here is how I did it, with the help of Kilgray Support.

1. Import file using import with options
2. Select "change filter and configuration".
3. Select "Add cascading filter..."
4. Select "Regex text filter" from the drop-down menu and click ok.
5. Click "Regex text filter".
6. Click "Include/exclude" tab and make sure that "Rules define content to be excluded" is selected.
7. In the "Rule" field enter "\[.*?\]" and click "add".
8. Click OK.
9. Click OK again to import.

This works very well!

/Michael

[Edited at 2016-01-11 16:39 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to ignore text in square brackets on import

Advanced search






Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search