Problem Importing Client Packages (memoQ 2015)
Thread poster: Rowan Morrell
Rowan Morrell  Identity Verified
New Zealand
Local time: 13:44
Member (2003)
French to English
+ ...
Feb 7, 2016

I have been having a most exasperating time this week with problems importing memoQ 2015 packages from clients who themselves have memoQ (and the same build as me, which is the latest one, i.e. 7.8.120).

Just now, I got a "General Error" when trying to import a package, along with the following bit of drivel:

"TYPE:
ICSharpCode.SharpZipLib.Zip.ZipException

MESSAGE:
Cannot find central directory

SOURCE:
SharpZipLib

CALL STACK:
at ICSharpCode.SharpZipLib.Zip.ZipFile.ReadEntries()
at ICSharpCode.SharpZipLib.Zip.ZipFile..ctor(FileStream file)
at MemoQ.Project.LogicAndData.HandoffDelivery.HandoffImportController.Execute(String packagePath, Form ownerForm, ProjectMetaInfo projectMetaInfo)
at MemoQ.Project.LogicAndData.HandoffDelivery.HandoffController.ImportHandoffPackage(String path, ProjectMetaInfo projectMetaInfo)
at MemoQ.Application.MemoQApp.OnImportHandoffPackageWithResult(String handoffPackageFileName)
at MemoQ.Application.MemoQApp.OnImportPackage(String path, String serverAddress)
at MemoQ.Application.MemoQApp.OnImportPackage()
at MemoQ.ApplicationFramework.CommandBinding.Execute()
at MemoQ.ApplicationFramework.WindowManager.DispatchCommand(String id, Object param, Boolean forced)
at MemoQ.ApplicationFramework.WindowManager.DispatchCommand(String id)
at MemoQ.ApplicationFramework.Command.Execute()
at MemoQ.ApplicationFramework.RibbonBarItemCommandAdapter.HandleUIEvent(Object sender, ItemClickEventArgs e)
at DevExpress.XtraBars.BarItem.OnClick(BarItemLink link)
at DevExpress.XtraBars.BarButtonItem.OnClick(BarItemLink link)
at DevExpress.XtraBars.BarItemLink.OnLinkClick()
at DevExpress.XtraBars.BarButtonItemLink.OnLinkClick()
at DevExpress.XtraBars.BarItemLink.OnLinkAction(BarLinkAction action, Object actionArgs)
at DevExpress.XtraBars.BarButtonItemLink.OnLinkAction(BarLinkAction action, Object actionArgs)
at DevExpress.XtraBars.BarItemLink.OnLinkActionCore(BarLinkAction action, Object actionArgs)
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.ClickLink(BarItemLink link)
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.UnPressLink(BarItemLink link)
at DevExpress.XtraBars.Ribbon.Handler.BaseRibbonHandler.OnUnPressItem(DXMouseEventArgs e, RibbonHitInfo hitInfo)
at DevExpress.XtraBars.Ribbon.Handler.BaseRibbonHandler.OnUnPress(DXMouseEventArgs e, RibbonHitInfo hitInfo)
at DevExpress.XtraBars.Ribbon.Handler.BaseRibbonHandler.OnMouseUp(DXMouseEventArgs e)
at DevExpress.XtraBars.Ribbon.Handler.RibbonHandler.OnMouseUp(DXMouseEventArgs e)
at DevExpress.XtraBars.Ribbon.RibbonControl.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at DevExpress.Utils.Controls.ControlBase.WndProc(Message& m)
at DevExpress.XtraBars.Ribbon.RibbonControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)"

I tried saving the package to a folder of my own, and also restarted my computer in case memoQ was misbehaving (I had just completed a project in it). Neither of those things worked.

But that's not all. I also had major problems importing the package for a project I just finished. This is what memoQ told me for that earlier package:

"General error.
TYPE:
System.NullReferenceException

MESSAGE:
Object reference not set to an instance of an object.

SOURCE:
MemoQ.TranslationMemory.GUI

CALL STACK:
at MemoQ.TranslationMemory.TranslationMemoryManager.AddToProject(GlobalInfo globalInfo, String langcode)
at MemoQ.Project.LogicAndData.HandoffDelivery.HandoffImportController.ImportTM(ZipEntry zipEntry, ZipFile zipInput)
at MemoQ.Project.LogicAndData.HandoffDelivery.HandoffImportController.DoJob()
at MemoQ.Common.Job.JobBase.Execute(Object o)"

For this previous problem, the client came up with a "stopgap" solution: they sent me a new package that didn't include a TM, and had me import the TM separately and then just attach it to the project. That worked, and I have just completed and delivered it. So I had this new project that came in yesterday and wanted to get stuck into that. But thanks to this latest problem, I guess I have the rest of the weekend off. :/ Nice in some respects, but it potentially means serious time pressure later on, which is why I wanted to rip into it now.

Anyway, does anyone know just what exactly memoQ's problem is with these packages? Is memoQ 2015 just buggy or badly configured for importing packages? Is the client doing something wrong? Am I? (All I'm doing is double clicking the package attachment in the client's e-mail, which always worked in memoQ 2014 R2 and until this week worked fine for memoQ 2015, so I don't THINK I'm doing anything I shouldn't myself.) Many thanks in advance for any solutions or at least elucidation that you can provide.


Direct link Reply with quote
 
Omer Shani
Israel
Local time: 02:44
Member (2012)
memoQ support team will do the work Feb 7, 2016

Hi Rowan,

BlueLion also have memoQ 2015 and every time we experience a technical issue, we immediately submit a support ticket at Kilgray website

https://support.kilgray.com/index.php?/Default

Their repose time is very quick and agile, and they really, well..support you

Hope it helps

Omer


Direct link Reply with quote
 
Rowan Morrell  Identity Verified
New Zealand
Local time: 13:44
Member (2003)
French to English
+ ...
TOPIC STARTER
Support Ticket Submitted Feb 7, 2016

Omer Shani wrote:

Hi Rowan,

BlueLion also have memoQ 2015 and every time we experience a technical issue, we immediately submit a support ticket at Kilgray website

https://support.kilgray.com/index.php?/Default

Their repose time is very quick and agile, and they really, well..support you

Hope it helps

Omer


I belatedly thought of that after posting this topic, and have now submitted a support ticket, but there's still no harm in asking here as well. Anyway, if Kilgray are able to help me, I can post their solution here, which could potentially help anyone else with the same problem. Thanks all the same for that though.

Of course, if anyone here DOES know of a solution ...


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem Importing Client Packages (memoQ 2015)

Advanced search






SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search