Problem importing termbases to MemoQ from xlsx/csv files
Thread poster: Sergii Kolomiiets

Sergii Kolomiiets  Identity Verified
Ukraine
Local time: 10:47
Ukrainian to English
+ ...
Jun 9, 2016

I have tried to import a termbase (English-Russian) to MemoQ 2014 from an Excel table and a csv file, but the memoQ only copies term segments (English) and ignores definition segments (Russian), so in the end I get a term base with terms that contain empty segments where definitions should be available. I properly assign functions to all table columns and choose corresponing languages, but it doesn't work out. The same happens when I try to import a TM.

Why does the software ignore the definition|target text column? What am I doing wrong, or is there a different way of getting text segments and their translations into MemoQ so they stay as a TM or a termbase?


 

Tony M
France
Local time: 09:47
Member
French to English
+ ...
Hidden columns? Jun 9, 2016

I don't know if it's relevant or even feasible in your situation, but just recently I got caught out when trying to import some Excell stuff into another document, as I hadn't noticed the opriginator had for some resaon included several columns that were 'hidden' (i.e. had width = 0) I only spotted this when I noticed that the column heading letters jumpsded from 'P' to 'S'. Those superfluous columns (apparently blank) were ruining the compatibility of my formatting.

Might just be worth checking?


 

Sergii Kolomiiets  Identity Verified
Ukraine
Local time: 10:47
Ukrainian to English
+ ...
TOPIC STARTER
Thanks, but not a solution for me... Jun 9, 2016

Thanks for your input, Tony M, but, unfortunately, what you describe does not look like my case. I have a two column document, and MemoQ sees source text coulmn as F0, and target text column, as F1, and everything looks nice, and I hit import, and the F1 text just doesn't show up.

 

Kelly Neudorfer  Identity Verified
Germany
Local time: 09:47
German to English
Language variants? Jun 9, 2016

I have never worked with Russian, so I don't know if this could be the case there, but you have to make sure that the variant (or lack thereof) is also lined up. I tried to import a termbase using the English (UK) and German (Germany) setting, and I kept getting only the English terms. It was driving me nuts, and then I tried just doing English (UK) and German with no country variant. It worked. So if Russian also has options for the variant, make sure that you've got the same one when you're setting up your termbase and defining the columns.

 

Michael Beijer  Identity Verified
United Kingdom
Local time: 08:47
Member (2009)
Dutch to English
+ ...
that's what I was thinking too: check the language variants! Jun 9, 2016

Kelly Neudorfer wrote:

I have never worked with Russian, so I don't know if this could be the case there, but you have to make sure that the variant (or lack thereof) is also lined up. I tried to import a termbase using the English (UK) and German (Germany) setting, and I kept getting only the English terms. It was driving me nuts, and then I tried just doing English (UK) and German with no country variant. It worked. So if Russian also has options for the variant, make sure that you've got the same one when you're setting up your termbase and defining the columns.


 

Sergii Kolomiiets  Identity Verified
Ukraine
Local time: 10:47
Ukrainian to English
+ ...
TOPIC STARTER
Thanks, but the language variant didn't help Jun 10, 2016

Thanks for your ideas, guys, but I originially did not assign a country variant. I played around with that, and, unfortunately, it didn't work...

I will welcome any new ideas.

Thanks!


 

Stepan Konev  Identity Verified
Russian Federation
Local time: 10:47
English to Russian
Not a definition Jun 11, 2016

Both English and Russian columns (F0 and F1) must be imported as terms.

[Edited at 2016-06-11 14:12 GMT]


 

Sergii Kolomiiets  Identity Verified
Ukraine
Local time: 10:47
Ukrainian to English
+ ...
TOPIC STARTER
Thank you Stepan! Jun 11, 2016

Thank you, Stepan!

It worked. As weird as it is, but yay, I fed my two-language term list into my MemoQ by assigning both language columns the function of terms.

Thanks again everyone!

Cheers!

Serg


 

Anil Gidwani  Identity Verified
India
Local time: 13:17
German to English
+ ...
That worked for me too (DE->EN) Jan 12, 2017

Stepan Konev wrote:

Both English and Russian columns (F0 and F1) must be imported as terms.

[Edited at 2016-06-11 14:12 GMT]


Thanks Stepan:

That worked for me too (DE-EN) after several unsuccessful attempts with other strategies. It is weird, but one would have thought the second language should be imported as the definition. I guess memoQ 'defines definition' differently!

This is one of those things that is an exception to memoQ's otherwise superb ease of use.

Anil


 

Georgios Tziakos  Identity Verified
Spain
Member (2011)
English to Greek
+ ...
doesn't work for me Apr 14

I am afraid I am having the same issue and calling them both "terms" doesn't solve it.icon_frown.gif

Thanks,
Georgios

PS: I just called the column "Arabic" and the import was done. Go figure. But the problem is that while translating, my project looks only for Greek terms (naturally), which means it's still unusable. If I use non-variant English, it doesn't detect it either. If I use English (US) it does. Unfortunately, MemoQ doesn't seem to have any Greek variants available so I can bypass the issue that way.

[Edited at 2018-04-14 12:26 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem importing termbases to MemoQ from xlsx/csv files

Advanced search






SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features, ensures new

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search