Term recognition in MQ 2015. How is it supposed to work?
Thread poster: Luca Tutino

Luca Tutino  Identity Verified
Italy
Local time: 01:50
Member (2002)
English to Italian
+ ...
Jul 4, 2016

I have set up a termbase, I can add terms into it while translating (eg by pressing ctrl-q) and search in it (ctrl+p). I have also disabled any termbase plugin because I need to stick to specific terminology in this project.

Now I have 3 questions:

1 Why in automatic lookup and fragment assembly the terms that I have added do not always appear?
If I cannot solve this, the termbase becomes practically pointless.

2 Is there a way to alert me about the presence of a termbase term in the original segment by automatic highlight? Or should I just search the entire list in the automatic lookup each time? (which is quite unpractical)

3 What are the orange segments in the automatic lookup window (on the right side)?
The status of the window only gives a question mark and the name of my project TM. In the window that opens if I hit the "Customize appearance" context menu option, the orange color does not appear at all.


Direct link Reply with quote
 

Mirko Mainardi  Identity Verified
Italy
Local time: 07:50
Member
English to Italian
+ ...
Case sensitivity? Jul 4, 2016

3) "automated concordance / Longest Substring Concordance (LSC) hits: orange. memoQ attempts to retrieve the longest possible expressions that can be found by concordancing and tries to offer their equivalent too." - http://kilgray.com/memoq/2015-100/help-en/index.html?grid_translation_results_pane.html

As for 1 and 2, those should be automatic, but perhaps you're not setting the right case sensitivity/matching parameters (or operators)? To do this, you should use CTRL+E, rather than CTRL+Q (which is the "quick add"). Also see http://kilgray.com/memoq/2015-100/help-en/index.html?grid_translation_results_pane.html


Direct link Reply with quote
 

Stepan Konev  Identity Verified
Russian Federation
Local time: 09:50
English to Russian
Termbase properties for "New terms" Jul 4, 2016

In your termbase properties, you can change settings for new terms by setting Fuzzy for prefix and No for case sensitivity. This makes your termbase recognize almost everything.
For example, if you add "word" with ctrl+Q (with Fuzzy and No settings), it will recognize and highlight "words" and even "wording" as a term assigned to "word".
Unlike the above referenced ctrl+e combination that allows you to assign settings for one term each time, changing properties for new terms allows you to do it for all future terms without the need to set them each next time.

[Edited at 2016-07-04 17:31 GMT]


Direct link Reply with quote
 

Luca Tutino  Identity Verified
Italy
Local time: 01:50
Member (2002)
English to Italian
+ ...
TOPIC STARTER
Matching: 50% and Case sens.:Permissive, now changed into Fuzzy and Permissive - still not working Jul 4, 2016

I have now changed both my default and the term "aantal" properties as indicated in the title. However, when I go on the segment "Aantal vragen bij overname" the term "aantal" does not appear on my right side window, and I only have "Aantal" -> "Numero" as an orange result.

My impression is that I did not activate some term recognition pane, which I cannot find in the help.

@Mirko: Thank you about the explanation for the orange results!

None of the results in my translations results shows any symbol and in particular not the symbol for "The match comes from a regular term base." as specified in the reference url page


Direct link Reply with quote
 

Luca Tutino  Identity Verified
Italy
Local time: 01:50
Member (2002)
English to Italian
+ ...
TOPIC STARTER
I should add Jul 4, 2016

I should probably add that I am working on an online project (on client's server), and I have created and applied my own termbase on my local disk.

...and thanks to Stepan too, of course!

[Edited at 2016-07-04 21:29 GMT]


Direct link Reply with quote
 

Mirko Mainardi  Identity Verified
Italy
Local time: 07:50
Member
English to Italian
+ ...
Case sensitivity > No Jul 4, 2016

Luca Tutino wrote:


Matching: 50% and Case sens.:Permissive, now changed into Fuzzy and Permissive - still not working


If you get a suggestion for "Aantal", but not for "aantal", then it sounds as if the problem is in fact the case sensitivity setting. As Stepan was saying, "case sensitivity" should be set to "no", rather than "permissive" (which is the default value).

As far as I remember, the automatic lookup for both TM an TB should be enabled by default... The only other thing that comes to mind is that you can get more results by clicking on the "eye" left of "Translation results", right above the auto lookup pane, but I don't think that's got anything to do with your problem...

P.S. And you're welcome

[Edited at 2016-07-04 21:48 GMT]


Direct link Reply with quote
 

Luca Tutino  Identity Verified
Italy
Local time: 01:50
Member (2002)
English to Italian
+ ...
TOPIC STARTER
I have also tried No, without success Jul 4, 2016

TB activation means that the case to the left of the termbase should be selected on Project Home > Termbases and "automatically scan segments" should be selected in the Translation > Translation settings dialog, right?

Direct link Reply with quote
 

Mirko Mainardi  Identity Verified
Italy
Local time: 07:50
Member
English to Italian
+ ...
Very weird... Jul 5, 2016

Luca Tutino wrote:

TB activation means that the case to the left of the termbase should be selected on Project Home > Termbases and "automatically scan segments" should be selected in the Translation > Translation settings dialog, right?


Fact is, if "automatically scan segments" was disabled, you wouldn't see anything in the automatic lookup, while that's not your case, as you do see TM hits and only some TB hits...

I tried setting up a test project, and here is what I see, for instance:






Not sure if this has something to do with some settings your PM set server-side, at this point, although I'd think that what counts should be the settings of your own local TB in this specific case...


Direct link Reply with quote
 

Luca Tutino  Identity Verified
Italy
Local time: 01:50
Member (2002)
English to Italian
+ ...
TOPIC STARTER
Solved - Kudoz to Kilgray's support!! Jul 5, 2016

For some reason the checkmark was missing in the "lookup results" tab of the "customize results" dialog (right click on the results pane). I had verified this dialog many times, and I I probably missed the presence of this second tab.

Kudoz to Kilgray's support. They are always available, competent, helpful and precise. This is really a big plus for MemoQ!

[Edited at 2016-07-05 12:16 GMT]


Direct link Reply with quote
 

Mirko Mainardi  Identity Verified
Italy
Local time: 07:50
Member
English to Italian
+ ...
I would've never thought about that... Jul 5, 2016

At any rate, glad you solved this, and thanks for letting us know!

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Term recognition in MQ 2015. How is it supposed to work?

Advanced search






TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search