How to change types of quotation marks?
Thread poster: psicutrinius

psicutrinius  Identity Verified
Spain
Local time: 00:20
Member (2008)
Spanish to English
+ ...
Oct 27, 2018

I KNOW that there is a way of changing quatation marlks, angled, "intelligent" "straight"... in memoQ 8.5.8, but need to change from straight upper (as they appear in the keyboard) to angled ones. Have used that, but quite a time ago and now I am totally unable to find that.

Any help? Thanks in advance

Marcel


 

Samuel Murray  Identity Verified
Netherlands
Local time: 00:20
Member (2006)
English to Afrikaans
+ ...
@Marcel Oct 27, 2018

psicutrinius wrote:
I need to change from straight upper (as they appear in the keyboard) to angled ones.


Are you talking about guillemets, i.e. ‹ › and « » ?


 

psicutrinius  Identity Verified
Spain
Local time: 00:20
Member (2008)
Spanish to English
+ ...
TOPIC STARTER
Yes, Samuel Oct 27, 2018

I mean the "twins", that is , your last example.

 

Samuel Murray  Identity Verified
Netherlands
Local time: 00:20
Member (2006)
English to Afrikaans
+ ...
@Marcel Oct 27, 2018

psicutrinius wrote:
I mean the "twins", that is , your last example.


Well, I'm not a MemoQ user, so we'll have to wait for one to drop by.

In the mean time, googling leads me to suspect that this appears to be what you're looking for:
https://help.memoq.com/8-4/en/Places/autocorrect-settings.html
...and your target language has to be set to something that uses French quotes, so... maybe FR.

My own CAT tool does not allow for this sort of thing, so personally I use an AutoIt/AutoHotKey script that creates these fancy quotes when I press a certain shortcut (in my case, Shift+Ctrl+9 and Shift+Ctrl+0).


halit yilmaz
 

Elzbieta Lubelska
Poland
Local time: 00:20
French to Polish
+ ...
the 3 key Oct 30, 2018

I just use the "3" key with the French keyboard layout.
Another option is the "Insert Symbol" command button in the "Edit" menu.
But I'm not sure what you mean by "changing" quotation marks... You mean automatically in the whole document?


 

halit yilmaz  Identity Verified
United Kingdom
Local time: 01:20
Member (2014)
English to Turkish
+ ...
I dont know why this is a problem we are facing Nov 25, 2018

I have many softwares and cat tools on my computer and Memoq insists that I do not want to use '' and that instead, I must use « because, just because it said so.

A seriously perfect software otherwise. Why dear Memoq, WHY?


 

Stepan Konev  Identity Verified
Russian Federation
Local time: 01:20
English to Russian
A workaround for smart quotes Nov 27, 2018

- Type signs “ and ” anywhere in a text document (MS Word or memoQ or anything else).
- Type signs « and » anywhere in a text document.
- In memoQ, press Ctrl+Shift+O. ('Replace straight quotes with smart quotes' checkbox has to be ticked.)
- If you don't have an AutoCorrect list yet, create one by pressing 'New list'. Once done, tick it.
- In the 'Replace:' field copy and paste the “.
- In the 'With' field copy and paste the «.
- Press 'Add'
<
... See more
- Type signs “ and ” anywhere in a text document (MS Word or memoQ or anything else).
- Type signs « and » anywhere in a text document.
- In memoQ, press Ctrl+Shift+O. ('Replace straight quotes with smart quotes' checkbox has to be ticked.)
- If you don't have an AutoCorrect list yet, create one by pressing 'New list'. Once done, tick it.
- In the 'Replace:' field copy and paste the “.
- In the 'With' field copy and paste the «.
- Press 'Add'

Repeat the latter three steps for ” and » accordingly. Don't forget to press 'Add' each time you add a pair of signs.
Press OK.

To make it work in Editor, type the signs “” followed by a trailing space.
Once you type the second quotation mark (”), the first one will turn to («).
Once you type 'space', the second quotation mark (”) will turn to (»).
Also I heard that in some languages a space is required after/before opening/closing quotation marks. If this is your case, typing space after a quotation mark will also turn “ to «.

In case that you don't need this behavior, don't type quotation marks together. Split them by the quoted text instead. Pressing any letter after the first quotation mark will keep both marks as quoted text

The procedure looks long and complicated, but you need to do just one time.

[Edited at 2018-11-27 05:32 GMT]
Collapse


Jan Truper
 

Philipp Reinhold  Identity Verified
Germany
Local time: 00:20
German to Spanish
+ ...
Another alternative Nov 30, 2018

Just edit the smart quotes settings file SmartQuotes.xml (mine was in C:\Users\Philipp\AppData\Roaming\MemoQ\AutoCorrect. The "AppData" folder is usually hidden, you have to be able to see hidden folders):

- Make a backup copy of the original file in case you fudge something up.

- Open the file with an editor, search for the language code you need and change the standard quotes, which will then be used automatically in MemoQ if you tick "Replace straight quotes with sma
... See more
Just edit the smart quotes settings file SmartQuotes.xml (mine was in C:\Users\Philipp\AppData\Roaming\MemoQ\AutoCorrect. The "AppData" folder is usually hidden, you have to be able to see hidden folders):

- Make a backup copy of the original file in case you fudge something up.

- Open the file with an editor, search for the language code you need and change the standard quotes, which will then be used automatically in MemoQ if you tick "Replace straight quotes with smart quotes" under Translation settings > Auto correct. Save file.

- Close MemoQ, open it again et voilà.

For example, I changed my settings for Spanish like this:

Unbenannt



[Edited at 2018-11-30 10:38 GMT]
Collapse


Andrii Vovchenko
 

Michael Beijer  Identity Verified
United Kingdom
Local time: 23:20
Member (2009)
Dutch to English
+ ...
Thanks! Dec 30, 2020

Philipp Reinhold wrote:

Just edit the smart quotes settings file SmartQuotes.xml (mine was in C:\Users\Philipp\AppData\Roaming\MemoQ\AutoCorrect. The "AppData" folder is usually hidden, you have to be able to see hidden folders):

- Make a backup copy of the original file in case you fudge something up.

- Open the file with an editor, search for the language code you need and change the standard quotes, which will then be used automatically in MemoQ if you tick "Replace straight quotes with smart quotes" under Translation settings > Auto correct. Save file.

- Close MemoQ, open it again et voilà.

For example, I changed my settings for Spanish like this:

Unbenannt



[Edited at 2018-11-30 10:38 GMT]


Thanks! This has been bugging me for years. I foxed it in 5 minutes using your tip!

Here is my (fixed) XML, should anyone working in Dutch or English care to copy it:

fix-for-curly-quotes-in-memoQ

Michael


 

Riccardo Schiaffino  Identity Verified
United States
Local time: 16:20
Member (2003)
English to Italian
+ ...
You just have to adjust your autocorrect settings Dec 30, 2020

halit yilmaz wrote:

I have many softwares and cat tools on my computer and Memoq insists that I do not want to use '' and that instead, I must use « because, just because it said so.

A seriously perfect software otherwise. Why dear Memoq, WHY?


It's just a question of having the correct settings:

Open a project. In Project home, click Translations. Open a document for translation. On the Translation ribbon, click Translation Settings. From the menu, choose AutoCorrect. The AutoCorrect settings window opens.
Under "Smart quotes and capitalization", deselect "Replace straight quotes with smart quotes"

At that point, you should be able to type straight quotes, and not seeing them replaced by curly (or "smart") quotes.


 

Anthony Rudd

Local time: 00:20
German to English
+ ...
Correct quotation marks Dec 31, 2020

Despite Autocorrection settings, there are situations when inappropriate quotation marks result in the target. In such case I run a regex to correct the settings (I have a library of such regexes).

 

Recep Kurt  Identity Verified
Turkey
Local time: 01:20
Member (2011)
English to Turkish
+ ...
Great tip, thank you! Feb 4

Philipp Reinhold wrote:

Just edit the smart quotes settings file SmartQuotes.xml (mine was in C:\Users\Philipp\AppData\Roaming\MemoQ\AutoCorrect. The "AppData" folder is usually hidden, you have to be able to see hidden folders):



Worked like a charm, thank you!


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to change types of quotation marks?

Advanced search






Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search