spell check issue, HELP, please!
Thread poster: Javier Wasserzug

Javier Wasserzug  Identity Verified
United States
Local time: 12:05
English to Spanish
+ ...
Nov 12, 2008

After I received a document in Spanish to proofread, my MS Word 2003 stopped the “spell check as you type”. English and Spanish.

I have tried many things and nothing works. It has been working just fine for a long time. An extensive search in Internet did not give me any useful solution.

Any ideas?


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 14:05
Spanish
+ ...
Re-install it Nov 12, 2008

If you already tried the obvious and you still can't find a solution, try to re-install Word.

Direct link Reply with quote
 

Javier Wasserzug  Identity Verified
United States
Local time: 12:05
English to Spanish
+ ...
TOPIC STARTER
trying to avoid it Nov 12, 2008

Thank you for your answer.

I thought I could ask here, maybe it happen to someone before and there is a way to fix it.
I was hoping to be able to avoid that instance and find an alternative fix. It takes time to rearrange everything the way it was before...

But... since we are in this topic, do you know how to save the custom dictionaries?


Direct link Reply with quote
 
Tarara Paso
Sri Lanka
Local time: 21:05
English to Spanish
+ ...
spell check Nov 12, 2008

Try to do this:
1. Select all your doc and go to Tools -- language
2. Select your language and back to document
3. Select again all doc and go to Tools ---- customize
4. Clik option spell check as you write but not grammar review.
Good Luck.


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 21:05
Member
French to English
+ ...
So obvious it's stupid, but... Nov 12, 2008

...I suppose you have 'selected all' text and checked that the 'do not check spelling or grammar' checkbox isn't checked (or checked, but greyed out)? I don't know if this affects the check-as-you-go features, but logically it might... and if the settings were wrong when the document was created, it's easy to overlook this particular one when you come to edit / translate it.

Direct link Reply with quote
 

Marina Soldati  Identity Verified
Argentina
Local time: 16:05
Member (2005)
English to Spanish
+ ...
Are you working on a bilingual document? Nov 12, 2008

Hi Javier,

If this is the case, and the document is big (more than 20 or 30 pages) there are two many spelling mistakes in the document (all the Spanish words if the spell checker is set to English, or viceversa) for Word to handle and it turns itself off.

If this is the case, there`s nothing you can do. Just go to Tools, Options, Spellcking and disable the spell check as you write option (don´t know the exact names, sorry, my Word´s Spanish)

Once you´ve finished editing, hide the source text, enable the spellchecker again, and it´ll show you all the mistakes it can find.

Hope this helps
Marina


Direct link Reply with quote
 

Szilas Cseh
Serbia
Local time: 21:05
Member
English to Hungarian
+ ...
another tip Nov 13, 2008

This is also very obvious but did you try to copy the whole text and paste it into a new document? If spell checking is enabled in Word by default then the new errors should be displayed in the new document.

I've had a similar problem once and this solved it.

Szilas


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 22:05
Member (2006)
English to Russian
+ ...
Work with OpenOffice.org Nov 13, 2008

its spellcheck function is much more robust as compared to Microsoft Office.

Direct link Reply with quote
 

Javier Wasserzug  Identity Verified
United States
Local time: 12:05
English to Spanish
+ ...
TOPIC STARTER
Resolved, thank you so much Nov 13, 2008

Finally, I found it!
I was resisting the hard never-ending work of reinstalling word.

So, after I played with all the obvious options of “spelling & Grammar” at the end of the “options” menu, run a “detect and repair” and, travel deep into pretty unrelated options like the language bar…

I was looking around and got to the “tools/language/set language”. There, the “do not check spelling or grammar” was checked. That was the solution to my problem.

The weird circumstance was that a .doc did it. HOW?? I have no idea but it is clear that it was the cause since the same happened to the person who emailed it to me.

Thank you everyone for your help!!!! It was driving me crazy!!



[Edited at 2008-11-13 16:58]

[Edited at 2008-11-13 17:00]


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 21:05
Member
French to English
+ ...
Happens to me all the time! Nov 13, 2008

I'm glad it turned out to be what I thought! The point seems to be that the presence of any text marked 'do not check spelling / grammar' in a document seems to activate this check box, albeit greyed-out if it is not all of the doc. It often happnes, for example, if you copy-&-paste text inot a working doc from a doc with different settings; so the setting of this parameter comes with the doc, which overrides the default Word setting on your machine.

And I suppose it is only logical that this feature should override the 'check-as-you-go' feature too.

I always create my working docs by starting with 'selecting all' and setting the target language, and check this parameter at the same time; has saved me hours of headaches!

[Edited at 2008-11-13 20:51]


Direct link Reply with quote
 

Jesús Cordero-Salvado  Identity Verified
Local time: 20:05
English to Spanish
+ ...
about "there are too many spelling or grammatical errors" using Word 2003 and Trados Jan 22, 2009

I work with Trados on bilingual documents English-Spanish using Word 2003. After having translated a few pages in big documents I used to get the message "there are too many spelling or grammatical errors" and suddenly I lost the check-spelling-as-you-type feature. I hated it because then you need to recheck much more carefully all the text after the whole doc is translated.

Solution was:
1. Before start translating Select ALL the text in the doc. Using Tools/Language/Select Language make sure ALL selected text is marked as the source language of the document; within this Language box, make sure the options "Do not check spelling or grammar" and "Detect language automatically" are UN-ticked.

2. Now change your keyboard to the TARGET language (ALT+TAB). If you do not have set up different keyboards with Windows I strongly recommend it (Control Panel/Date Time Language and regional Options/Regional and language Options/Text Services and input Languages/languages/Details/Settings/Installed Services/Add where you can more keyboards).

3. Then start translating. As your keyboard is set to the target language, the translated target text is marked as the target language. As such, the check-spelling-as-you-type feature will detect only the misspellings. It will not consider the whole sentence as wrongly spelled, which eventually clogs the system. The key here is not to have the "Detect language automatically" ticked which is the thing that messes all up

4. If this has happened to you half way through, do point one, then select a few of the longest paragraphs of the target text and mark them as Target language, then go to Spell Checking, tick spell as you type and Recheck.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

spell check issue, HELP, please!

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search