Glitch with Word spell-checker
Thread poster: Jonathan MacKerron

Jonathan MacKerron  Identity Verified
Member (2005)
German to English
+ ...
Apr 18, 2010

Hello,
I am running MS-Word 2002 SP3 and have the following problem: my document contains pages in both landscape and portrait format, i.e. the first three pages in portrait followed by two in landscape, and then the rest of the document in portrait. The pages after the landscape portion do not allow for a spell-check. When starting the spellcheck I get the message "spellcheck completed". I have tried to reformat the document language, but to no avail.
I would appreciate any tips on how to rectify this problem.
TIA,
J. MacKerron

[Edited at 2010-04-18 13:49 GMT]


Direct link Reply with quote
 

Oliver Walter  Identity Verified
United Kingdom
Local time: 18:14
Member (2005)
German to English
+ ...
A suggestion Apr 18, 2010

That seems a strange problem unless, perhaps, that last section is in text boxes (I don't remember whether they are automatically spell-checked).
Suggestions:
1. Select the text in the last section and then do the spell-check;
2. Copy the last section into a new separate document and see whether that can be spell-checked.

Reminder: spell checking doesn't really check for correct spelling - it checks that the text consists of words. It's up to the author to ensure that the words used are the correct words to use. (This isn't specifically directed at you, Jonathan, but it might be a good place to point out this fact.)
Example: Word2000 accepts the following as spelled correctly, although it isn't (one error in each sentence): "The weather is dependant on the volcano. I must go out and buy some stationary"

Oliver


Direct link Reply with quote
 

Jonathan MacKerron  Identity Verified
Member (2005)
German to English
+ ...
TOPIC STARTER
@Olivar Apr 18, 2010

Thanks, but neither of these suggestions work.

[Edited at 2010-04-18 14:37 GMT]


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 19:14
Member
French to English
+ ...
Similar problem... Apr 18, 2010

I did once have a similar problem, not specifically with spell-checking, but with language setting in general.

The problem seemed to be that, try as I might, I could not force the entire document to be the language I set, and I kept on finding it would revert to another, unwanted, language in odd places — this was especially irritating, as the language was Arabic, and so the text would suddenly start going from right to left!

First of all, could I suggest checking one thing? 'Select all', then go to Tools > Language as if to set the language, and look closely at the little check box near the bottom left 'Check spelling and grammar'. If this box if checked OK in black, then you should be OK; however, I have often found it with the check mark greyed out, meaning certain parts of the text are set to 'do not check spelling or grammar'.

If it is checked black OK, then I don't know what to suggest.

However, if it is greyed out, then you could try various different ways of selecting all and changing the language and checking the 'check spelling...' box — I have found several times that it was necessary to try different tactics, like using the 'select all' command or else manually selecting all the text (go to start > F8 > go to end) — illogically, these methods sometimes seem to produce different results.

You might also wish to check the styles used in the document; I don't know if it's true or not, but I suspect that the language setting in a given style may override the attribute for the document as a whole (and of course, that language setting includes 'check / do not check spelling'!) You may have to go through quite carefully to make sure you have caught all possible styles that might be implicated.

In a perfect world, if your document had no formatting, I'd suggest 'clear formatting' (under style) and then re-imposing a known good style. But of course this may not be feasible.

Soapbox time: how I hate receiving work from translators where they have not set the target language, thus proving that they have not even bothered to run an elementary spell check! icon_mad.gif

[Edited at 2010-04-18 15:29 GMT]


Direct link Reply with quote
 

Brian Young  Identity Verified
United States
Local time: 10:14
Danish to English
spellcheck in Word Apr 18, 2010

I too have been frustrated with this. I get word documents in Danish, and want to type over into English. It can seem impossible at times to get the default language to remain as English. I set it to English, then see that it is not working. I check the language, and it has gone back to Danish.
Sometimes I open a new document, set the default to English, and then copy and paste the Danish text. But often it seems to take the language with it.
If this is really bothering me, I paste the entire document into Pages, which is the Mac word processor. That always works, but I can only use it for spellchecking. Then I have to re-export to Word. I have not been able to solve this problem entirely. But I am not much of a geek, and these things elude me.


Direct link Reply with quote
 

xxxmediamatrix
Local time: 13:14
Spanish to English
+ ...
Recheck document ... ? Apr 18, 2010

I use Word 2000, not 2002, so I don’t know if this will work for you, Jonathan.

After a spell-check has been done once on a section of text, a flag is set somewhere to say ‘this text has been checked’. If the spell checker is run again, you get the The spelling and grammar check is complete. message.

If you edit the text in any way that may affect spelling or grammar, the flag is removed automatically, and a new spell check operation will work normally. But mere changes of style or layout do not remove the flag.

However, if you still want to spell check text that has the flag set, you can over-ride the flag:

In Windows 2000:
Go to Tools --> Options --> Spelling & Grammar and click the Recheck document button (at the bottom of the dialog box). Then Select All --> Tools --> Spelling & Grammar.

HTH
MediaMatrix


Direct link Reply with quote
 

Jonathan MacKerron  Identity Verified
Member (2005)
German to English
+ ...
TOPIC STARTER
Thanks to you all for your input Apr 18, 2010

I've since identified some odd behavior:
when I mark the entire document, then select Extras+Language and uncheck the "Do not check spelling or grammar" box (German wording), after scrolling through a few pages it automatically inserts the check back into the "Do not check spelling or grammar" command! So as a stop gap measure I unclick this box every few pages, which isn't optimal, but at least I can continue my work.
There is obviously some hidden command somewhere that is bollocksing things up, but damned if I can find it. I'm convinced that the problem lies at a deeper formatting level that simply isn't obvious to the lay user.
If I come up with any other interesting discoveries in this regard I will post my findings in this thread.
Again, thanks to you all for your kind assistance!!


[Edited at 2010-04-18 19:51 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Glitch with Word spell-checker

Advanced search






Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search