Problem with target language recognition in Word
Thread poster: Helen Matthews

Helen Matthews  Identity Verified
United Kingdom
Local time: 16:18
Member (2008)
Italian to English
+ ...
Jan 14, 2011

Not sure if this is posted in the right place - staff please correct if I'm wrong!

I'm using Trados 8.0 and Microsoft Office 2007 on an Italian computer.

Hoping someone can help, I'm experiencing the following difficulty:

Most (80%) of the time I translate from IT-EN with trados and word with no problem at all. Word initally assumes I'm writing Italian in my target section, but as soon as I get to a full stop, or back delete or similar, it recognises that I'm writing in English and therefore applies the immediate English spellcheck, autocorrect features etc. to the target segment.

When, on the other hand, I work from FR or ES into EN, word does not appear to recognise English as the language in which I am writing until I actually close the segment - meaning that I either turn the spellcheck (and autocorrect) off completely, or I risk word "autocorrecting" my English into French/Spanish words, which I may only pick up on after I've closed the segment, so then have to go back and correct.

As I'm currently working on some very lengthy segments in my ES-EN combination, this is becoming a bit of an issue.

All suggestions welcome!

Thanks,

Helen


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:18
Member (2003)
Polish to German
+ ...
Why using this annoying fature? Jan 14, 2011

I would instead change the language of the whole text to target before I start.
First change the language to target in the styles.
Then select the whole text by pressing CTRL+A. Go to Tools - Language, chose Language, select the target language and activate the option "Do not check spelling and grammar".
Now select a small part of the document, let's say 4-5 pages, repeat the last step, but deselect the option "Do not check spelling and grammar" for this part of the document. That way Word will keep spellchecking and all options for the target language permanently. When you finish that part of the text select again the whole document, switch spelling off as described above, select another part of the document and switch the spellchecking on for it.


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 18:18
Member (2003)
Finnish to German
+ ...
Did you uncheck automatic language recognition? Jan 14, 2011

In Word at Tools > Language there should be unchecked the box for automatic recognition.
I cannot imagine any other reason.

Heinrich


Direct link Reply with quote
 

Helen Matthews  Identity Verified
United Kingdom
Local time: 16:18
Member (2008)
Italian to English
+ ...
TOPIC STARTER
Thank you Jan 14, 2011

@ Jerzy: Thank you - I hadn't thought of selecting the automatically check option for just a few pages, and as you guessed, it won't keep it for the whole document as there's too much ES text to be "forced" into English and it picks up too many "spelling mistakes"

@ Heinrich: the problem was that I didn't want to remove the automatic correction entirely, I rather like the fact that Word corrects my "teh" to "the" (which I still end up typing incorrectly after YEARS of touch-typing) automatically, but I wanted it to automatically correct to the right language! (i.e. EN not ES in this case!)

Thanks both of you for answering so quickly - at least I have a solution now, although I am still curious as to why it causes this problem in ES/FR and not in IT!

Have a good weekend!

Helen


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem with target language recognition in Word

Advanced search






PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search