Words 2007 keeps changing the language back to English
Thread poster: Jacques DP

Jacques DP  Identity Verified
Switzerland
Local time: 03:02
Member (2003)
English to French
Mar 28, 2011

Hello,

When translating some document with Word 2007 and Workbench (SDL Trados 2007), the target segment is always set to English (instead of French). I have selected all document and applied French. I have French installed and selected in the Office language tools as my only input language. I have French selected as my OS language. I have an EN>FR TM active.

I created a macro to apply French every time, but it a bit cumbersome to apply it on every segment.

Any idea? Thanks.

[Edited at 2011-03-28 16:07 GMT]


 

Jerzy Czopik  Identity Verified
Germany
Local time: 03:02
Member (2003)
Polish to German
+ ...
Switch the automatic language recognition off Mar 28, 2011

This is one of the most annoying and translator-hostile features in Word.

 

Jacques DP  Identity Verified
Switzerland
Local time: 03:02
Member (2003)
English to French
TOPIC STARTER
I did that, at least... Mar 28, 2011

Hi Jerzy!

Well, I did that already, at least in the Revision > Language setting (from the ribbon)... It doesn't care however. And when I go back to it it's checked again.

Another thing to note is that when I apply my macro (change language to French), translate a segment, close it, open it again, it's in English again. And it doesn't happen here and there but on every single segment of the document...

Jacques


 

Jerzy Czopik  Identity Verified
Germany
Local time: 03:02
Member (2003)
Polish to German
+ ...
Check the styles, if those are not set to automatcially adapt the settings Mar 28, 2011

Select also the text part in question and check, if there is no auto sdelection of language. Also check, if you did not set up in Word, that keyboard shall be switched automatically according the language.

 

Jacques DP  Identity Verified
Switzerland
Local time: 03:02
Member (2003)
English to French
TOPIC STARTER
It's the styles indeed, apparently Mar 29, 2011

Hi Jerzy,

This came too late for this project, but I just got back to it to test your last suggestions. And indeed when I saw the Normal style had "English" forced, and when I chose French+do-not-detect instead for the Normal style, it suppressed any language information from the style (French being the default language), and now it seems to work correctly.

Thanks a lot, it'll help some other time!


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Words 2007 keeps changing the language back to English

Advanced search






SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search