MS Office 2010: how to get rid of superscript ordinals and replace straight quotes with curly quotes
Thread poster: Susan Welsh

Susan Welsh  Identity Verified
United States
Local time: 23:24
Member (2008)
Russian to English
+ ...
Jun 13, 2012

I am editing a document translated by some one else and I have tried what all the online helpers say about getting rid of those annoying superscript "th"s in ordinal numbers. I want an ordinary "th." Nothing works. I've gone into File > Options > Autoformat (and all the other things in there that are related), and I've "unchecked" every ordinals box I can find. Still comes out the same way it was.

I have also wasted at least another hour today trying to search and replace "straight" quotes with "curly" quotes. It's not working. Ctrl + G for the "find and replace" box > puts straight quotes in the boxes, and when you let it run, it finds the quotes whichever way you have them, and "replaces" them with exactly the same thing. I cannot see any way to put the proper quotes into the "find and replace" slots.

Can you tell I'm in a bad mood?
Thanks for any help!


 

Adam Łobatiuk  Identity Verified
Poland
Local time: 05:24
Member (2009)
English to Polish
+ ...
Ctrl + H and then... Jun 13, 2012

1. For the 'th's

Find: th, expand the additional options, use Format, select Font, select Superscript
Replace with: th, expand the additional options, use Format, select Font, clear Superscript

2. The quotes

This is less straightforward. First, copy the correct opening quote you need. Then open the Search and Replace pane and paste it into the Replace with field, preceded by a space. In the Find: field, type a space and a straight quote. Replace all. Do a similar thing with the closing quote, but put the space after the quote characters, and then repeat with a period/full stop instead of a space. The idea here is that opening and closing quotes are different, so you can't replace them all at once. Opening quotes usually appear after a space, while closing ones precede a space or a period (or possibly other punctuation marks).

HTH


 

Alex Lago  Identity Verified
Spain
Local time: 05:24
Member (2009)
English to Spanish
+ ...
Try this Jun 14, 2012

There may be quicker ways but this is what I would do

For the quotes

File->Options->Proofing
Right at the top click on "Autocorrect Options"
Clear the "Straight quotes" with "smart quotes" check box and then click OK.
Press Ctrl+H
In the Find what box, type a quotation mark.
In the Replace with box, type a quotation mark.
Click Replace All.

To get rid of supersrcipt (done in 2 parts)

Part 1
Stay in "Replace" window
Place the cursor in the "Find what" section
Click on "More"
At the bottom under "Replace" click on "Format" and in the list that appears click on "Font"
Under "Effects" leave all the boxes as they are (they should appear with a blue square) click on the box for "Supersrcipt" and a "tick" will appear (the "Subscript" box will also become empty automatically)
Place the cursor in "Replace with"
No click "Format" and make sure both the "Superscript" and "Subscript" boxes are empty
So now under "Find what" it should say "Superscript" and under "Replace with" it should say "Not Superscript/Subscript"

Part 2
Now you have to look for "th" "st", "nd" and "rd" and replace them with themselves, so you will have to repeat this step 4 times


[Edited at 2012-06-14 00:09 GMT]


 

John Fossey  Identity Verified
Canada
Local time: 23:24
Member (2008)
French to English
Language of text changes quote type Jun 14, 2012

For straight vs. curly quotes, check the language of the document. I have the opposite problem - I receive documents with French as the default language and all the quotes are curly, as in « ». A regular English quote mark "" will instantly turn into a curly quote until I change the language of the document to English. It gets more complicated if there are text boxes, because the language inside a text box is independent of the language outside the text box.

 

Tony M  Identity Verified
France
Local time: 05:24
Member
French to English
+ ...
Easy peasy! Jun 14, 2012

1) For the ordinals in superscript:

Assuming there are no WANTED superscripts in your text, then just 'Select all', apply the 'superscript' attribute (Ctrl D for Font...), and then unapply it; this should get rid of all supserscript in the document.

If, of course, you DO have wanted superscripts (or subscripts for that matter) in your document, then you'll have to do it the long way using Ctrl H and then 'st' 'th', 'nd', and 'rd'. However, if there are only a few subs / supers, and you know what they are, it might be quickest to simply put those back manually afterwards. CO2 being a common one; and note that there are even special characters for ² [Alt + 0178] and ³ [0179] — so if you have loads of m² etc. in your doc. it might be worth going through and doing those replacements globally first [^2 > Alt 0178, etc.]


2) For the 'typographic' quotes:

Use Ctrl H (search & replace > all), making sure you have first turned ON 'fancy quotes' under Tools > Autocorrect options > Correct as you type, and then just replace all " with " (and if necessary ' with ') — magically, all the quotes in your doc will be replaced with the other kind (i.e. according to the option you have set under Autocorrect)

Note, however, that this trick bugs if you try doing it between different languages, e.g. FR and EN; there, I've had nightmares trying to do the same thing, regardless of global / document language settings icon_frown.gif

[Edited at 2012-06-14 05:35 GMT]


 

wotswot  Identity Verified
France
Local time: 05:24
Member (2011)
French to English
Try this Jun 14, 2012

http://www.wot.fr/get.php/WOTT-ReplaceBasics.zip

These macros should save you a lot of time (designed for French and English single/double/straight/curly quotes, but you can adapt the code to your needs).


 

Susan Welsh  Identity Verified
United States
Local time: 23:24
Member (2008)
Russian to English
+ ...
TOPIC STARTER
Thanks Jun 14, 2012

Thanks everybody. I was successful for the superscripts, which is terrific. I have not yet experimented with the curly quotes, because somehow or other last night I managed to wrestle them into shape for this particular document. (I think I did it in Libre Office, where it was easier, but honestly I don't remember.) I will report back when I've had a chance to try your various methods.

 

Susan Welsh  Identity Verified
United States
Local time: 23:24
Member (2008)
Russian to English
+ ...
TOPIC STARTER
@wotswot Jun 16, 2012

I tried your macro, but there is a bug in it. It gets the spacing wrong, although it gets the straight>curly quotes right:
blah blah "word" blah blah
becomes
blah blah blah "wordb "lah blah


 

wotswot  Identity Verified
France
Local time: 05:24
Member (2011)
French to English
@Susan Welsh Jun 16, 2012

Thanks for the bug report Susan. I'll fix it when I have a mo' (you can too if you want because you have the code)

Richard


 

Susan Welsh  Identity Verified
United States
Local time: 23:24
Member (2008)
Russian to English
+ ...
TOPIC STARTER
code? Jun 17, 2012

I'm afraid that code is pretty much "Greek to me"!

I'd be much obliged if you'd re-post it when you get a chance to fix it.


 

wotswot  Identity Verified
France
Local time: 05:24
Member (2011)
French to English
@Susan Jul 25, 2012

Hi there,

Having some time on my hands, I'm trying to reproduce the bug you reported (wrong spacing when you run my "straight to curly" quotes macro). Could you please tell me exactly which menu option you are using? Is it "Convert straight quotes to curly (single/double, English only)"? If so, do you then click the fourth button (Double Straight to Double Curly)? I've tried with your example (copying blah blah "word" blah blah a hundred times then running the above), it works perfectly.

Could you perhaps give me some more meaningful sample text that definitely causes this bug in your Word? (2010? 2007? 2003?)

Thanks in advance

Richard


 

Susan Welsh  Identity Verified
United States
Local time: 23:24
Member (2008)
Russian to English
+ ...
TOPIC STARTER
@Richard Jul 25, 2012

Naturally, I can't reproduce it either now.icon_frown.gif
I ran a test (saved message in Word 2010, .docx, ran macro "Convert straight quotes to curly quotes (single/double, English only)" on your message to me just now, and got the following results:

EXTRACT: Having some time on my hands, I'm trying to reproduce the bug you reported (wrong spacing when you run my “straight to curly” quotes macro). Could you please tell me exactly which menu option you are using? Is it “Convert straight quotes to curly (single/double, English only)" ? If so, do you then click the fourth button (Double Straight to Double Curly)? I've tried with your example (copying blah blah “word” blah blah a hundred times then running the above), it works perfectly.
END EXTRACT

As you can see, the first instance works fine; the second instance converts the open quote to curly, but not the close quote; and the third instance is fine.


Then I ran some tests on some other files:
.doc files created by someone else, presumably in Word 2003 or earlier:
Convert straight to curly, SINGLE quotes: The close quotes were okay but the open quotes were still straight.
Convert curly SINGLE to straight: nothing happened.
Convert curly DOUBLE to straight: It made the double close quotes into single straight quotes! The open quotes came out right.

.docx files that were made from .doc files (I do this for my CAT tool, which doesn't support .doc format but does support .docx):
Convert straight SINGLE quotes to curly: The close quotes are okay, the open quotes are still straight.


If I come up with anything more, I'll post again.
Thanks for trying to help!
Susan


 

Susan Welsh  Identity Verified
United States
Local time: 23:24
Member (2008)
Russian to English
+ ...
TOPIC STARTER
A MUCH easier way Sep 1, 2013

For the record, for anyone who reads this old thread in the future:

There is a much easier way to replace straight quote marks with curly quotes:
Open the document in MS Word. Find and replace " with " and ' with ' -- that's right, they are both the same. Assuming your Word options are set for curly quotes as default, all the quotes will come out curly. Thanks to Didier Briel for this.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

MS Office 2010: how to get rid of superscript ordinals and replace straight quotes with curly quotes

Advanced search






BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search