Word 2010: "Do not check spelling or grammar" keeps getting checked.
Thread poster: Michael Joseph Wdowiak Beijer

Michael Joseph Wdowiak Beijer  Identity Verified
United Kingdom
Local time: 01:08
Member (2009)
Dutch to English
+ ...
Oct 4, 2012

In Word 2010, "Do not check spelling or grammar" keeps getting checked, which means that I have to keep going into language settings and un-checking it if I want to spell-check documents.

Is there any way to make sure that it always stays unchecked?

Michael

[Edited at 2012-10-04 19:56 GMT]


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 02:08
Member
French to English
+ ...
Mixed languages? Oct 4, 2012

I have found in Word 2003 that this box is checked (or greyed) by default if there are multiple languages within a document. Don't know if that might be the case for you too?

Direct link Reply with quote
 

neilmac  Identity Verified
Spain
Local time: 02:08
Spanish to English
+ ...
I don't know Oct 4, 2012

... but I hope someone does and posts the answer here!

I'd also like to know why when I select UK English in the spellchecker it often reverts to US English. These are really annoying little bugs which could surely be fixed if MS spent a little time on them instead of rushing out new, yet still unsatisfactory versions.

Another similar issue I have with the Office spellchecker is that when parts of a text have been classed "Do not check" (perhaps by a previous user of the document) I can never manage to undo them...

I also have problems when the original document has been created or processed on a Mac. I find I'm unable to add dictionary items when checking these documents too.

[Edited at 2012-10-04 20:17 GMT]


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 02:08
Member
French to English
+ ...
Not sure, but... Oct 4, 2012

The US / UK thing might be to do with what your default language for text entry is? I had quite some trouble finding this setting buried in the Windows settings, and needless to say, everything defaults to US and makes it quite hard to change it.

For the other language / spell check issues, this has been discussed before, I've had similar problems too.

Before I start working on a document, I always 'Select all' and change the language globally to my target language; this seems to get rid of most problems and purge odd rogue codes that may be lurking...

HOWEVER, if some of the styles in your doc have been configured to specify the language, I don't believe changing the language globally will work on text in those styles; if this is indeed true, then you might have to edit those styles, once you can find them! I guess the same thing might also be true for the spell check parameter, though I've never actually investigated that issue.


Direct link Reply with quote
 

Michael Joseph Wdowiak Beijer  Identity Verified
United Kingdom
Local time: 01:08
Member (2009)
Dutch to English
+ ...
TOPIC STARTER
@Tony + Neil: Oct 4, 2012

Re: the default language problem: every time I start working on a new document, I use 'LangID' in CodeZapper to do this.

From the CodeZapper .dot file info section:
LangID: Set language throughout document (all story ranges). Enter the LanguageID code in the input box displayed: 1036 = French, 1043 = Dutch, 1033 = EnglishUS, 2057 = EnglishUK, 1036 = Spanish, 1031 = German, 1040 = Italian, 1053 = Swedish, 1041 = Japanese, 1038 = Hungarian, 1037 = Hebrew, 1032 = Greek, etc. See:
http://msdn.microsoft.com/en-us/library/bb213877.aspx

DefLang: Sets the default wdlanguage code. As shipped, the default language is French (1036). You should change this setting to your source language before running CZ.

Michael


[Edited at 2012-10-04 20:49 GMT]


Direct link Reply with quote
 

Daniel Grau  Identity Verified
Argentina
English to Spanish
This is what's happening Oct 5, 2012

Language, as well as the "Do not check spelling or grammar" flag, are not settings or user preferences—they are both attributes of the text, just like Bold, Underline, Times New Roman, Red or 10-point size. In other words, you should handle it exactly as if you wanted to apply any other formatting attribute to the text.

In fact, if you copy formatting from one segment of text to another, both of these attributes (language and check-enable/disable) will also carry along. If this were any other way, you would not be able to conveniently mix languages in a single document.

Thus, just as if you wanted to apply Arial, you need to first select the text and then apply the two language attributes. If you simply change them without a selection, the change will only be effective at the cursor position.

If your Normal template has been modified and has the wrong language attributes, all your new documents will follow that pattern. You can open Normal.dotm and manually change its contents (or even the language attributes in its Normal paragraph style because, like other formatting attributes, these two can be incorporated as part of any character or paragraph style). Easier still, select some text, select the proper language and spell checking attributes and, before closing the dialog box, click on the "Default..." button to propagate that change back to the Normal template.

By the way, when a text selection contains mixed "Do not check…" attributes, Word does displays an ambiguous check box (neither blank nor selected). Likewise, if the selection contains more than one language, there won't be any language highlighted in the list of languages.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 02:08
Member (2010)
Spanish to English
CodeZapper Oct 5, 2012

Michael Beijer wrote:

Re: the default language problem: every time I start working on a new document, I use 'LangID' in CodeZapper to do this.


Thanks, Michael, that's a great tip. I'd forgotten all about language settings in CodeZapper.

And thanks Daniel, too, for the really clear explanation of how language settings work.


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 02:08
Member
French to English
+ ...
Very true, but... Oct 5, 2012

Daniel Grau wrote:

Language, as well as the "Do not check spelling or grammar" flag, are not settings or user preferences—they are both attributes of the text, just like Bold, Underline, Times New Roman, Red or 10-point size. In other words, you should handle it exactly as if you wanted to apply any other formatting attribute to the text.


Thanks, Daniel, for your very clear explanation!

There's just one thing which still bothers me; it seems to me, from empirical observation within my own (admittedly limited) experience that if the language / spell attributes are set within a style, these may not be reset using a 'select all' modification? I do not know why they should behave differently from any of the other attributes, but it has certainly seemed that way to me in the past.

An example, though not relevant to the present discussion, is the 'comments' style; it is a constant source of irritation to me that the 'comments' language can only be changed by going in and editing the 'comments' style — it does not change using 'select all' in the doc. Ditto headers / footers (though these don't seem to have any specific style?) and also text boxes (again, not one specific style) I wish some kind soul would write an idiot-understandable macro (or plug-in) that would let me globally select or change header/footer, comments, and text box language across the whole document.

At the moment, if I have a document with loads of text boxes, I use Werecat to extract the text, then even if I'm not translating it, I used the extracted doc to change the language and then pop the text back in again. A bit of a palaver, but still a lot quicker than doing lots of them manually!

[Edited at 2012-10-05 05:59 GMT]


Direct link Reply with quote
 

Michael Joseph Wdowiak Beijer  Identity Verified
United Kingdom
Local time: 01:08
Member (2009)
Dutch to English
+ ...
TOPIC STARTER
Hi Tony, Oct 5, 2012

I just read something on the DVX list that might interest you:
'The language in the exported Word file should be set according to your target language, including its national versions, so if it doesn't, and you are sure that your project target language is set correctly, I suggest that you report this as a bug.

Otherwise, CodeZapper is a great tool for setting your language in MS Word, as it sets the language throughout the document, including text boxes, headers and footers, … which otherwise requires more effort if you do it manually.

Setting your language through CodeZapper is just a matter of two clicks.

Vaclav'
(http://tech.groups.yahoo.com/group/memoQ/message/23876 )

Michael


Direct link Reply with quote
 
Mariusz Kuklinski  Identity Verified
Local time: 01:08
Member
English to Polish
+ ...
A related problem May 26, 2016

I am, right now, trying to spellcheck 3000+ words in Word 2010 with the multilingual package. I set the language to Polish using select all but every second or third word it jumps back to either UKENG or USENG. Completely useless.

Direct link Reply with quote
 
Mariusz Kuklinski  Identity Verified
Local time: 01:08
Member
English to Polish
+ ...
And it gets worse May 26, 2016

I changed the default language to Polish. It didn't help. In spellchecking it reverts to USENG and my attempt to persuade it to spellcheck in Polish are simply ignored.

Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 02:08
Member
French to English
+ ...
Similar problem even with earlier versions of Word May 26, 2016

I use Word XP, and even in that, I have just occasionally encountered similar problem, which seemed to be document-specific. This has been discussed in the fora before, but I don't recall what if any solution was suggested.

In my case, it was doubly annoying, as the language it reverted to was a R-to-L one, so every so often, as I was typing, I'd find myself going backwards!

I deduced that it was possibly due to 'rogue' language codes left embedded in the text, which for some reason 'Select All' was failing to find; I suspect this is more common than we realize, since I often notice certain attributes (like 'Do not check speling or grammar') reappearing for no apparent reason during a document.

I don't know if it will work, but you might try doing something that would forcibly remove the language attribute, like (possibly?) convert the file to RTF and back again? Or use the 'remove all styles' tool (if there's not too much use of styles in your doc?) — or even, at worst, saving out as text and back in again (requires total manual reformating, of course!)

I'd be very interested to know if you find a solution!


Direct link Reply with quote
 

Michael Joseph Wdowiak Beijer  Identity Verified
United Kingdom
Local time: 01:08
Member (2009)
Dutch to English
+ ...
TOPIC STARTER
CodeZapper's "LangID" May 26, 2016

I'm on Word 2016 by now, and continue to "solve" the problem with CodeZapper:

every time I start working on a new document, I use "LangID" in CodeZapper to do this.

From the CodeZapper .dot file info section:
"LangID: Set language throughout document (all story ranges). Enter the LanguageID code in the input box displayed: 1036 = French, 1043 = Dutch, 1033 = EnglishUS, 2057 = EnglishUK, 1036 = Spanish, 1031 = German, 1040 = Italian, 1053 = Swedish, 1041 = Japanese, 1038 = Hungarian, 1037 = Hebrew, 1032 = Greek, etc. See:
http://msdn.microsoft.com/en-us/library/bb213877.aspx

DefLang: Sets the default wdlanguage code. As shipped, the default language is French (1036). You should change this setting to your source language before running CZ."


Michael


Direct link Reply with quote
 
Mariusz Kuklinski  Identity Verified
Local time: 01:08
Member
English to Polish
+ ...
Not much help from MS for Office 2010 Multilanguage Pack problems May 26, 2016

I chatted with MS support, their advice was very unspecific. They advised me to install all Service Packs for both Office and the Multilanguage Pack (!!!) and invited me to subscribe to their paid support service, £65 per incident or £95 for an unlimited support over a year. They were not particularly impressed whey I told them I expected their software not to fail on its very first use.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Word 2010: "Do not check spelling or grammar" keeps getting checked.

Advanced search






PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search