Part of table not visible in MS Office 2007 Landscape Mode
Thread poster: Maria Dimitrova

Maria Dimitrova  Identity Verified
Bulgaria
Local time: 08:44
Member (2011)
Bulgarian to English
+ ...
Apr 18, 2013

Hi,

I have been struggling with some bug in MS Office and I though that maybe someone may help me work around this problem.

I had to translate several tables in excel (financial statements), but the client wants them pasted in Word afterwards, because they have to be a certified translation and so the translation must be in word to be able to put a header.

Since the tables are too wide, I changed the Page setup option in word to Landscape. However, when I paste the excel table, the only visible part of it is the one that would fit into a Portrait page.

Can anyone help me with info what settings should I change in order to be able to paste those tables properly?

Thank you in advance.


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 07:44
Member
French to English
+ ...
Similar problem in Word XP Apr 18, 2013

I have experienced a similar problem in the earlier Word XP; I found that once I had pasted the too-wide table, even changing the page layout to 'landscape' didn't bring back the missing part of the table. Part of the solution seemed to be to set the page layout to landscape BEFORE pasting; however, even then, some tables are just too wide for the paper size.

I found that by switching to 'Normal' view instead of the 'Page layout' view that one 'normally' uses (!), I was able in effect to have an 'infinitely wide' page, and so my table was visible, albeit by scrolling across to see it all; or of course, reducing the % zoom to reveal it all (but at that point, it is usually too small to be legible).

I don't know quite how all this works in W 2007, but I suspect the latter solution may well be what you need.


Direct link Reply with quote
 

Maria Dimitrova  Identity Verified
Bulgaria
Local time: 08:44
Member (2011)
Bulgarian to English
+ ...
TOPIC STARTER
Still doesn't work Apr 18, 2013

Thanks Tony, I tried what you said - changing the page setup before pasting and then switching to normal view, but the problem persists. I don't know, maybe I will have to draw tables manually and paste the translation((

Direct link Reply with quote
 

felicij  Identity Verified
Local time: 07:44
German to Slovenian
+ ...
You might try Apr 18, 2013

and adapt the table layout to fit the window.
Simply select the whole table (+ in upper left corner), right click on it, select Autofit and then Autofit to Contents or Autofit to Window. It works on every table for me...


Direct link Reply with quote
 

Maria Dimitrova  Identity Verified
Bulgaria
Local time: 08:44
Member (2011)
Bulgarian to English
+ ...
TOPIC STARTER
I already tried that Apr 18, 2013

Yes, I tried that, but it still fits within the space that would be for a portrait setup and some tables are really wide, so it turns out that the column names appear one letter over the other to fit.

Direct link Reply with quote
 

felicij  Identity Verified
Local time: 07:44
German to Slovenian
+ ...
well in that case Apr 18, 2013

I don't think you can do anything else but to reduce the font size.

Direct link Reply with quote
 
Alan Douglas  Identity Verified
France
Local time: 07:44
A possible work-around: Apr 18, 2013

Change column widths in Excel document(s) so that the full width of the table fits onto an A4 sheet.
Change margin sizes to minimum and orientation to horizontal to allow yourself as much space as possible on the page. Ensure that text cells are set to automatic multi-line (you may have to adjust line height if some of the text dissapears).
Gradually reduce the width of text columns until the full width of the table is to the left of the vertical dotted line. An additional option would be to reduce the standard font size (9 pt) is still legible in table format. Check on the pre-print view that the full width appears on the page and that no text has been lost.

Open a new Word document. Change margin sizes to minimum and orientation to horizontal. Now copy and paste in the Excel table.


Direct link Reply with quote
 

Rolf Keller
Germany
Local time: 07:44
English to German
There are 2 methods for inserting content from other sources Apr 18, 2013

Maria Dimitrova wrote:

I paste the excel table


The very first question: HOW do you paste? Via the clipboard oder via Insert/Object/MS Excel Sheet/From file? (I'm not sure about the English menu descriptions in your Word.)


Direct link Reply with quote
 

Maria Dimitrova  Identity Verified
Bulgaria
Local time: 08:44
Member (2011)
Bulgarian to English
+ ...
TOPIC STARTER
Things turned out to be not that bad Apr 18, 2013

Alan, felicij , thanks for your input, the problem is the excel tables are already 9 pt and some of them are so wide, that even reducing the font size to 6 pt will not make the table fit into a portrait orientation.

Rolf , I tried simple Copy-paste, then I tried the Paste special option and selected "MS Excel object", still no difference.

However I found a partial solution to the problem, I printed several pages of the ones that do not look properly and actually the entire table was printed on the sheet of paper, even though in word it seems "eaten". Probably this is some bug in the "View" options. It's a pity I didn't try this earlier...

Thanks everyone for your input!


Direct link Reply with quote
 

Tina Vonhof  Identity Verified
Canada
Local time: 23:44
Member (2006)
Dutch to English
+ ...
Landscape Apr 18, 2013

Maria Dimitrova wrote:

Alan, felicij , thanks for your input, the problem is the excel tables are already 9 pt and some of them are so wide, that even reducing the font size to 6 pt will not make the table fit into a portrait orientation.


I think you should have both documents in landscape (horizontal) orientation.


Direct link Reply with quote
 

Germaine  Identity Verified
Canada
Local time: 01:44
Member (2005)
English to French
+ ...
Go to the table properties Apr 18, 2013

This is how I do it, once I copied-pasted (Ctrl-C, Alt-Tab, Ctrl-V) the table in Word:

1. Click anywhere in the table. Right-click and select « Table properties… ».
2. Under the Table tab, check “Preferred Width”; for “Measure in”, select “Percent”, enter 100% and click ok.

The table will instantly fit between the margins of the page. Then you may adjust the font and if necessary, column sizes.


Direct link Reply with quote
 

Alex Lago  Identity Verified
Spain
Local time: 07:44
Member (2009)
English to Spanish
+ ...
Why not use Excel? Apr 19, 2013

If the only reason you want it in word is because you need a header why don't you just simply put a header into the Excel file?

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Part of table not visible in MS Office 2007 Landscape Mode

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search