Word 2010 spellchecker has to be turned on for every document
Thread poster: Susan Welsh

Susan Welsh  Identity Verified
United States
Local time: 17:57
Member (2008)
Russian to English
+ ...
Oct 13, 2013

My spellchecker for Word 2010 does not "stay on" from one document to the next. I have to turn it on, at File > Options > Proofing > tick Check spelling as you type - every single time. The language settings are correct (English U.S. on both Word and my Windows 7 OS).
I've been fixing this manually for every document for the past year, but it is driving me crazy, and I find nothing helpful online. There must be some "secret" place where this information is hidden!

Thanks for any help,
Susan


Direct link Reply with quote
 

Flavio Granados  Identity Verified
Venezuela
Local time: 18:57
Member (2006)
English to Spanish
references Oct 13, 2013

Hi Susan,

Maybe these references will help you.

http://wordfaqs.mvps.org/MasterSpellCheck.htm

http://office.microsoft.com/en-us/word-help/turn-on-automatic-language-options-HA010354274.aspx

Regards,

Flavio


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 17:57
Member (2008)
Russian to English
+ ...
TOPIC STARTER
To Flavio Oct 13, 2013

Thanks, but these references contain all the things I tried already (I had seen the first reference).

Direct link Reply with quote
 

Rolf Keller
Germany
Local time: 23:57
English to German
normal.dotm is your friend Oct 13, 2013

Susan Welsh wrote:

My spellchecker for Word 2010 does not "stay on" from one document to the next. I have to turn it on, at File > Options > Proofing > tick Check spelling as you type - every single time.


Close all documents. Afterwards, open normal.dotm, adjust any desired default setting(s), then close&store normal.dotm.

http://www.ehow.com/how_8747578_change-normaldotm.html


Direct link Reply with quote
 

Flavio Granados  Identity Verified
Venezuela
Local time: 18:57
Member (2006)
English to Spanish
Styles, templates Oct 13, 2013

The problem could be in your style or template.

Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 17:57
Member (2008)
Russian to English
+ ...
TOPIC STARTER
normal.dotm Oct 13, 2013

Rolf Keller wrote:

normal.dotm is your friend


Thanks, Rolf, this is very good to know. The link you gave is for Word 2007; this one is also for 2010:
http://www.speakeasysolutions.com/blog/2009/11/26/modifying-word-2007-normal-dotm-template/

My existing normal.dotm already has "spellcheck as you type" ticked, so there was nothing to change. But when I created a new document and copy/pasted one of my uncooperative files into it, it worked. So I'll have to see how it goes with new files and editing of old files. I'll report back after some more testing.


Susan


[Edited at 2013-10-13 18:31 GMT]


Direct link Reply with quote
 

Tina Vonhof  Identity Verified
Canada
Local time: 15:57
Member (2006)
Dutch to English
+ ...
Another way Oct 13, 2013

Go to File - Options - Proofing and check Spell check as you type (in Word 2010). This setting will stay from one document to the next until you turn it off. In fact, when you type your (English) translation directly into the source document, your entire source document may get 'flagged' and you may have to temporarily change the setting off.

Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 17:57
Member (2008)
Russian to English
+ ...
TOPIC STARTER
to Tina Oct 13, 2013

Thanks, but no, that was my whole point -- that "normal" method doesn't work!

Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 17:57
Member (2008)
Russian to English
+ ...
TOPIC STARTER
problem persists Oct 17, 2013

Now that I'm back working on relevant jobs, I find that the problem persists (which makes sense, since the normal.dotm already was set for "check spelling as you type"). I have a document that WILL NOT submit to spellcheck, no matter what I do ("recheck document" in options didn't do it).


I found this:
http://www.mockbox.net/office-2010/309-word-2010-spell-check-not-working
which led me to the discovery that my language setting for U.S. English is "do not check spelling." When I uncheck that box, it still doesn't work and says the spelling and grammar check is done. I look back at it again ... and the language setting is back to "do not check spelling"!!

I am really baffled.




[Edited at 2013-10-17 13:53 GMT]


Direct link Reply with quote
 

Rolf Keller
Germany
Local time: 23:57
English to German
More ideas Oct 17, 2013

Susan Welsh wrote:

I have a document that WILL NOT submit to spellcheck, no matter what I do ("recheck document" in options didn't do it).


Maybe the doc's formatting is the culprit. Have a look at this:
http://www.proz.com/forum/office_applications/234338-word_2010:_do_not_check_spelling_or_grammar_keeps_getting_checked.html#2028043 (Daniel Grau)

Idea 2: The doc might have been created with a different version of Word. Save the doc with "Save As ...", so that it will be converted to your version.

Idea 3: Docs and templates can contain macros, and macros can secretly change most settings. Not very probable, though.


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 23:57
Member
French to English
+ ...
As Rolf said... Oct 17, 2013

Rolf Keller wrote:
Maybe the doc's formatting is the culprit.


We've had similar issues before, though often with only parts of a text. If the styles used specify language attributes, these might well specify 'do not check spelling or grammar' — and for some reason, these internal style settings seem to over-ride the user's own global settings; don't ask me why or how!

It might be worth checking out one at least of the styles used in the document (but that is not native to the normal.dot template), and see if this is the case; if it is for one, then it is quite likely it will be for the others too, as they might all originally have been created from the same user template.


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 17:57
Member (2008)
Russian to English
+ ...
TOPIC STARTER
What Microsoft said... Oct 17, 2013

I finally located a human being at Microsoft, who convinced me to buy a $149 support package for one year in exchange for trying to fix my problem.
At first he thought it might be a registry issue, but it wasn't.
Then he asked whether the documents had been created by me or sent to me by someone else. The answer is, almost invariably these are documents that I have translated into English that were sent to me by someone else who wrote them in German or Russian. I take a .docx file, feed it into my CAT tool, OmegaT, translate it, and get a .docx at the other end.
What he said is that the source document must have used a spellchecker native to that language, and it has been embedded in the file and then gets transferred via OmegaT into the target file.

We found that if I SELECT a paragraph from my German translation into English, adjust the language setting to English, with "do not check spelling and grammar" unchecked, it will successfully mark typos in that selected portion. With Russian, however, it did not mark them, but did find them when I ran a spellcheck by hitting F7.

So, not very satisfying, but at least it works. This means that I can edit my files outside the CAT tool, which I always find useful because CATs make you think in segments rather than concepts.

Thanks for your help, everybody. I will look into your various links and see if anything better turns up.

PS - I just found that if I create a NEW Word document and copy/paste the target text into it, then fix the language/spellcheck definitions, it works like it is supposed to.

Whew!


[Edited at 2013-10-17 21:32 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Word 2010 spellchecker has to be turned on for every document

Advanced search






BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search