Help please with Arabic on Windows 10: .pdf and .docx jumbled
Thread poster: Dan Mackey

Dan Mackey
United States
Local time: 00:57
Member (Feb 2017)
Arabic to English
Mar 21

I have a specific document in two formats, .pdf and .docx, that I cannot open without it being jumbled in either Adobe or Microsoft Word. I also tried numerous different PDF viewers like Foxit. I also tried Google Docs.

I can and do open Arabic .docx files all the time and have translation experience but i am confused about this particular file because I sent it to a colleague and he was able to open it fine.

I would be forever grateful if someone could talk me through a troubleshooting so as to avoid this in the future.


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 00:57
Member (2002)
English to Hungarian
+ ...
A few ideas to try Mar 21

The problem may be the font type. Have you tried changing the font of the document to an Arabic font in Word? Maybe you need to get the specific font the document uses.

If not, you may have some encoding issues. (Although I doubt it, as current versions of Adobe and Word should be Unicode-compatible.)
In Windows 10, try this:
Open up the Windows Settings panel and select Time & language.
Go to Region & Language, and check if you have Arabic among your languages (I assume you do, but just to make sure.)
Next, scroll down and click on Additional date, time, & regional settings. This will bring up the Clock, Language and Region panel. Click on "Change location" under Region.
In the Region panel, click on the third tab called "Administrative".
See what you have set for "Current language for non-Unicode programs". Try setting it to Arabic.
To do that, you need to click on "Change system locale..."
You will need to reboot your computer after this, to take effect.
Then try opening your document again.

If it did not help, then you may want to go back and change the non-Unicode language setting to whatever you had before (perhaps English), and reboot again.

Sorry if it did not help...
Katalin


Direct link Reply with quote
 

Dan Lucas  Identity Verified
United Kingdom
Local time: 05:57
Member (2014)
Japanese to English
Agree with Katalin Mar 22

Katalin Horváth McClure wrote:
See what you have set for "Current language for non-Unicode programs". Try setting it to Arabic.

Dan - having recently moved to a new PC I was wondering why I was getting similar problems with certain documents and it turned out that I had not yet made the "non-Unicode" adjustment. So I would try that first.


Direct link Reply with quote
 

Dan Mackey
United States
Local time: 00:57
Member (Feb 2017)
Arabic to English
TOPIC STARTER
Thanks but did not work Mar 22

I tried but it did not work.

Thank you for the excellent instructions. Very clear and I followed all steps exactly but to no avail. The saga continues...


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Help please with Arabic on Windows 10: .pdf and .docx jumbled

Advanced search






Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search