Any way to override block on spell checking?
Thread poster: Kim Metzger

Kim Metzger  Identity Verified
Local time: 19:39
German to English
Jul 21, 2005

I'm using MS Word 2002 and typing over text in a document sent to me by my client. When I finished the translation and wanted to do my regular spell check I got this message:

"The spelling and grammar check is complete. Text marked with 'Do not check spelling or grammar was skipped.'"

Does anybody know how to override this block? Thanks in advance for your suggestions.

[Edited at 2005-07-21 03:25]


Riccardo Schiaffino  Identity Verified
United States
Local time: 18:39
Member (2003)
English to Italian
+ ...
One way is to first select all the text you need to spell-check... Jul 21, 2005

...then go to the Tools menu, then Language, and then Set Language. You'll get to the Language dialog. In this dialog you can select which language to apply to the selected text, and whether to spell check or not the selection.

If you are using a translation memory tool (like Trados) which gives different colors to the different segments (e.g. blue for the source language and dark green for your translation), you can also use the search and replace formatting function of MS Word to selectively apply language settings to the various kinds of segments:

1) In the Edit menu select Replace
2) In the Replace dialog, with your cursor in the Find What box, Clic on the More button
3) Clic on the Format button
4) Clic on Font
5) In the Find Font dialog, clic on the Font color drop down list and select the color used in the translated segments
6) Clic OK
7) Back in the Replace dialog, clic on the Replace with box, then click on the Format button -> Font - > Font color, and select for the replace the color used in the translated segments
8) Click OK
9) Click again on the Format button
10) Click on Language
11) Select your language and remove any check mark in the "Do not check spelling or grammar" checkbox
12) Click OK

At this point You are back in the Replace dialog. Clic on "Replace All", and Word will replace all the segments which had the color used for the target language, with the same color, and indication to use your language and to spell check that text.

[Edited at 2005-07-21 03:48]


Cilian O'Tuama  Identity Verified
Local time: 02:39
German to English
+ ...
Tools/Language/... Jul 21, 2005

Kim Metzger wrote:
"The spelling and grammar check is complete. Text marked with 'Do not check spelling or grammar was skipped.'"


[Edited at 2005-07-21 03:25]

Hi Kim, I've checked a Word 2003 version, but maybe the terminology has remained the same.

Select the text block in question, then go to Tools/Language/Select Language and untick the box titled "Do not check spelling or grammar".

That should do it.


[Edited at 2005-07-21 08:40]


Ken Cox  Identity Verified
Local time: 02:39
German to English
+ ...
you can also search for text marked 'do not check spelling' Jul 21, 2005

Open the Find or Find/Replace window.
Click on More.
Click on Format.
Click on Language.
Enable the 'Do not check spelling or grammar' check box.
Click OK

Make sure the search field is empty, and then click on Find or Find Next.

In many cases, text is marked 'Do not check spelling or grammar' because it would be pointless to do so.


[Edited at 2005-07-21 11:29]


Elena Miguel  Identity Verified
Local time: 02:39
English to Spanish
+ ...
I'm having a similar problem of late Jul 21, 2005

Apparently, the spellchecker for English is properly set up for Word but when I try to check the spelling of an English document, I get the following message "Tag protection ON!" on the lower bar and Word does not detect any misprint (even if I make mistakes "on purpose").
Unfortunately, nobody has been able to help me to solve this problem, which in principle seems to have to do with Trados even if I experience the same problems when I try to check the spelling of documents which have not been translated with any CAT tool.
I add this remark just in case somebody reads this and can help me to...


To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

Any way to override block on spell checking?

Advanced search

SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »

  • All of
  • Term search
  • Jobs
  • Forums
  • Multiple search