Problem with Smart Quotes / languages in Word XP
Thread poster: Tony M

Tony M  Identity Verified
France
Local time: 08:08
Member
French to English
+ ...
Sep 26, 2006

I've come across an occasional problem that is irksome, and can't seem to find the solution.

If I get a document that was originally created in French (with the language set to French), and then want to work on it for my English translation, I can of course go in, 'select all', and set the language to English. No problem! And from that point on, when I type quotes, they come out as correct English quotes (I have the 'Smart Quotes' option turned on)

HOWEVER... if I perform a 'search-and-replace' — for example, to convert previous un-smart quotes into smart ones — the quotes it replaces with are French ones («...»), and I cannot find any way of stopping this.
It does not happen if 'smart quotes' are turned off, but of course that defeats the object!

I assume the 'search' facility has got 'stuck' in its original language, but does anyone know how to get round this?

Thanks, in advance, for any tips

[Edited at 2006-09-26 19:38]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 08:08
Member (2003)
Polish to German
+ ...
Have you set the language in the styles to your target language? Sep 26, 2006

Ist the automatic language recognition switched out?

Should the language in the styles still be French, than you have your reason.
Is the automatic language recognition on, Word sees what is in French and acts accordingly.

Regards
Jerzy


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 08:08
Member (2004)
English to Slovenian
+ ...
Check the other Tab in AutoText Sep 26, 2006

if I perform a 'search-and-replace' — for example, to convert previous un-smart quotes into smart ones — the quotes it replaces with are French ones («...»), and I cannot find any way of stopping this.


Could it be that checkbox in AutoFormat? - first entry in "replace" - something like "replace straight quotes with typographic".

I never figured out those quotes anyhow, so pls ignore if Im barking up the wrong tree.

Regards

Vito


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 08:08
Member
French to English
+ ...
TOPIC STARTER
Styles with language set were indeed the problem Sep 26, 2006

Jerzy Czopik wrote:

Should the language in the styles still be French, than you have your reason.


Thanks, Jerzy — got it in one!

I thought the standard 'Normal' style was language-free, so I didn't even think to check there... but that's the problem OK.

Thanks a lot for your help, and also to Vito for your contribution — yes, I had checked that, but it didn't make any difference


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem with Smart Quotes / languages in Word XP

Advanced search






BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search